Jump to content
The Dark Mod Forums

Search the Community

Showing results for tags 'particles'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Ever since I worked on "Chalice of Kings" with Bikerdude, I have wanted to get flame particles with new particle glares into the core mod. My reasoning was that the candles have glares and the un-glared torches look mismatched. This proposal was met with mixed reactions, so (knowing the history of TDM feature proposals...) I have created a technical demo. You may download it here: zzz_flameglare.pk4.txt (fixed) Just rename without the .txt extension at the end and place it in your Darkmod directory. Here are some screens. Using particles for this is probably the wrong way to go now that Duzenko has an emissive light feature in his branch: http://forums.thedarkmod.com/topic/19659-feature-request-emissive-materialsvolumetric-lights/
  2. I have a tracker action to make one-shot particles controllable by triggering ( previous discussion ). I want to check briefly how people think they should work. Particles that cycle for ever can be turned on and off by triggering the func_emitter. When you restart them by triggering, they start up again with random timing so that you can trigger two or more of the same type at the same time, and the particles won't look identical or move in sync with one another. What you can't do using the current system is trigger one-shot particles, because the random timing usually means they don't show up at all (see prev discussion for details). So you can't have a puff of smoke come out of a sewer when the door is opened, or a bunch of sparks shoot out of a rusty lever or button when used. Not easily, anyway. I've fixed that up in my test build so that when triggered "off" the particle does nothing, when triggered "on" it fires. But after trying it in a test map, I think the better way to handle one-shot particles would be to have them always fire when triggered. After all, once they've fired they stop doing anything and they look "off" anyway. I can't think of any reasons we'd want to distinguish between "on" and "off" for particles that don't carry on puffing away forever. The only possible reason I can think of is, if the particle lasts a long time before stopping, you might want to trigger it off before it finishes. I haven't thought of any realistic situations though. Does anyone think that it needs a spawnarg? Or should we just have one-shotters always fire when triggered?
  3. Hello there. I started playing with TDM yesterday evening and after viewing the tutorial mission and playing through Tears of Lucia, I've got to say I'm rather impressed. I won't go into any sort of glowing praise for the game here (though you guys do deserve it), but I did want to point out that I've experienced an issue on my setup in regards to the way torches, water, and other reflective surfaces (such as health potion vials) appear in the game. I'm assuming the issue is mostly on my end, but regardless here's what I'm seeing with torches while playing: With water: All of this appears to be some re-rendering of the player's view on top of the particles or surfaces involved, but they're being displayed incorrectly on my setup (thought thankfully this is the only bug I've encountered so far). If this is an effect that could have a configuration setting tied to it to toggle it on and off, that would be fine for me and anybody else who may be having this problem. Otherwise, hopefully this feedback is somewhat helpful, even if it is an uncommon bug. I've enjoyed the game tremendously so far, and I hope that making it standalone at its current state draws a lot of attention. Goodness knows the hardcore stealth genre could use a bit more attention. My computer stats are: -Macbook Pro -Nvidia GeForce GT 650M -16 GB RAM -500 GB SSD I'm running TDM through a Parallel's Windows 7 virtual machine that routes jobs to the graphics processor quite quickly from what I can tell, so performance isn't much of an issue here in light of the goofy configuration.
×
×
  • Create New...