Jump to content
The Dark Mod Forums

Search the Community

Showing results for tags 'windows'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 6 results

  1. http://www.computerweekly.com/news/450418770/Businesses-urged-to-apply-Windows-patch-to-avert-WannaCry-attacks OK this is aimed at businesses but I doubt wannacry cares who owns the system it encrypts If you are at all concerned the tl;dr is you need the MS17-010 patch on your system, if you use windows update you should get it automatically, not everyone keeps their systems up to date though You can check the details on the Microsoft site here https://technet.microsoft.com/en-us/library/security/ms17-010.aspx
  2. Okay, so while I fix up my Linux box, I tried playing TDM on my Windows 7 laptop. It installed well and ran great for about 30 minutes. However, for some reason, no matter what mission I play, it eventually crashes. I am not able to determine exactly why it crashes, and it may not even be the fault of the game, but I just want to rule that out. It also seems to crash more often after I have played the game for a while, continually reloading it (when all temps are up). For example, it will run initially for about 20-30 min, then crashes. Then I reload the game, then will crash again in about 5-10 min. Repeat. I am ruling out overheating simply on the basis that the system monitor never shows the CPU above 40% load. The video card, however, may be working harder, but I could not find a default windows system tracker for video card load %. The only thing I can think of is that there may be a conflict between the discrete graphics and on-board graphics cards installed on the laptop. Would it be beneficial to disable one of them? Will that upset windows at all? Please let me know if more details are needed, as I really don't have any error windows other than the "windows is closing this now because it won't respond" window. Thanks!! Here are some system specs: Dell Latitude E6540 OS: Windows 7 Pro SP1 Processor: Intel® Core™ i5-4300M CPU @ 2.60GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s) Display(discrete card): AMD Radeon HD 8790M (2GB VRAM) Display(onboard): Name Intel® HD Graphics 4600 (2GB VRAM) RAM: 4GB PS - I ran TDM for over a year, problem free, on an older Dell laptop. However, it was a company laptop and it was property to a department that I don't belong to any more. So, they gave me this great new one, for all the good it does me now.
  3. I'm using the Logitech G930 7.1 Surround Sound headset and can't get the game to recognise it. When I click the Surround Sound setting I get this message: "UNABLE TO LOCATE 3D AUDIO - SURROUND SPEAKERS NOT FOUND - MAKE SURE THE SPEAKER SETTINGS ARE CONFIGURED PROPERLY IN THE WINDOWS CONTROL PANEL" A fix for this would be awesome.
  4. What do I need to do to get surround (5.1) sound working? When I click on "STEREO" in the audio settings I get the following message UNABLE TO LOCATE 3D AUDIO Surround speakers not found. Make sure the speaker settings are configure properly in the Windows Control Panel. I believe I have configured my speaker settings properly in the Windows Control Panel. I have attached a screen capture of the error message and the relevant control panel windows. I'm running a Swedish Windows Installation, but I think the images will speak for themselves. The following is printed to the console when I try to change the speaker layout in TDM, and the complete console output is available in the attachments. Shutting down sound hardware sound: hardware reported unable to use multisound, defaulted to stereo sound: STEREO condump_soundFail.txt As can be seen in the console output, I have tried to fiddle around with the s_numSpeakers variable, but I will have to do some more reading and testing before I can say anything conclusive about that. Is this a direction that is worthwhile to explore further? In other threads about audio problems, e.g., http://forums.thedarkmod.com/topic/15121-headset-not-recognized-can-only-play-in-stereo/page__hl__surround__fromsearch__1, there is talk about OpenAL and third-party software installation. Is this required for 5.1 speaker systems? I would prefer to not install anything that would risk breaking other things. I have a 5.1 surround sound setup where audio is passed through the HDMI port of a graphics card to a Onkyo home theater receiver. I get proper 5.1 sound both while playing Skyrim and playing videos with Windows Media Player. System: Windows 7, 64bit NVIDIA GTX 580, driver version 314.07 Onkyo TX-NR609-1 Please ask if you need additional details. // Martin
  5. Hello. I've attached a patch file which is a diff between my local working copy of the trunk and a clean copy of the trunk (latest revision: 5670). This patch brings the following changes, all in one: Support for compiling idLib, TypeInfo, the game DLL and the Engine (EXE) with "Debug Without MFC" and "Release Without MFC" solution and project configurations A fix for the Sys_GetVideoRam function which had a bug on Windows (at least on my dev environment) For the MFC stuff, I have split the _Debug.props into _Debug.props and (the new) _MFCDebug.props (needed to isolate the linking to nafxcwd.lib into _MFCDebug.props alone) split the _Release.props into _Release.props and (the new) _MFCReleaseprops (needed to isolate the linking to nafxcw.lib into _MFCRelease.props alone) excluded from the build a bunch of .cpp files related to editors (which are almost the sole uses of the MFC stuff) for those configurations modified BuildDefines.h for taking into account the NO_MFC defined for not defining the ID_ALLOW_TOOLS define added the GetVideoRam_f function and its companion new console command getVideoRam in Console.cpp (explained below) added the " [Debug]", in case of a debug build, and " [No MFC]", in case of compilation without MFC support, tags in the both the console version string (Console.cpp) and the game window title (win_glimp.cpp) reimplemented the Sys_GetVideoRam function without using MFC's CComPtr, CComBSTR and CComVariant classes; using MSVC's "native" _COM_SMARTPTR_TYPEDEF, _bstr_t and _variant_t macros and types; though I've left the original implementation in case of standard build (using the other configurations) as a better-safe-than-sorry approach (some reference material I looked up for the MFC-free conversion: http://edndoc.esri.com/arcobjects/9.1/arcgisdevhelp/developmentenvs/com/vcpp/SmartTypes.htm - http://msdn.microsoft.com/en-us/library/417w8b3b%28v=vs.100%29.aspx - https://groups.google.com/forum/?fromgroups=#!topic/microsoft.public.win32.programmer.directx.video/f8rscRiEGqw ) I compile and run on a 64-bit Windows 7 using Visual C++ 2010 Express which doesn't ship with the MFC (among other things). Ok, for the Sys_GetVideoRam bug. I know my video adapter (nVidia GT 530) has 2 GB of on-board (DDR3) RAM and, when looking for replacing the MFC-based stuff that function uses, I wanted to have a check that it was doing what it was intended for. Hence, I added the new "getVideoRam" command, 'cause I couldn't get the info from the log file. "qconsole.log" seems to log too late in relation to the primary system analysis performed by the Win32-specific portion of the engine. Instead of getting the expected 2048 (MB) value, I kept getting -2048 thrown at. Negative 2048. After debugging, and looking into some documentation over at the MSDN, I found that's because in Sys_GetVideoRam, the system does return the value through a VARIANT type of which the Int value is taken (which is of INT type), that's a signed integer. Then, it gets divided by "1024 * 1024" (signed as well) and the result is stored in an unsigned int (which is then returned as an int, hum hum). The MSDN states that the "AdapterRAM" property of the "Win32_VideoController" class is to be read/parsed as an UInt32. In the debugger, without any fix, the value after division and storing in the unsigned int was well over in the 4,000,000 range. When printing using common->Printf() and the "%i" format specifier, it would print "-2048". With the "%u": the same value as in the debugger. The fix is simple: retSize = static_cast< unsigned int >(varSize.intVal) / ( 1024u * 1024u ); instead of retSize = varSize.intVal / ( 1024 * 1024 ); After the fix, it reports the expected "2048" value. As a side note, the patch also this coupe of lines: -# Visual Studio 2010 +# Visual C++ Express 2010 I couldn't get rid of them using the diff command. Also, I might have messed up the properties for the Dedicated-related configurations. Sorry about that For the trivia, I had originally bought the Doom 3 BFG Edition pack but only then learned it wouldn't work with TDM. So, after much frustration recompiling some Doom 3 GPL fork (dhewm3 and the vanilla Doom 3 GPL), I've set out to finally buy the original Doom 3 and was relieved to see TDM come to life I hope this patch will be of some use. I know you've got a lot of work for a small team of core (code) developers, so NoMFC-compatibility isn't something you especially need (with a high priority) but I thought I would still contribute this, at least. I've played the tutorial and been playing the Tears of Saint Lucia mission so far. I love all the feel to it. Please pardon if my English is a bit broken in places but I'm not a native English speaker. Edit [2013-01-02]: Can't upload the patch file ("Error You aren't permitted to upload this kind of file"). I've made a pastebin ticket out of it (http://pastebin.com/MSeyRxAe). I hope it won't mangle the file (embedded UTF-8 BOMs and all). If requested, I could still upload the original file to some file/media sharing site. Edit [2013-01-07]: Edited out all the unrelated/useless junk I originally put in.
  6. If you miss turn-based strategy, like MoO2.. we would like to present You our project: an old school turn-based space stretegy - "M.O.R.E." The game is based on "Master of Orion 2" and will have: 3D turn-based spacebattles, 3D galaxy map, 20 races, technology tree with dedicated tech branch to every race spaceships created from predefined blocks by player great music, cutscenes and many many more of unique features! (like Dyson Spheres) For more information, I invite you to visit our project website on kickstarter: http://www.kickstart...e-strategy-game We have over 75% now and we have still 28 more days to go, but we need your support! And our community needs Your support! If You can help us - we will appreciate this. Thank You
×
×
  • Create New...