Jump to content
The Dark Mod Forums
Sign in to follow this  
PranQster

Fan Mission: Samhain Night (v.3 update) by PranQster (2015/08/03)

Recommended Posts

samhain_001.jpg
"Samhain... the festival of the new year, the harvest, the onset of winter, and celebration of the dead.
The pagans who celebrate it are likely dancing around fires in the forest right about now. The Builders see to it that the celebrations don't take place in the city. The townsfolk mostly stay indoors this night.
A good night for me to go looting. I have something special in mind this year... (more)
... (the tomb) houses a large Ruby which nobody has ever been able to steal, though every few years some taffer decides to try...
... I have never been a superstitious man, and nobody in this town has my skills. This year the ruby will be mine. Bugger their stupid curse.
This should be easy. The town is quiet and the cemetery unlikely to have guards or many visitors this night. It should be a simple matter of entering the tomb, prying up the ruby, and leaving."

Download Links:
Samhain --- Version 3

Samhain Night
by PranQster
My second mission, third release
2011 Halloween Contest speed build entry
Version 3 (updated)

Build Time:
v1: 3 weeks, Sept. 18, 2011 - Oct. 09, 2011
v2: 2-3 hours, Oct. 06, 2013

v3: a few hours spread out over 6+months

Credits:
The TDM community

Special Thanks:
Nosslak for the plague mask and Springheel for the jack-o-lantern packaged in previous versions

Changes:
Fixed an accidental AI death. Changed some textures and added a few details.

Known Issues:

I see some patch shadows in a few places. Some AI sink into the patchwork a little bit. Lighting is goofy, but so is the whole mission.

samhain_002.jpg
samhain_003.jpg
samhain_004.jpg

Edited by PranQster
added thedarkmod.com download link
  • Like 3

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Woohoo! :)

I'm getting faster at building for sure. But I need practice making a city map. This one was fast because

most areas didn't require any precision since it is mostly patchwork rooms and tunnels

.

Enjoy!


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

i see black boxes on peoples heads...thats not normal is it?

 

No that's not normal. Grrr... those tested fine and I thought I packaged them carefully. I'll upload another .pk4 in a bit.

One sec... repackaging and uploading again.

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Sorry folks. I had forgotten to package Nosslak's .pk4 inside mine. All fixed now. Please re-download and reinstall.

I was too excited when I first packaged it :o

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

I just started playing and the following is what I see:

 

 

I too see black boxes on the people's heads right at the beginning. There is also three black "squares" at the end of the hallway. One on each wall and one on the door. At the top of the black squares is written "Invalid GUI: guis/john01.gui"

 

 

 

I'm going to hold off playing for a bit in case there's a tweak or two needed.

Share this post


Link to post
Share on other sites

I just started playing and the following is what I see:

 

 

I too see black boxes on the people's heads right at the beginning. There is also three black "squares" at the end of the hallway. One on each wall and one on the door. At the top of the black squares is written "Invalid GUI: guis/john01.gui"

 

 

 

I'm going to hold off playing for a bit in case there's a tweak or two needed.

 

Thanks. I'll fix that in about 5 minutes. :o yikes.

Uploading.

Thanks guys for being my un-planned beta testers :)

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Ok. It should be good now.

 

i have re installed it a few ways now. i still have the issue.

may just be me though.

i like what i see though, great job.

Share this post


Link to post
Share on other sites

i have re installed it a few ways now. i still have the issue.

may just be me though.

Did you delete the /doom3/darkmod/fms/samhain directory and the /doom3/samhain directory first, before reinstalling the updated .pk4?

Sorry to hear that it's still causing trouble. It was a final touch but not important to the actual mission. The rest of the mission should not give any similar troubles since I used all regular TDM resources for it.

i like what i see though, great job.

Thank you. I hope the rest of the mission works well for you. :)

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Did you delete the /doom3/darkmod/fms/samhain directory and the /doom3/samhain directory first, before reinstalling the updated .pk4?

Sorry to hear that it's still causing trouble. It was a final touch but not important to the actual mission. The rest of the mission should not give any similar troubles since I used all regular TDM resources for it.

 

lol, don't sweat it. this is better tech support than im usually treated with. glad to see you actively participating in your own beta :D

and no i did not :/ thanks. ill try that now.

Share this post


Link to post
Share on other sites

lol, don't sweat it. this is better tech support than im usually treated with. glad to see you actively participating in your own beta :D

and no i did not :/ thanks. ill try that now.

Cool. Yeah, those directories still hanging around may be the problem now. A clean install from the updated .pk4 should work fine.


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

For the fun of it... here's a screenshot of a glimpse of my developer notes:

post-3285-131822560235_thumb.png

 

  • Like 1

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Cool. Yeah, those directories still hanging around may be the problem now. A clean install from the updated .pk4 should work fine.

 

ok, did that. still the same thing.

it doesnt bother me much at all really, i just thought you should know.

 

im already past the spiders and am stuck trying to open a gate that wont highlight. i see a skeleton in the room, but cant open the grate to get at it :(

 

 

ill reload and try again.

Edited by Senju

Share this post


Link to post
Share on other sites

ok, did that. still the same thing.

it doesnt bother me much at all really, i just thought you should know. im already past the spiders and am stuck trying to open a gate that wont highlight. i see a skeleton in the room, but cant open the grate to get at it :(

ill reload and try again.

 

 

That grate will highlight... might have to back down a bit or adjust your view angle. I have been through there literally dozens of times and never had problems with the grate that adjusting position didn't easily fix.

 

 

Ok, well, I re-uploaded another .pk4. This time I not only included Nosslak's .pk4, but I also extracted it into the mission directories as well. But it may have to be pulled out and put directly into the /doom3/darkmod directory.

I'll update the mission announcement to include Nosslak's .pk4 and have players put it directly into their darkmod directory, if it still doesn't work.

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

ok, so i figured out something.

 

after i torched the skeletons i had time to check out that book. but when i tried to read it i couldnt, then my mouse buttons wouldnt work, like i was stuck in reading mode. i could move and look around, but not activate anything, swing my blackjack, switch to another tool etc. the only thing i could do after using the book was move.

i tried it again, reloaded from the begining, and when i got to the book it happened again, and that was the reason i couldnt open the gate the first time.

 

 

Edited by Senju

Share this post


Link to post
Share on other sites

oh, and the new file works just fine..dont know what you did but the masks look great. i even followed them to the stairs to make sure everything was ok. very nice now.

Share this post


Link to post
Share on other sites

ok, so i figured out something. after i torched the skeletons i had time to check out that book. but when i tried to read it i couldnt, then my mouse buttons wouldnt work, like i was stuck in reading mode. i could move and look around, but not activate anything, swing my blackjack, switch to another tool etc. the only thing i could do after using the book was move.

i tried it again, reloaded from the begining, and when i got to the book it happened again, and that was the reason i couldnt open the gate the first time.

 

Ok. I've seen that problem with a book before. But it normally only happens when trying to give or use a book on another entity (or drop it?). I didn't experience any problem just using to book to read it and close it again. I'll look into that and fix it. Thanks!


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

congrats PranQster!

 

I won't play any halloween fm until I release mine. I don't want to be influenced by any author. :)

 

That's cool. I look forward to it. :)


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

ohh... now that was fast PranQster... cool!

 

... will dig into it around Halloween :)


"To rush is without doubt the most important enemy of joy" ~ Thieves Saying

Share this post


Link to post
Share on other sites

Ok. I've seen that problem with a book before. But it normally only happens when trying to give or use a book on another entity (or drop it?). I didn't experience any problem just using to book to read it and close it again. I'll look into that and fix it. Thanks!

 

I am having the same problem. I cannot read the book, and now that I tried it, I cannot drop it, clear my inventory nor can I do anything else.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...