Jump to content
The Dark Mod Forums
Sign in to follow this  
Grrbrr

Rather odd performance problem

Recommended Posts

Problem: Framerate dips down to 5fps at certain locations. Which in themselves are rather random by elements present in them.

Possibly linked problem: Loading the map at launching the game always takes about 5 minutes, this happens after the loading bar completes. Cpu is just about 15%.

 

Examples: Requiem starts lagging after entering to the central part of town, where the church is located. It ends after descending down. It starts again right after you pick the third stone disk. (i guess you can pick these out of order, this is the one i got first) Both in town and after picking up the disc, the map is populated by lots of AI. So maybe it's related to that. I've also had this in Alberic's curse in the wide beginning part, i did not go further.

 

Now what makes this weird is that when i played requiem and the performance got bad again. I Noticed that the problem goes completely away for about 15-20 seconds if i press esc to enter the menu and stay in there for a while. A Short taps of the menu do nothing, but about a minute in there and the problem is gone for the brief time.

 

I have tried messing around with graphical settings with no luck. All from resolution to v-sync to other quality options.

I did try resetting the Darkmod.cfg by restoring the old one. I have also tried to change as many compression and image settings there as i have the knowledge to.

I play with 3 screens in eyefinity normally, but i also tried just a single screen.

My windows installation isn't very old. Just a 1-2 months. Drivers installed were the latest ones.

 

My computer specs are following: Amd 8 core 4ghz, 4gb ram, Radeon HD6850. Windows 7.

So you wouldn't think that it's a problem with my computer since i don't have any temperature issues and i run other games just fine.

 

Here's to show this in action. I waited a while in the menus to for the fps to get back up and started recording. The framerate goes bad again in 0:26

http://www.youtube.com/watch?v=kZv7rpcIu8k

 

Is there something i should try?

Share this post


Link to post
Share on other sites

Try these:

http://wiki.thedarkm...erformance_poor

http://wiki.thedarkm...is_very_slow.21

http://wiki.thedarkm...w_loading_times

http://wiki.thedarkm...n_opening_doors

http://wiki.thedarkm...AMD_ATI_drivers

http://wiki.thedarkm...rash-to-desktop

 

I would start maybe by disabling EAX, disabling Catalyst AI, disabling Windows Aero, The malloc failure fix.

 

Hopefully something of these works!

 

 

I have now tried all of these and there was not change in the fps problem and strangely not even in the long loading problem. Thanks though.

I also redownloaded requiem just in case if it was corrupted.

 

Stumpy, it was already off.

Edited by Grrbrr

Share this post


Link to post
Share on other sites

Disabling vertical sync should help with map load times. Hmm.

 

I played through Requiem and didn't have any issues but I was running 1920x1200. I have yet to try it on 3 screens and I'm running Nvidia but I can give this a go and see if anything similar happens when running 5760x1200.

 

Are you running this off an SSD or standard hard drive?

Edited by Lux

Share this post


Link to post
Share on other sites

Disabling vertical sync should help with map load times. Hmm.

 

I played through Requiem and didn't have any issues but I was running 1920x1200. I have yet to try it on 3 screens and I'm running Nvidia but I can give this a go and see if anything similar happens when running 5760x1200.

 

I already tried running the game on single-screen only and it didn't change a thing. Even deleted the config-file completely and ran the game at whopping 640x480 with all settings off and nothing changed.

 

EDIT: My hard-drive is a reqular one. It's quite fast though.

Edited by Grrbrr

Share this post


Link to post
Share on other sites

The slow load time is caused by the textures being compressed on-load. You can disable that with errr image_useNormalCompression 0

 

Sometimes you get pretty dramatic slowdowns as you cross into a new area. If you stand perfectly on the edge of the portal it can drop your fps to the 1-5 area, but it's fairly rare that people get it so exact (this is not a bug/problem to solve, either). So it seems a little bit odd, perhaps related to an overlay or something running on your system?

Share this post


Link to post
Share on other sites

The slow load time is caused by the textures being compressed on-load. You can disable that with errr image_useNormalCompression 0

 

Sometimes you get pretty dramatic slowdowns as you cross into a new area. If you stand perfectly on the edge of the portal it can drop your fps to the 1-5 area, but it's fairly rare that people get it so exact (this is not a bug/problem to solve, either). So it seems a little bit odd, perhaps related to an overlay or something running on your system?

 

I Actually tried that setting for the darkmod.cfg. It didn't help much if it did something.

The current load time for Requiem save is:

- 7 seconds of "loading" bar

- 2 minutes 19 seconds of "starting" text

- 20 seconds of "loading" bar again.

 

I do not have any overlays running over darkmod and i now tried closing everything nonessential from processes manager. Also no active virus scanner present.

Share this post


Link to post
Share on other sites

Rather open the console with ctrl + alt + ~ and type in 'image_useNormalCompression 0' then close the console with the same combination and start the mission. Can't think of much else happening after the map load that takes up so much time. But your timing is consistent with texture load issues.

Share this post


Link to post
Share on other sites

I tried the console -method instead before loading the game and it didn't seem to do differently. I have now started to re-download the whole darkmod again in case of bad files.

 

Edit: Since i've always had the long loading thing. Could someone say how long it takes to load with a working setup?

Edited by Grrbrr

Share this post


Link to post
Share on other sites

This may be totally irrelevant/facepalmingly 'well dur' but I'll throw it out there anyway: make sure TDM is running off your Radeon card and not off your integrated graphics card (if you have one).

 

Just speaking from experience: when I updated to 1.08 back along, Windows 7 decided that my playing experience would be enhanced by switching TDM play from my GT550M to Intel HD 3000. Bless.

Share this post


Link to post
Share on other sites

This may be totally irrelevant/facepalmingly 'well dur' but I'll throw it out there anyway: make sure TDM is running off your Radeon card and not off your integrated graphics card (if you have one).

 

Hah, nothing that silly. It's a custom desktop pc.

Share this post


Link to post
Share on other sites

I had this problem also but only when recording with Fraps.

 

To test with this right click on the task bar and open Task Manager. Click on the Performance tab on the top. Then click on Resource Monitor.

 

At the top of the RM, click on the Disk tab, and the graph on the right there is a Disk Queue Length.

Run TDM and wait for it to start going slow and quit the game quickly by typing /quit in the console window. Check your disk queue, the green bar shouldn't be above 5


I always assumed I'd taste like boot leather.

 

Share this post


Link to post
Share on other sites

As far as disabling v-sync goes, did you do that in both TDM settings AND the graphics card settings in the OS? That should does really help a lot with the mission load and dmap times.


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

So, i redownloaded a clean darkmod installation. No change.

Even though i had v-sync on "off, unless application decides", i put it to permanently off. No change.

 

So about that disk thing, well i have 3 monitors... I don't need to alt tab. ;D

 

 

at3V4PGl.jpg

 

 

But there doesn't seem to be anything fishy going in there. I have darkmod on D-drive.

Share this post


Link to post
Share on other sites

I just tested this mission out. I had numerous load point throughout from my first play through so I could load right in to the area with the vertical climbing and undead you have in the OP.

 

Playing at 5760x1200 on single nvidia 780

 

autoexec.cfg

---------------------

seta r_mode "-1"

seta r_aspectRatio "2"

seta r_customHeight "1200"

seta r_customWidth "5760"

seta r_fovRatio "4.801"

seta r_fullscreen "1"

set com_allowconsole "1"

 

Darkmod.cfg

----------------------------

seta r_renderer "best"

seta r_brightness "1"

seta r_gamma "1.2"

seta r_swapInterval "0"

seta r_useIndexBuffers "1"

seta r_customHeight "1200"

seta r_customWidth "5760"

seta r_fullscreen "1"

seta r_mode "-1"

seta r_multiSamples "4"

seta image_downSizeLimit "256"

seta image_ignoreHighQuality "0"

seta image_downSizeBumpLimit "128"

seta image_downSizeSpecularLimit "64"

seta image_downSizeBump "0"

seta image_downSizeSpecular "0"

seta image_useCache "0"

seta image_cacheMegs "20"

seta image_cacheMinK "200"

seta image_usePrecompressedTextures "1"

seta image_useNormalCompression "2"

seta image_useAllFormats "1"

seta image_useCompression "1"

seta image_preload "1"

seta image_roundDown "1"

seta image_forceDownSize "0"

seta image_downSize "0"

seta image_lodbias "0"

seta image_anisotropy "16"

seta image_filter "GL_LINEAR_MIPMAP_LINEAR"

 

TDM shortcut launch properties

------------------------------------------

Target: D:\games\darkmod\TheDarkMod.exe +set sys_videoRam 3072

 

Vertical Sync is OFF in driver and OFF in TDM settings (which I find odd because my in-game framerate is still capped at 60)

 

I also switched seta image_useCompression "1" to "0" after seeing that I hadn't set that setting to 0 in 2.0 yet and it made no difference.

 

Initial map load took ~6 seconds on loading bar, then another 1:09 seconds till I I'm in-game so about 1:15 total.

 

After the initial load, loading any of the save points I have takes between 3-4 seconds.

 

FPS are constant 59-60 anywhere I go in the map. I do get ~48fps in the large room with all the activate statues (earth wind fire, whatever) but only right when you drop down in there because of the lighting. The only time I get solid 7fps is when I noclip outside of the map boundries and everything in the level is simultaneously rendered.

 

If you have identical results after re-installing TDM, maybe you should reinstall your video drivers?

 

I always do the uninstall/reboot to safe mode/run driver cleaner to remove remnants/reboot and reinstall Nvidia with clean install checked. I never install any of the 3D driver bs.

 

Not sure what ATi options there are. Do you have a clean driver install?

 

Are your audio drivers up to date? I'm running onboard Realtek 889 with latest drivers.

 

Also, as AluminumHaste mentioned, what applications are you running in the background? Another user with ATi had issues when running Xfire in the background so its worth mentioning.

Edited by Lux

Share this post


Link to post
Share on other sites

Well, i installed fresh drivers to my video card just recently as i formatted my windows-installation. It should be as clean as it gets. Also there are no newer drivers for it yet other than beta stuff.

And my soundcard is an old Creative Audigy one with modded x-fi drivers. So set my usb-soundcard as a default and gave it a whirl. But again it didn't change a thing. So it's not soundcard related.

 

So does setting the shortcut to +set sys_videoRam 3072 help a lot? Weren't there a similar setting in the cfg?

Share this post


Link to post
Share on other sites

Obviously it has to be set to your video ram size but as far as "help a lot" I'm not particularly sure. It didn't affect my FPS but it did stop occasional crashes on my setup at least.

 

I was getting occasional memory allocation errors and that put an end to it on win7 64bit. I believe it has to do with TDM autodetect not always detecting correctly or similar.

 

Someone with more knowledge on the subsystems would have to field that answer.

 

Personally, I would say it won't affect your situation, but it can't hurt to try.

Edited by Lux

Share this post


Link to post
Share on other sites

I don't know about "having it on for other missions that work well" as TDM may recognize your VRAM correctly already. All that does is make sure of that so for me at least its a basic configuration step.

Share this post


Link to post
Share on other sites

So i fixed my problem and wanted to inform possible other people that might get in the same situation.

 

My 125w cpu was on a motherboard that only supported 95w. Thusly it throttled the cpu under heavy load to preserve the the motherboard from igniting. I only noticed this after monitoring the frequency after installing a new cooler. What's funny is that the throttle was not related to the cpu-temperature, i didn't look to it before. I just mostly watched cpu-usage and temp.

 

I bought a proper motherboard and all is fine now.

Share this post


Link to post
Share on other sites

Glad to hear you figured it out. I would not have thought of that issue and its good to have in the arsenal of troubleshooting tips.

 

Its always a good idea to match components when assembling a system however installing a newer CPU in a board that's a generation or two older could present this problem. Generally when I upgrade a CPU, I will also upgrade the platform but it isn't always necessary.

 

Thanks for the info and again, glad you figured it out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...