Jump to content
The Dark Mod Forums
Sign in to follow this  
Fieldmedic

Tinnitus in ambient

Recommended Posts

This is weird. In certain ambients I've started to hear a faint high pitched tone. I first heard it in darknessfalls_z but I have tried forest_children_z and factory_01_loop and several others which also have high pitch tone that in some cases pulsates with the music :S The sound is okay in the editor. I have tried with a new, empty map but still same sound... Now don't tell me it's a sound driver thing :D

  • Like 1

Share this post


Link to post
Share on other sites

This is the first report I've seen for this problem. There's a problem with sounds popping occasionally that'll be fixed in 2.04, but that's unrelated. You'd never come across it in an empty test map.

 

What's your setup in that test map? Are you using a simple speaker, or the location system?

Share this post


Link to post
Share on other sites

It's the zone system and it's triggered by the ambient starting... Now you must think I'm crazy. I just got out of bed and fired up my computer to try to record the noise but it seems to have stopped now. I did reboot yesterday to see if it made any difference but it did not. Well, at least it's gone now :)

  • Like 2

Share this post


Link to post
Share on other sites

Shall test again this evening to see if it still absent... I feel so dumb for reporting strange things that just dissappear...

Share this post


Link to post
Share on other sites

It is a well known symptom of FMPD (Fan Mission Publishing Deprivation) Syndrome, which is relatively common among mappers.

 

It will heal by itself once you release a new FM for TDM. Just work on your WIP harder.

 

Trust me, I'm a doctor.

 

:D

  • Like 2

Clipper

-The mapper's best friend.

Share this post


Link to post
Share on other sites

Funny thing is, I've got real tinnitus but it is not as annoying as "bugs" in the mod that emmerge and then just scamper away :)

 

Sooo, the finlandier wants more missions from the swede? :) I've got some nice ideas that I will build/implement this evening. No plot just yet, only planless city building. It's easy to implement storys later, especially as I take so much time to create things (much time to thing about plot).

 

Sidenote, use earplugs when attending conserts ore going to clubs! You do NOT want to experience tinnitus. My version is VERY mild but as I got it some months ago, (on a club) I got real scared and wondered how I could cope with that crap.

Share this post


Link to post
Share on other sites

Tom Larson Dub-Techno / Electro / Ambient

Share this post


Link to post
Share on other sites

Now here we go again! Last night the high pitched sound was there again. I didn't record it but when I started mapping today I found yet another strange sound error. It seemed like the game didn't want to play certain ambient correctly. It sorta played it in a lower pitch/slower tempo... I have recorded proof

 

This is the ambient city_night04_loop_z first played in darkradiant and then in game. What is going on??

 

https://ufile.io/f0121

 

And this is city_streets01_loop_z played first in darkradiant then in the map

 

https://ufile.io/aa241

Share this post


Link to post
Share on other sites

I posted about this a year ago in the newbie thread but nobody replied. There is a difference in how the "_z" (zoned) ambients and normal ambients play in-game. Can you do these tests with regular, non-zoned ambience and tell me if the problem persists?


My FMs: The King of Diamonds (2016)



| Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM! |

Share this post


Link to post
Share on other sites

That's definitely a strange bug..

 

If it's any help:

I messed around with you files and it looks like the in-game version is playing at half the speed. Any audio file you run through a game engine is usually going to have different characteristics in-game (compression, volume ,ect). However, I've never heard anything play at half speed unless its some kind of sample rate issue..

 

As far as I know, the only difference between the zoned ambient sound shaders is that they play a brief silent .ogg before they start. I remember reading somewhere that it prevents audio popping when switching between ambient tracks.

Edited by kingsal

Share this post


Link to post
Share on other sites

I posted about this a year ago in the newbie thread but nobody replied. There is a difference in how the "_z" (zoned) ambients and normal ambients play in-game. Can you do these tests with regular, non-zoned ambience and tell me if the problem persists?

 

city_streets01_loop_z used on an ordinary green speaker - Slow bug sound :(

 

city_streets01_loop_z used the zoning system - Slow bug sound :(

 

city_streets01_loop used on an ordinary green speaker - Correct sound :)

 

city_streets01_loop used on the zoning system - Correct sound :) (No popping what I've noticed)

 

I think I'll stick to the shaders without the Z then

 

Thanks :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...