Jump to content
The Dark Mod Forums
Sign in to follow this  
greebo

DarkRadiant 2.0.5 pre-release testing

Recommended Posts

When you select a bunch of func_statics then click "merge selected" the origin of the resulting FS should be the last selected FS' origin. This isn't the case in 2.0.5 and it isn't in 2.0.4, but I could've sworn it was in 2.0.3. Am I imagining things, was that ever the case? Right now, from a mapper's perspective, the choice of origin point seems arbitrary.


My FMs: The King of Diamonds (2016)



| Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM! |

Share this post


Link to post
Share on other sites

Am I imagining things, was that ever the case? Right now, from a mapper's perspective, the choice of origin point seems arbitrary.

It was never the case, the origin has always for me atleast been random. Its such a monir bug that if Greebo can't be fix in 5mins then its not really worth fixing.

Share this post


Link to post
Share on other sites

Tested this with the June 19th release.

 

I never get a random origin; the resulting origin is always the same as one of the original origins.

 

Selecting A and then B and merging will sometimes use A's origin and sometimes use B's origin.

 

Maybe it has to do with selecting the origin that's closest to (0,0,0). That's what I was seeing.

 

Best to ask greebo what it does.

Share this post


Link to post
Share on other sites

Is it possible to (sometime in the future), being able to merge func_statics made up of models? Say if you add a model table with model chairs, all in func_statics. Then merge it to save memory/entities? Or am I forced to learn Blender or similar modelling software? :)

Share this post


Link to post
Share on other sites

SEED can merge models:

 

http://wiki.thedarkmod.com/index.php?title=SEED_-_Combining_entities

 

but they all need to be identical as I recall.

 

Another option is the inline 1 arg which will turn them into WS which reduces the entity count but doesn't save you

any memory.

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Well, the concept works but it seems that SteveL tried some further experiments with merging stuff by material

and it caused FPS to increase on AMD while decreasing on Nvidia. Based on what I now know about triangle

rejection rates for these vendors, the merge operation probably throws off the heuristic for Nvidia's culling whereas

AMD is not doing much culling at all so the merge is all win there. Not sure how different the story is for seed_combine

(Tels reported small gains on his older Nvidia hardware) but the memory benefits are there at least.


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

thanks for implimenting the mouse pan in 3d

there is an issue on my setup tho, moving up/down is reversed

maybe some conflicting option i have?

Share this post


Link to post
Share on other sites

i was looking for surface inspector shortcut to H/V shit size, but found some isues

MoveSelectionUP is crashing DR when nothing is selected. on a fresh load

bound key to "PLUS" is not working. need to be rebound to "="
Maybe a regon issue? im using US for keyboard


in old radaint there is an option to match surface inspector H/V shift value to match grid size
could this be implimented. instead of manualy typing values

thanks
david

Share this post


Link to post
Share on other sites

Sorry, can't help you there. For me, it appears that distro maintainers are changing or renaming their packages every 2 minutes. Stuff that has worked before is now broken due to a system-level change that is out of your control.

My system has taken many updates recently, including glew-devel and a new nvidia 367.35.

I had gotten past the glew issue before, but ran into a bug with nvidia 367.27 which affected development compilation of many software packages, including DR.

The new nvidia version fixed issues with compilation for those programs, or so I assume because I could build some missing kde-pim stuff and DR is building now. :)

 

Update: It built! :) I ended up with what is reporting as version 2.0.2, but I had downloaded it in early june. So... compiling again after fresh download.

And... kersplat!

  CXXLD    libwxutil.la
.libs/FileChooser.o: In function `_GLOBAL__sub_I_FileChooser.cpp':
/usr/include/boost/system/error_code.hpp:221: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:222: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:223: undefined reference to `boost::system::system_category()'
collect2: error: ld returned 1 exit status
Makefile:579: recipe for target 'libwxutil.la' failed
make[3]: *** [libwxutil.la] Error 1
make[3]: Leaving directory '/home/john/Desktop/DarkRadiant-master/libs/wxutil'
Makefile:437: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/john/Desktop/DarkRadiant-master/libs'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/john/Desktop/DarkRadiant-master'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2

My distro's current beta has libboost 1.60.0, while the current official boost is 1.61.0... likely what I need for those undefined references. This is the same issue that nvidia-367.27 had. Ironically, my distro's libboost-1.61.0 package may have been delayed by that very nvidia devel issue. lol

* Nope, I'm wrong. boost is a simple copy to /usr/include/ for installation. But DR still failed to compile with the same error.

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

SEED can merge models:

 

http://wiki.thedarkmod.com/index.php?title=SEED_-_Combining_entities

 

but they all need to be identical as I recall.

 

Another option is the inline 1 arg which will turn them into WS which reduces the entity count but doesn't save you

any memory.

This is a real pain.

 

the spawnarg for when it is supposed to make them hit the brush/entity/prefab under (mesh/whatever) messes up and it ends up floating (perhaps removes "seed brush" as intersecting degenerate triangle) and sometimes saves entity count, sometimes doesn't. I don't understand that spawnarg, but use seed a lot.

 

doubt it is an issue for (m)any other people tho. but it really messes up for loot...

Edited by teh_saccade

Share this post


Link to post
Share on other sites

I just downloaded the latest and it built just fine in Mageia 6 Cauldron. I had to delete ~/.darkradiant and allow DR to recreate it, else I got a segfault before the main window was even drawn.

DR started right up and I set the game options, restarted, configured my preferences, and loaded my map. At first I thought there was a graphics error but soon discovered the settings for the camera distance clipping. The 'about' dialog still says version 2.0,2, but I don't expect that would be updated until the official release. I haven't tested it out yet, but so far so good for the upcoming Mageia release (it launches).


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

For those who crash at startup when DR is initialising its XML registry, which is a problem that I get from time to time, usually when my pc crashes while DarkRadiant was saving, I could solve it in my case by deleting the user.xml file in my user account's hidden AppData/Roaming/DarkRadiant folder.

 

Here's a user.xml file that makes my DR crash at startup:

 

 

edit: had it again today, deleting user.xml alone wasn't sufficient to solve it, I had to delete everything else in there to get it to start again.

user.xml.txt

Edited by Dragofer

Share this post


Link to post
Share on other sites

I am having an issue with DR freezing up after adding an particle emitter, when I open the dialog to select a particle. No particle effects render in the pane on the right, I only get a blank grey area. When I select a particle from the list, I have to click it a second time to see it get selected. When selecting the OK button after selecting a particle, the dialog stays rendered on the screen over a frozen DR.

I will for now need to copy/paste a particle emitter from elsewhere in the map or from another map and then type in the new particle name. I'll likely need to open the pk4 file containing the particle effects so I can see them listed. Then will have to trial/error the particles by checking them in TDM.


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

edit: had it again today, deleting user.xml alone wasn't sufficient to solve it, I had to delete everything else in there to get it to start again.

Thats why after a fresh install and full key setup of DR I backup of that folder.

I am having an issue with DR freezing up after adding an particle emitter, when I open the dialog to select a particle.

What version of DR are you running..?

Share this post


Link to post
Share on other sites

What version of DR are you running..?

That was the version I downloaded from git https://github.com/codereader/DarkRadiant on Aug 17. It was supposed to be 2.0.5, but the about file says 2.0.2. I assumed the version number hadn't been updated yet for the 'about' dialog.


pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Where would I find the sources for this release, if I wanted a linux build?

As I recall, this is the Git:

 

https://github.com/codereader/DarkRadiant

I had followed this thread to get the source.

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

Linux. I have the windows version also, 2.0.2, running in wine. I can choose particles in that version. A previous build of 2.0.5 did not run in wine for me, but I will try again with the latest.

The biggest problem I have running the windows version of DR in wine is that everything takes an extra mouse click or extra keypress for the gui to refresh. This gets particularily annoying when selecting/de-selecting entities or vertices.

 

Also, I'm pretty sure I need an 32bit build to run in wine, but I'll try the 64bit version anyway.

Yeah, I get an architecture error when trying to run the installer for the 64bit version. So I'll have to wait for a 32bit release to run it in wine.

 

The 32bit version of 2.0.4 does not run at all in wine... I won't bother with the crash dump. Going back to 2.0.2 works again in wine.

Edited by PranQster

pranqname.gifLinux pranqster 4.14.44-desktop-1.mga7 #1 SMP Fri May 25 18:06:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

If I bring up a layer, and discover an object that belongs to a hidden layer, and then select that object and move it to the hidden layer, the object remains visible.

 

It used to disappear, because its new layer is hidden.

Share this post


Link to post
Share on other sites

If I bring up a layer, and discover an object that belongs to a hidden layer, and then select that object and move it to the hidden layer, the object remains visible.

 

It used to disappear, because its new layer is hidden.

This is likely to be side-effect of the changes I made for the grouping feature. I'll look into that, I'd like to have the layers behaviour to stay the same as it was before.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...