Jump to content
The Dark Mod Forums
Sign in to follow this  
Epifire

DR Unhandled Exception

Recommended Posts

So out of nowhere it seems I keep getting this error when I try to launch DR...

 

Screen%20Shot%2012-18-16%20at%2010.33%20

 

Anything I press on this screen just leaves it to remain frozen on the loading bar or ends it. Didn't do anything different as far as I'm aware of. I deleted my install of DR and ran the installer for the newest version and still have the same problem. Any guesses as to what could be causing this?


You need a model? Epi does you a model.



Toss me a PM I promise I don't bite.



Share this post


Link to post
Share on other sites

This happens for me when the .xml files which contain preferences get corrupted. They can be found in [your user account name]/AppData/Roaming/DarkRadiant. Your system settings must be set to show hidden folders. You can delete them so that new ones are created when you next start DR.

 

It'd be worth considering making a backup of them when you've configured your DR preferences (close down DR for the changes to get saved). Sending the corrupted files to greebo to have a look at would also be good.

Share this post


Link to post
Share on other sites

Can you send me a copy of those .xml files? I'd like to see what's causing this behaviour.

Share this post


Link to post
Share on other sites

Can you send me a copy of those .xml files? I'd like to see what's causing this behaviour.

 

Dragofer had told me about clearing the Appdata folder via Discord before there were any replies today, so I currently don't have the corrupted files anymore. :wacko:

 

To be sure I will be sending any such corrupted files your way in the future should this start happening again.

  • Like 1

You need a model? Epi does you a model.



Toss me a PM I promise I don't bite.



Share this post


Link to post
Share on other sites

Sorry for reviving a dead topic, but I started having this same problem just now, also just out of the blue (worked fine day before yesterday).

5cgcxv.png

Removing said XML files as Dragofer mentioned fixed it. I saved the corrupted files elsewhere before deleting however, would it still be interesting to inspect them greebo? If so I can upload to dropbox for you.

Share this post


Link to post
Share on other sites

Yes, please do upload them somewhere, or even better open an issue on the bugtracker and attach the files.

Share this post


Link to post
Share on other sites

Ok, they're uploaded.

Sorry I've never actually used the bugtracker so I don't know where to find it or how it works. I'm guessing you can put it up for me though, with the files.

No idea why it started happening, and there was no unusual behavior prior to it happening, that I know of. I'm running Win 10 and DR 2.4.0 x64.

Share this post


Link to post
Share on other sites

It happened again -.- this time I tried to figure out which file was corrupted by removing them one at a time, and once I removed the file called "filters" DR booted back up as normal, and I didn't have to delete my user preferences and redo them! Yay! That was a real pain in the ass last time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...