Jump to content
The Dark Mod Forums
Sign in to follow this  
Spooks

Stereo Zoned Ambients Need a Stereo silence.ogg Leadin Sound

Recommended Posts

Oh man, I was just trying to figure this out the other day! Thanks Spooks!

 

I couldn't for the life of me figure out why my ambient tracks where playing at a lower sample rate. I thought it had something to do with transitioning from a mono to stereo ambient. I didn't even think to look at the silence file.

Share this post


Link to post
Share on other sites

I'll crosspost this from the internal thread for the public record.

 

I'm the one that originally decided to use the silence.ogg "leadin" to stop the popping problem.

(It was actually only a guess. I was never 100% sure it stops the problem or if it's confirmation bias. The pop-in will happen or not also depending on if the incoming ambient is very loud or not at the start, and possibly other issues that I don't even know about. But I at least had rational grounds to believe leadin works the way the problem works.)

 

But anyway, all of that is aside from the main point here.

It seems spooks really figured out stereo depends on having a stereo leadin.
In that case, it should be an easy yes to allow the switch IMO.

There was no rational reason I used mono in the first place except that it was fast to make & didn't occur to me it'd be a problem.

Share this post


Link to post
Share on other sites

By my guesses the pop in happens only when you enter a zone for the first time or when you travel between three zones fast. The latter case is fixable by setting your 2foip spawnargs to a longer fadein/out. The former I could only guess happens because even though the sound shaders are supposed to be "precached" they still load for the first time, making them skip fadeins. Perhaps making the sound shaders consist of two files makes the system load both, skipping the fade on the silence (which doesn't cause a pop, obviously) but it still works for the song proper. Again, all conjecture.

Share this post


Link to post
Share on other sites

There was no rational reason I used mono in the first place except that it was fast to make & didn't occur to me it'd be a problem.

So just a case of replacing the silence.ogg file then..?

Share this post


Link to post
Share on other sites

Seems to me you'd be better off keeping the original and substituting the new one into the stereo ambients, but that'd likely be a lot more work.

Share this post


Link to post
Share on other sites

Seems to me you'd be better off keeping the original and substituting the new one into the stereo ambients, but that'd likely be a lot more work.

As I understand it, all the ambient's are stereo files - so unless silence.ogg is used with any non-ambient's its shouldn't be an issue to direct replace the file.

Share this post


Link to post
Share on other sites

Seems to me you'd be better off keeping the original and substituting the new one into the stereo ambients, but that'd likely be a lot more work.

Assuming all the ambient's are stereo files, unless silence.ogg is used with any non-ambient's its shouldn't be an issue to direct replace the file.

Share this post


Link to post
Share on other sites

By my guesses the pop in happens only when you enter a zone for the first time or when you travel between three zones fast. The latter case is fixable by setting your 2foip spawnargs to a longer fadein/out. The former I could only guess happens because even though the sound shaders are supposed to be "precached" they still load for the first time, making them skip fadeins. Perhaps making the sound shaders consist of two files makes the system load both, skipping the fade on the silence (which doesn't cause a pop, obviously) but it still works for the song proper. Again, all conjecture.

 

Since this issue came up again, cf. http://forums.thedarkmod.com/topic/18982-tdm-206/?p=414263, I'll just comment on this. The reason it happens (I thought at the time) is because, for a sound that is faded in, the way id4 set things up, the script function start_sound begins the sound at full volume, then you use a .01 second fadeout to silence, then you gradually fade it back up in volume.

 

The pop I thought was due to the fadeout coming online after start_sound already started a loud sound, so you get that blip of full volume before it fadesout. So a longer fadein would not address that issue.

 

The idea of the silent leadin was to allow the .01 second fadeout to do its work before the main sound comes online. As I said before, I don't know that that was ever actually the problem. E.g., there have been other issues with sound popping: http://bugs.thedarkmod.com/view.php?id=4148, which (the video in the first post of the attached thread) is what the original pop sounded like too AFAICR.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...