Jump to content
The Dark Mod Forums
Sign in to follow this  
Bikerdude

Game/project popup at launch

Recommended Posts

Morning

 

I started getting this last night after deleting my darkmod.config from from my appdata folder, Im running Windows 7 and I have full read/write rights to the darkmod folder. The reason I nuked the config file is I have had a number of minor bugs with DR and the first step of fixing some of them was to nuke the config file.

 

post-496-0-79953600-1519548889_thumb.jpg

 

Evenign when I correct the game path from the list of available Fms (see below) it will continue to popup at launch.

 

post-496-0-62011200-1519549072_thumb.jpg

Edited by Bikerdude

Share this post


Link to post
Share on other sites

I don't know, am still using the configuration settings for Doom3, as it allows for more settings.

 

is the path to the AppData/Roaming/DarkRadiant folder visible or hidden, windows will sometimes not let you write configure files to a folder that is hidden even if you have full access rights to that folder,

 

the AppData files should be

 

darkradiant.language users language

darkradiant.log log of previous use

filters.xml

input.xml keyboard shortcuts

user.xml darkradiant config

Edited by stumpy

Share this post


Link to post
Share on other sites

Picking up the issue in the original post, biker, can you tell me more about your folder structure you have in E:\darkmod? Where is your TheDarkmod.exe located? Is this in E:\darkmod or in E:\darkmod\darkmod? DR should be pointed to the folder where the EXE is located (actually, it should warn you about a missing exe if you point it to somewhere else).

Share this post


Link to post
Share on other sites

Picking up the issue in the original post, biker, can you tell me more about your folder structure you have in E:\darkmod?

Yes, as per TDM defauts..

Share this post


Link to post
Share on other sites

That's a little less detailed than I hoped for, I must admit :)

 

I was wondering how the structure looks like in E:\darkmod. It seems there is a E:\darkmod\darkmod folder? Where is the TheDarkMod.exe located?

Share this post


Link to post
Share on other sites

Yes, as per TDM defauts..

I was wondering how the structure looks like in E:\darkmod. It seems there is a E:\darkmod\darkmod folder? Where is the TheDarkMod.exe located?

Sorry fella, I though the screenshots in the Op were enough.

 

post-496-0-20363500-1524475878_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks, I'll try to repro this on my machine.

Share this post


Link to post
Share on other sites

I've found that I get this sometimes.

I have my TDM installed to C:\Games\thedarkmod

So I set my DR to C:\Games and it works.

So I guess in your case, try setting it to E:\

No, I take that back, mine is set to C:\Games\thedarkmod\


I always assumed I'd taste like boot leather.

 

Share this post


Link to post
Share on other sites

I have a folder here called D:\darkmod, which has all the PK4 files and TheDarkMod.exe in it:

 

ddarkmod.jpg

 

I start DarkRadiant (either 2.5.0 or the most recent Git version) and set up the Game/Project paths like this:

 

gamesetup.jpg

 

DarkMod Path set to D:\darkmod

Mission: forest (I can select just any of these from the dropdown)

 

DR saves those settings and doesn't issue a warning. I can shut down DR and re-open it, both without any dialog, it keeps the settings.

 

My relevant log section looks like this:

GameManager: Selected game type: The Dark Mod 2.0 (Standalone)
GameManager: Map path set to D:/darkmod/fms/forest/maps/
GameManager: Prefab path set to D:/darkmod/fms/forest/prefabs/
Initialising filesystem using 2 paths
VFS Search Path priority is:
- D:/darkmod/fms/forest/
- D:/darkmod/

Can you try again on your end with the DarkMod path set to E:\darkmod? The mission list below the path should populate itself as soon as you enter E:\darkmod in the path box, so you should have the "campaign" option in there.

 

If it still keeps issuing a popup on startup, I'd like to see the darkradiant.log file from your Roaming\DarkRadiant folder, please.

Share this post


Link to post
Share on other sites

Testing now!

So using the same setting as above its not remembering, I get the following pop-up everytime -

post-496-0-32640200-1524511015_thumb.jpg

I removed the darkradiant prefs folder, same pop-up. I also checked I had full read/write perms to the prefs and program folders.

Edited by Bikerdude

Share this post


Link to post
Share on other sites

Why is there "E:\darkmod\darkmod\fms\bhm" in the mission box, instead of just "bhm" (which should be selectable from the dropdown)?

Share this post


Link to post
Share on other sites

Why is there "E:\darkmod\darkmod\fms\bhm" in the mission box, instead of just "bhm" (which should be selectable from the dropdown)?

TDM is putting it there at launch, I have to manually select BHM from the pull down every time.

Share this post


Link to post
Share on other sites

Ok, in that case, can you give me the darkradiant.log file from when such a startup dialog comes up, please?

Share this post


Link to post
Share on other sites

It's in C:\Users\\AppData\Roaming\DarkRadiant\darkradiant.log, or shorter: %appdata%\DarkRadiant\darkradiant.log

Share this post


Link to post
Share on other sites

Ok, in that case, can you give me the darkradiant.log file from when such a startup dialog comes up, please?

It's in C:\Users\<USERNAME>\AppData\Roaming\DarkRadiant\darkradiant.log, or shorter: %appdata%\DarkRadiant\darkradiant.log

darkradiant.log.txt

Share this post


Link to post
Share on other sites

Ok, two things I saw in the log:

 

2018-04-24 10:38:08 (3216) This is DarkRadiant 2.5.0pre2 x64

 

=> You're using the pre-release Version 2.5.0pre2. In the specific case of Game/Project setup this shouldn't make much difference, but there's no reason to stick with the pre2-Version.

 

2018-04-24 10:38:08 (3216) GameManager: Selected game type: The Dark Mod 2.0 (Standalone)
2018-04-24 10:38:08 (3216) Found fs_game_base command line argument, overriding existing mod base path.
2018-04-24 10:38:08 (3216) Found fs_game command line argument, overriding existing mod path.
2018-04-24 10:38:09 (3216) Auto-saving registry to user settings path.
2018-04-24 10:38:13 (3216) GameManager: Map path set to E:/Darkmod/fms/bhm/maps/
2018-04-24 10:38:13 (3216) GameManager: Prefab path set to E:/Darkmod/fms/bhm/prefabs/
2018-04-24 10:38:13 (3216) Initialising filesystem using 2 paths
2018-04-24 10:38:13 (3216) VFS Search Path priority is:
2018-04-24 10:38:13 (3216) - E:/Darkmod/fms/bhm/
2018-04-24 10:38:13 (3216) - E:/Darkmod/

 

=> I see you're starting DR with concrete command line arguments to override the project settings. Can you tell me how your shortcut looks like? Then I might be able to repro the problem.

Share this post


Link to post
Share on other sites

=> You're using the pre-release Version 2.5.0pre2. In the specific case of Game/Project setup this shouldn't make much difference, but there's no reason to stick with the pre2-Version.

=> I see you're starting DR with concrete command line arguments to override the project settings. Can you tell me how your shortcut looks like? Then I might be able to repro the problem.

oops, didnt realise that.

yes -

TDM - E:\Darkmod\TheDarkMod.exe +set r_fullscreen 0 +set com_allowConsole 1 +set r_fullscreen 0 +set fs_currentfm bhm

DR - "C:\Program Files\DarkRadiant\DarkRadiant.exe" fs_game_base=darkmod fs_game=darkmod/fms/bhm

 

Share this post


Link to post
Share on other sites
  • DR - "C:\Program Files\DarkRadiant\DarkRadiant.exe" fs_game_base=darkmod fs_game=darkmod/fms/bhm

 

I'm pretty sure the additional darkmod/ is coming from the red quoted part above. Try to use fs_game=fms/bhm and the dialog at startup should be gone.

Share this post


Link to post
Share on other sites

I'm pretty sure the additional darkmod/ is coming from the red quoted part above. Try to use fs_game=fms/bhm and the dialog at startup should be gone.

Awesome that, fixed it coming up with the wrong path, so the only issue now is that Im still getting the pop-up. I assume this because I am using concrete command line arguments, which didnt effect the previous versions of DR.

Share this post


Link to post
Share on other sites

You're still getting the dialog? I'll try to repro that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...