Jump to content
The Dark Mod Forums
Sign in to follow this  
koo

TDM x64 blank screen

Recommended Posts

TDM x64 starts with blank screen. Music is playing.

 

I get these warnings:

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

The same happens even if I use the settings described in the http://wiki.thedarkmod.com/index.php?title=What%27s_new_in_TDM_2.06#Old_TDM_Look .

 

I also used the patch provided on the https://www.moddb.com/mods/the-dark-mod/downloads/the-dark-mod-206-intel-glsl-fix without success. I don't know if I applied the patch correctly. I have simply overwritten the file. Is that OK?

The operating system I use is Linux. The VGA Controller is Intel.

 

Abayo.

Edited by koo

Share this post


Link to post
Share on other sites

TDM x64 starts with blank screen. Music is playing.

 

I get these warnings:

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

The same happens even if I use the settings described in the http://wiki.thedarkmod.com/index.php?title=What%27s_new_in_TDM_2.06#Old_TDM_Look .

 

I also used the patch provided on the https://www.moddb.com/mods/the-dark-mod/downloads/the-dark-mod-206-intel-glsl-fix without success. I don't know if I applied the patch correctly. I have simply overwritten the file. Is that OK?

 

The operating system I use is Linux. The VGA Controller is Intel.

 

Abayo.

I'd say your GPU is not compatible with TDM 2.06

I wish it was beta tested on a system old like that but it's quite rare I guess

Share this post


Link to post
Share on other sites

Download the 2.0 full installer from this listing:

 

https://www.moddb.com/mods/the-dark-mod/downloads

 

then use the tdm_updater to upgrade from 2.0 to 2.01 and so on then interrupt the 2.05 to 2.06

step.

 

Otherwise, use the 2.0 to 2.01 (etc) zip packages on that same page to iteratively update.


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Try if you have a distribution based on Ubuntu or derivatives:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt-get update

sudo apt dist-upgrade

 

For uninstall:

sudo apt-get install ppa-purge && sudo ppa-purge ppa:ubuntu-x-swat/updates

Edited by noni

Share this post


Link to post
Share on other sites

I believe it is possible to create updated version of shaders for 2.06.

Someone needs to unpack all shaders, then switch their version pragma to 120, then use glslvalidator on all of them.

Replace some in/out-s with varying/whatever, probably remove some code, and it will work.

Share this post


Link to post
Share on other sites

I believe it is possible to create updated version of shaders for 2.06.

Someone needs to unpack all shaders, then switch their version pragma to 120, then use glslvalidator on all of them.

Replace some in/out-s with varying/whatever, probably remove some code, and it will work.

I'm afraid it's not that simple

Shadowmap.gs will certainly break in any case and the only workaround for that is to delete the .pk4

We need to fix this in 2.07 anyway

Share this post


Link to post
Share on other sites

I think it's best for everyone if we fix this in 2.07 alpha

 

@koo, please try this and report the errors you have

http://forums.thedarkmod.com/topic/19257-testers-and-reviewers-wanted-bfg-style-vertex-cache/?p=429158

 

Since I haven't found the instructions for applying the 2.07 version I assumed overwriting the contents of my darkmod folder with the zip file contents should do the trick.

 

I have tried the configuration for old tdm look. (r_nvidiaOverride 0, r_softShadowsQuality 0, r_useFBO 0, r_useGLSL 0) as well as the default configuration file and both return the same result.

------------- Warnings ---------------

during The Dark Mod initialization...

WARNING:Couldn't load sound 'sound' using default

WARNING:file materials/tdm_epi_shader_2.mtr, line 462: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:366

WARNING:file materials/tdm_water.mtr, line 1208: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1

WARNING:shaderCompileFromFile(glprogs/ambientInteraction.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/ambientInteraction.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/blend.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/blend.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/cubeMap.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/cubeMap.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/depthAlpha.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/depthAlpha.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/fog.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/fog.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/interaction.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/interaction.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/oldStage.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/oldStage.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.gs) validation

P�,

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

WARNING:shaderCompileFromFile(glprogs/stencilShadow.vs) validation

0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

 

22 warnings

terminal support enabled ( use +set in_tty 0 to disabled )

pid: 15663

Async thread started

Couldn't exec autocommands.cfg - file does not exist.

Killed

 

 

Abayo.

Edited by koo

Share this post


Link to post
Share on other sites

 

Since I haven't found the instructions for applying the 2.07 version I assumed overwriting the contents of my darkmod folder with the zip file contents should do the trick.

 

I have tried the configuration for old tdm look. (r_nvidiaOverride 0, r_softShadowsQuality 0, r_useFBO 0, r_useGLSL 0) as well as the default configuration file and both return the same result.

Abayo.

Thanks

 

I will try to come up with a patch over the next few days

Share this post


Link to post
Share on other sites

Try

Reloadglslprograms

In game console

Also, attach your darkmod.cfg

 

Edit

Oh wait - you're on linux, right?

Someone will have to compile the main executable binary for you.

 

If you could build on your system, that would be great

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...