Jump to content
The Dark Mod Forums
Sign in to follow this  
Flanders

lights not working - fixed

Recommended Posts

Hi

 

I have a weird issue with playing the mod. All lights except for the ambient lights are not working. See attached image. This happens in all the missions I tried today.

The light gem doesn't light up and guards cannot see me if i move closer to a light. If I use the lantern the light gem becomes bright but there is no light in my surroundings from the lantern.

 

So I reinstalled tdm completely and I updated my nvidia geforce drivers but the issue remains unfortunately. Anybody has an idea what causes this?

 

i1zpdz.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Update:

If I use r_showlights 1 I see no lights

But if I use r_showlightcount 1 I get a colourful picture with different lights hitting each surface and if I move closer to a lantern post my light gem will light up. This doesn't happen if I set r_showlights to 0 again

 

:blink:

  • Like 1

Share this post


Link to post
Share on other sites

That's very weird. Which version of TDM are you running? What are your specs? Does r_useFBO 0 help?

Share this post


Link to post
Share on other sites

So I am playing TDM 2.06 on a windows 7 notebook with latest windows 7 updates. It's an acer aspire 5750G with intel core i5 with 6GB of memory and a NVIDIA geforce GT 520M for which i downloaded the latest updates

Share this post


Link to post
Share on other sites

Since you have a clean install, deleting darkmod.cfg shouldn't do much, but you might try that anyway. I think another user had similar problem lately, but can't find it.

 

Btw. what's your TDM install path? If possible, make it as simple as you can.

Share this post


Link to post
Share on other sites

Ok so I deleted darkmod.cfg and started the game again but the issue remains.

 

My install path is C:\Games\TDM. It was in program files before but I moved it since i had some read-only issues in the program files folder. But both before and after I moved it I had this issue

Share this post


Link to post
Share on other sites

Since you have a notebook, does it use this dual card setup? Like Intel integrated something + nvidia chip? I remember TDM had trouble with detecting my nvidia card sometimes, so I went to nvidia control panel and made a 3d settings profile for TDM, changing OpenGL rendering card option from Automatic to my nvidia card model.

  • Like 3

Share this post


Link to post
Share on other sites

Yessss that fixed it! I set the 'preferred graphics processor' to 'high performance NVIDIA processor' instead of 'auto-select' and it worked. The lights are back on. Thank you so much.

 

Somehow I did get a deja-vu feeling of some sorts, like I had this or a similar issue before and fiddling in the nvidia control panel fixed the issue... It must have been some time ago since I cannot quite remember what it was exactly.

  • Like 4

Share this post


Link to post
Share on other sites

This does bring to light that TDM engine needs a way to detect the principal GPU better in laptops, based on my search it seems you just use this exports in the engine for that.

extern "c"
{
   __declspec(dllexport) DWORD NvOptimusEnablement = 0x01;
   __declspec(dllexport) DWORD AmdPowerXpressRequestHighPerformance = 0x01; 
}
Edited by HMart

Share this post


Link to post
Share on other sites

 

This does bring to light that TDM engine needs a way to detect the principal GPU better in laptops, based on my search it seems you just use this exports in the engine for that.

extern "c"
{
   __declspec(dllexport) DWORD NvOptimusEnablement = 0x01;
   __declspec(dllexport) DWORD AmdPowerXpressRequestHighPerformance = 0x01; 
}

I suggest filing a feature request.

If you add links, it would be great.

Share this post


Link to post
Share on other sites

I suggest filing a feature request.

If you add links, it would be great.

 

Don't know if I did it correctly (or in the right place) but like you suggested i made a feature proposal in the bugtracker for this.

 

Share this post


Link to post
Share on other sites

Confirmed that 1) Set "r_useGLSL 0" and restart to revert to old shaders looks to be the easiest solution to fix this issue.


"I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

Share this post


Link to post
Share on other sites

Confirmed that 1) Set "r_useGLSL 0" and restart to revert to old shaders looks to be the easiest solution to fix this issue.

 

I would not call this a solution but a workaround, you are essentially disabling GLSL and returning to the old and deprecated ARB shaders, so losing the ability to use features implemented in the engine that require GLSL.

 

Of course this does make people, like me, that also add to disable GLSL, able to play the game and that ultimately is what matters but i hope is not a permanent workaround.

Share this post


Link to post
Share on other sites

 

I would not call this a solution but a workaround, you are essentially disabling GLSL and returning to the old and deprecated ARB shaders, so losing the ability to use features implemented in the engine that require GLSL.

 

Of course this does make people, like me, that also add to disable GLSL, able to play the game and that ultimately is what matters but i hope is not a permanent workaround.

 

You're right. But if it is permanent, maybe it can be included as a setting in the menu for older systems. Or we need new drivers or some such thing if TDM will not support ARB shaders anymore in the future.


"I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

Share this post


Link to post
Share on other sites

 

I would not call this a solution but a workaround, you are essentially disabling GLSL and returning to the old and deprecated ARB shaders, so losing the ability to use features implemented in the engine that require GLSL.

 

Of course this does make people, like me, that also add to disable GLSL, able to play the game and that ultimately is what matters but i hope is not a permanent workaround.

Do shadow maps work for you? Do you have access to svn?

Share this post


Link to post
Share on other sites

Do shadow maps work for you? Do you have access to svn?

 

No using r_shadows 2 makes them disappear, with r_useGLSL 0 but I assume that is the expected behavior?

 

About svn I don't think so, I have access to the bug tracker tho.

Share this post


Link to post
Share on other sites

Do shadow maps work for you? Do you have access to svn?

I presume you back-ported this to the 2.07 branch?

 

If you have compiles, upload them to Google drive, Drobox, Yandex, etc

 

and I will put them up on Moddb.

 

Otherwise let me know which source branch to compile.

 

If it's just Trunk then I'll need you to backport to 2.07 since the "cubemap reflect"

change you made in Trunk is not ready for production.


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

I presume you back-ported this to the 2.07 branch?

 

If you have compiles, upload them to Google drive, Drobox, Yandex, etc

 

and I will put them up on Moddb.

 

Otherwise let me know which source branch to compile.

 

If it's just Trunk then I'll need you to backport to 2.07 since the "cubemap reflect"

change you made in Trunk is not ready for production.

It's trunk

I would have posted it online already but I am waiting for someone with the problem to sign up for testing this.

When they confirm the fix I will merge to 2.07

Please note that these are two separate issues:

  1. no lights is missing ext_gpu_shader4 in MESA linux driver - the fix is to send an ifdef from C++ to GLSL.
  2. bad lights seems to be GLSL compiler bug in AMD 19.1 driver - work around is to move initialization code around the shader

P.S. great job AMD dropping the ball again. MESA is open source and is entitled to decide on the antique extension support and it actually kicked us in the right direction to add good useful stuff on our side. AMD just enjoys breaking working things and wasting everyone's time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...