Jump to content
The Dark Mod Forums
Sign in to follow this  
Wolf64

[Linux] arrow keys not recognized

Recommended Posts

Hello folks,

 

I'm a Linux (Mint) user and in games I'm using the arrow keys for movement (probably the worst kind of gamer to most of you) since I'm left-handed.

On both my Linux machines (Mint 18 and 19) TDM does not recognize the arrow keys and instead sets it to zero (0x00) on each arrow key pressed, making it impossible to configure the controls to use this scheme. However, the arrow keys on the numpad (8, 4, 6 and 2) are recognized as such, which is not what I want.

I've also tried different keyboards and different system layouts (since I'm using a german keyboard with the respective layout), but no success.

 

On Windows this is no problem, as all the keys are recognized correctly.

 

Any ideas regarding this issue?

Edited by Wolf64

Share this post


Link to post
Share on other sites

That bug has been around since ages for TDM on linux :mellow:

 

It didn't bother me that much in the past as I quickly adapted to use the numblock keys.

 

It's a bit annoying that I cannot acess system functions while I'm running TDM though - e.g. swich off sound, or minimize TDM and switch back to the desktop. That's what I miss most

Share this post


Link to post
Share on other sites

That bug has been around since ages for TDM on linux :mellow:

It didn't bother me that much in the past as I quickly adapted to use the numblock keys.

The issue with arrow keys may be not as easy as it seems.

Probably worth adding a bug for it.

 

It's a bit annoying that I cannot acess system functions while I'm running TDM though - e.g. swich off sound, or minimize TDM and switch back to the desktop. That's what I miss most

Note that a change for Linux side has been merged: 4190.

It changes the way TDM interacts with system controls, for better or worse...

Nightcrawler, I seriously suggest testing 2.07 beta.

Share this post


Link to post
Share on other sites

Thanks for pointing me to the new beta. I completely forgot about it.

I did some testing in the tutorial map and I'm really glad that I can use the system keys and also switch back to desktop now.

However I already found a bunch of new bugs:

  • Some keys (i.e the arrow keys and mouse button 4 and 5) still cannot be assigned properly.
  • The dark Mod crashes as soon as you enter the game if "Maps" was chosen as shadow implementation. I created a bug for this on the tracker.
  • Lightning does not work for me at all on the new version. Everything seems to be displayed in the same brightness. I also created a bug for this and put some screenshots there.

Share this post


Link to post
Share on other sites

I have added the arrow keys issue to the bugtracker: #4963

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...