Jump to content
The Dark Mod Forums
Sign in to follow this  
stgatilov

Testers needed: Windows Vista and non-Ubuntu Linux

Recommended Posts

We have done some major changes in the way TDM is built, changing toolsets, third-party libraries, etc.

It would be great to check that the new build still works on old Windows and some Linuxes.

 

The following volunteers are needed:

1) who play TDM on Windows Vista

2) who play TDM natively on Linux (preferably on non-Ubuntu distribution)

 

The instructions for testing are rather simple:

1) Backup your TDM 2.07 installation.

2) Download several files (exe/pk4) to TDM installation directory (replacing whatever is there).

3) Start TDM game, open console and verify that number 8165 is present in the lower-right corner.

4) While in-game, check that you can download some FM, can start some mission, cinematics play, save/load works (with correct savegame preview screenshots).

5) Start tdm_update and let it go (it will downgrade back to official TDM 2.07).

No in-depth testing is required: it is just a brief check that it does not crash on start / on first use of some library.

 

Link to testing archive

  • Like 1

Share this post


Link to post
Share on other sites

I have an old Dell Optiplex 960 that runs Vista. The thing is, I'm not sure if it can run TDM (I tried installing it about a year or so ago but the game crashed). This is what it has, Vista Business 32-Bit SP2, Intel Core2 Duo CPU E8400 @ 3.00GHz, 4.0GB RAM, ATI Radeon HD 5450

 

I'd be happy to try again but I can't promise that the results will reveal a OS problem or if it will be from some sort of other problem like for example, a ATI Radeon HD 5450 problem.

 

Update:

I downloaded TDM and everything went splendidly but then when it tried to download Microsoft Visual C++, the program stalled and then it froze - no joy for me.

Microsoft Visual C++ 2017

Redistributable (x86) – 14.14.26405

 

http://Untitled.jpgbp fuel station finder

Edited by Jetrell

Share this post


Link to post
Share on other sites

Thank you for response!

 

I have added the link in the original post.

You can kill tdm_update process when it tries to install VC redist. The testing package does not need it.

Share this post


Link to post
Share on other sites

Hm... i had a similar issue when i last did a update with the TDM Updater. It told me it installed VC Redist, but then said it couldn't be installed, and, when i tried to manually install it, from the TDM folder, it told me that it is already installed, or a newer version is installed, or something similar.

Share this post


Link to post
Share on other sites
I have added the link in the original post.

You can kill tdm_update process when it tries to install VC redist. The testing package does not need it.

Thanks for the link, I used it and got TDM to work, which was a big and happy surprise. I started the Training Mission, A New Job, and Tears of St. Lucia. I had terrible video distortions but I'm certain that has nothing to do with TDM and everything to do with my old and sad video card but as a result I was only able to skim through the maps.

 

To the information that you wanted:

This was a completely new install, after the download, I had TDM 2.08/32

While in-game, everything seemed to work just fine, missions started, cinematics played, save/load worked. I had a crash but again, I'm certain it was my video card's fault.

I tried "Start tdm_update" but it didn't work and I got this instead.

 

untitled2.jpg

  • Like 1

Share this post


Link to post
Share on other sites
I tried "Start tdm_update" but it didn't work and I got this instead.

Yes, this is exactly why I started this testing :D

I'll have to define PSAPI_VERSION to workaround it (as described here).

 

I will create a new build, but a bit later.

I'm afraid 2.07-hotfix needs attention this weekend.

  • Like 1

Share this post


Link to post
Share on other sites

Can we have a dedicated "2.08 beta" thread to avoid any confusion? (Maybe just renaming this one)

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

Can we have a dedicated "2.08 beta" thread to avoid any confusion? (Maybe just renaming this one)

This is in no way 2.08 beta.

I simply build some TDM binaries and kindly ask players to test them.

This thread will go down by itself after a week or so, I guess.

Share this post


Link to post
Share on other sites

I tried "Start tdm_update" but it didn't work and I got this instead.

Please download new version, and overwrite all the stuff with its contents.

Then try again.

 

I'm currently using Manjaro Linux, so I guess I can give it a spin over the course of the weekend...

Yes, please.

This will be a good test case.

  • Like 1

Share this post


Link to post
Share on other sites

Please download new version, and overwrite all the stuff with its contents.

Then try again.

I downloaded the new version but sadly there was still no joy.

This is what happened, after the TDM download, it told me that I needed to install VC myself which I did but the download froze.

untitled2.jpg

  • Like 1

Share this post


Link to post
Share on other sites

I downloaded the new version but sadly there was still no joy.

This is what happened, after the TDM download, it told me that I needed to install VC myself which I did but the download froze.

Ignore that.

The build being tested does not need redistributable, so I will remove this part from tdm_update.

The main thing is that the updater started, downloaded a bit of files, and finished properly (aside from this warning). Right?

I think we can stop here.

 

I wish to hear some more feedback from testers with Linux.

In the meantime, if someone takes time to briefly test this on Windows 7 --- that would be helpful (just to be sure).

  • Like 1

Share this post


Link to post
Share on other sites
The main thing is that the updater started, downloaded a bit of files, and finished properly (aside from this warning). Right?

Yes, that's exactly what happened.

Share this post


Link to post
Share on other sites

Never got to do this ever thew weekend, so will try and do it this evening.

So my old spare Dell D630 is quite dead, so I am doing a vbox install and will see how it goes.

Share this post


Link to post
Share on other sites

So my old spare Dell D630 is quite dead, so I am doing a vbox install and will see how it goes.

I think virtualbox is overkill.

Better wait for someone who already has the setup for proper testing.

Share this post


Link to post
Share on other sites

VMPlayer is already better than Virtualbox (gamer use case).


Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

You can kill tdm_update process when it tries to install VC redist. The testing package does not need it.

As I was at work I just let it install everything and it installed flawlessly on Vbox

I think virtualbox is overkill.

Its running on a 2015 Macbook air so if anything its not powerfull enough, but cant get openGL enabled. I have another older laptop that 'may' be capable of taking vista, so will try that...

Share this post


Link to post
Share on other sites

Sorry for the delay, RL got in the way.

Tested it today (Manjaro Linux 64bit with latest packages).

 

Downloaded the files, copied them over, started the game, all fine (version number in console is 8165).

Save/load works, get a low-res screenshot, too.

Downloaded a FM (and installed/started it), check.

Finished with starting the updater, which apparently worked without any issues.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...