Jump to content
The Dark Mod Forums
mcmike1489

TDM can't update

Recommended Posts

I keep getting this error message saying that "Microsoft Visual C++ redistributable package failed to install. You have to install it yourself in order to run the game. Run vcredist_x86.exe and  vcredist_x64.exe in game directory and make sure installation completes successfully. I already have the latest version of the package from when I update Windows 10 from Windows update. Why is this happening to me? How do I fix it to make it go away?

Share this post


Link to post
Share on other sites

Yes, the game works just fine but the problem I am having is that I can't update TDM from the "tdm_update.exe" It just won't update for anything current up to this point.

Share this post


Link to post
Share on other sites

Disregard this warning about "Microsoft Visual C++ redistributable". The only case when it is a real problem is when you start TDM and it crashes right away with some dialog box. Since it is not happening to you, it is not a problem for you.

Could you please tell us which version of TDM you have? Also, attach tdm_update.log file which should be created when you run tdm_update.

P.S. I guess the most likely culprit is our sick server not serving some of the files.

  • Thanks 1

Share this post


Link to post
Share on other sites

I am using TDM version 2.07 as the latest version up to date, no using older versions of the game. Oh ok, maybe whenever the next version for the game which is 2.08 Hopefully it will fix the updating problem. I'm sure it is the server that doesn't recognize the package file for Microsoft Visual C++ redistributable  No need to uninstall and reinstall Microsoft Visual C++ redistributable, I've done that before and it didn't work the way I wanted to so I learned my lesson that time.

tdm_update.log

Edited by mcmike1489

Share this post


Link to post
Share on other sites

Yes, just ignore the message if you already installed the package.

Some solutions for the updater:
(but i dont know if the updater does this. but in the update-log you see it detects some things of my vc installation)

  • program the installer that its installing the right bit-version.
    On my x64 system, the updater wants to install the x86. (in the updaterlog it detects my 64-bit system)
  • Using another vc_redist installer, instead of 2017, maybe use 2015-2019.
    (https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads)
  • Check if some files already exists.
  • start the vcredist installer in quet-mode, use its log argument and search in the log for error "0x80070666" (=if its already installed)
    (https://www.itninja.com/software/microsoft/visual-c-redistribuable-2017/v14-1)
  • etc.
Edited by freyk

Share this post


Link to post
Share on other sites

Ok, I fixed the problem, I had to uninstall the redistributable package in order for TDM to install the files for the updater to work properly.

Edited by mcmike1489

Share this post


Link to post
Share on other sites

I'm having the same problem (had it for some time now, but, always ignored it). I'll just ignore it for now, as i don't know if one of my installed games or programs requires the C++ redistributable which the one from TDM obviously collides with.

Share this post


Link to post
Share on other sites

Guys, don't pay to much attention to this stupid redistributable.

  1. If it does not install, it will not cause any problems. Unless you get immediate crash with a dialog box when you start TDM, simply ignore whatever the updater is saying about it.
  2. The redistributable packages should not collide and make conflicts. You can have many of them installed simultaneously. Sometimes installing a new one upgrades the previous one: in this case everything which worked with older redist should work with the newer redist too.
  3. I have already removed dependency of TDM on VCRedist package, and removed that dreadful "Installing VC Redist" step from updater. Nobody will ever have such problems any more.

 

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...