Jump to content


Photo

Trouble installing FMs


  • Please log in to reply
5 replies to this topic

#1 killhour

killhour

    Member

  • Member
  • PipPip
  • 125 posts

Posted 07 April 2010 - 01:36 PM

Every time I try to install a new FM, I get this error:


--------- Initializing Game ----------
The Dark Mod 1.00, code revision 3718
Build date: Oct 13 2009
Initializing event system
...759 event definitions
Initializing class hierarchy
...183 classes, 400752 bytes for event callbacks
Initializing scripts
--------- Game Map Shutdown ----------
--------------------------------------
********************
ERROR: Error: file script/tdm_events.script, line 41: Unknown event 'frobHilight'


********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

I can load my existing installed FM just fine. What's going on?

#2 Fidcal

Fidcal

    Master Mapper

  • Development Role
  • PipPipPipPipPip
  • 16678 posts

Posted 07 April 2010 - 02:42 PM

It may be that your last update did not complete. Run tdm_update.exe again and again until you see the message: "All done, your TDM installation is up-to-date. Enjoy!" Let us know if that doesn't solve the problem

#3 killhour

killhour

    Member

  • Member
  • PipPip
  • 125 posts

Posted 07 April 2010 - 04:36 PM

It may be that your last update did not complete. Run tdm_update.exe again and again until you see the message: "All done, your TDM installation is up-to-date. Enjoy!" Let us know if that doesn't solve the problem


Nope, still not working.

#4 Serpentine

Serpentine

    Uber member

  • Active Developer
  • PipPipPipPip
  • 2903 posts

Posted 07 April 2010 - 04:42 PM

--------- Initializing Game ----------
The Dark Mod 1.00, code revision 3718
Build date: Oct 13 2009

Seems to indicate you're having trouble updating.
Where is your darkmod folder located?
Uninstall your current FM then close TDM and run the updater.
Try search your doom3 folder for all gamex86.dll's and delete them all then run the updater again

(I have a feeling that the updater might need to delete all the dll's between major updates)

#5 killhour

killhour

    Member

  • Member
  • PipPip
  • 125 posts

Posted 07 April 2010 - 05:59 PM

--------- Initializing Game ----------
The Dark Mod 1.00, code revision 3718
Build date: Oct 13 2009

Seems to indicate you're having trouble updating.
Where is your darkmod folder located?
Uninstall your current FM then close TDM and run the updater.
Try search your doom3 folder for all gamex86.dll's and delete them all then run the updater again

(I have a feeling that the updater might need to delete all the dll's between major updates)


Figured it out. It was in the program files folder, so I needed to give tdmlauncher.exe admin privileges to install the FM.

#6 Serpentine

Serpentine

    Uber member

  • Active Developer
  • PipPipPipPip
  • 2903 posts

Posted 07 April 2010 - 06:09 PM

Figured it out. It was in the program files folder, so I needed to give tdmlauncher.exe admin privileges to install the FM.


Thought it might have been that :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users