Jump to content


Crash with "The Thieves"


17 replies to this topic

#1 Professor Paul1290

    Member

  • Member
  • PipPip
  • 253 posts

Posted 07 March 2011 - 02:08 PM

Whenever I try to start the FM called "The Thieves" it crashes as soon as it's finished loading.

I have not had any problems with any of the other FMs that I've tried, which so far include:
-The Crown of Penitence
-The Outpost
-The Parcel
-Too Late.
-Thomas Porter series
-No Honor Among Thieves series
-Thieves Den series
-Lockdown
-Return to the City
-Some others I can't remember off the top of my head right now...


Is there something different about "The Thieves" in particular that would cause it to crash like this? Again, this is the only FM I've had this problem with so far so I guess there must be something different about it.


EDIT:
Ok, it seems that "Trapped!" does the same thing for me. Not sure if it's related or not though.

Edited by Professor Paul1290, 07 March 2011 - 02:24 PM.


#2 jaxa

    Advanced Member

  • Member
  • PipPipPip
  • 819 posts

Posted 07 March 2011 - 02:17 PM

Lol: http://modetwo.net/d...e-dark-mod-104/
Houston, we have a problem.

#3 jaxa

    Advanced Member

  • Member
  • PipPipPip
  • 819 posts

Posted 08 March 2011 - 02:09 AM

I can confirm that "Trapped!" also crashes for me on "Mission Loaded... Please Wait."

#4 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 03:24 AM

Thieves crashes here as well...

Is there a reason for the extra complex "angle" in the info_player_start entity?


// entity 213
{
"classname" "info_player_start"
"name" "info_player_start_1"
"angle" "-1.4033418253411173e-014"
"origin" "-1374 -92 -244"
}


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#5 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 04:21 AM

More Detail:

Windows Error log events:

Faulting application doom3.exe, version 1.0.0.1,
faulting module gamex86.dll, version 0.0.0.0, fault address 0x002bd3f6.

0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 64 6f 6f ure doo
0018: 6d 33 2e 65 78 65 20 31 m3.exe 1
0020: 2e 30 2e 30 2e 31 20 69 .0.0.1 i
0028: 6e 20 67 61 6d 65 78 38 n gamex8
0030: 36 2e 64 6c 6c 20 30 2e 6.dll 0.
0038: 30 2e 30 2e 30 20 61 74 0.0.0 at
0040: 20 6f 66 66 73 65 74 20 offset
0048: 30 30 32 62 64 33 66 36 002bd3f6
0050: 0d 0a ..

Fault bucket -1950341116.

0000: 42 75 63 6b 65 74 3a 20 Bucket:
0008: 2d 31 39 35 30 33 34 31 -1950341
0010: 31 31 36 0d 0a 116..


I have attached a conDump of a Thieves dmap


Also, the "script" directory in the PK4 was empty...

Attached Files


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#6 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 06:04 AM

"Trapped!" also crashes as above...
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#7 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 06:14 AM

Just random testing of a couple more oldies...

Crown of Penitence (Perfect)

Awaiting the Storm... same crash behavior :(
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#8 greebo

    Heroic Coder

  • Root
  • 15,327 posts

Posted 08 March 2011 - 06:18 AM

I can confirm the crash in SVN. It's atdm_ai_rat_small_5 which is running into a NULL when accessing memory.currentPath.

http://bugs.angua.at/view.php?id=2683

#9 grayman

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 8,031 posts

Posted 08 March 2011 - 10:47 AM

I've found and fixed this problem in SVN.

However, the problem causes the following missions to crash at the start with 1.04:

Special Delivery
The Thieves
Storm
Trapped


#10 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 12:48 PM

I removed the "Patrol" spawnarg (it was only assigned to rats and one map only had one instance another was like three...) from all four maps and now they work fine in 1.04.

I am uploading to my dropbox account but if someone wants to beat me to the punch that would be great.

:)

Edit: Nevermind... Here they are:

Trapped!

http://dl.dropbox.co...561/trapped.pk4

Awaiting the Storm

http://dl.dropbox.co...06561/storm.pk4

Thieves!

http://dl.dropbox.co...561/thieves.pk4

Special Delivery

http://dl.dropbox.co...61/delivery.pk4

:D

Edited by nbohr1more, 08 March 2011 - 12:52 PM.

Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#11 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 03:38 PM

Any comments?

I don't think these fixes have any detrimental effect on the "rat ambience" for these maps?

Would these changes be acceptable to distribute officially?

:unsure:
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#12 jaxa

    Advanced Member

  • Member
  • PipPipPip
  • 819 posts

Posted 08 March 2011 - 05:45 PM

So is the real solution (considering it was a map breaker) to update these maps or push 1.05?

#13 nbohr1more

    Uber member

  • Member
  • PipPipPipPip
  • 4,343 posts

Posted 08 March 2011 - 05:51 PM

I am speculating that the "Patrol" spawnarg was an attempt to get the rats to run around the maps properly. Now that Grayman has fixed most of the rat behavior, I don't think those heroics are required.

I didn't get a ton of test time but the rat at the beginning of Trapped wandered the prison just as cheerfully as I recall from before...

Is it really worth fretting over now?
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.com/mods/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#14 Springheel

    Creative Director

  • Admin
  • 31,904 posts

Posted 08 March 2011 - 08:29 PM

Quote

Would these changes be acceptable to distribute officially?

Better to fix the mod rather than change all the maps.
Posted Image

#15 New Horizon

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 13,139 posts

Posted 11 March 2011 - 10:56 PM

Is this crash supposed to be fixed in the latest SVN? Trapped is still crashing for me.

#16 New Horizon

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 13,139 posts

Posted 12 March 2011 - 08:19 AM

Loading now after compiling a new dll.

#17 grayman

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 8,031 posts

Posted 12 March 2011 - 10:39 AM

View PostNew Horizon, on 11 March 2011 - 10:56 PM, said:

Is this crash supposed to be fixed in the latest SVN? Trapped is still crashing for me.

Source rev 4667 has the fix.

#18 New Horizon

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 13,139 posts

Posted 12 March 2011 - 10:54 AM

View Postgrayman, on 12 March 2011 - 10:39 AM, said:

Source rev 4667 has the fix.

Awesome. :) Yeah, I wasn't sure if the fix was in the main trunk or only in source. Thanks Grayman. All the fixes are great. The AI just keep getting better and better.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users