Jump to content


Photo

Graphics stuttering solution


  • Please log in to reply
9 replies to this topic

#1 blockhead

blockhead

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 23 October 2013 - 01:21 AM

I'm not sure how many people get stuttering with this game but there is one solution which works for me in this and Doom 3.

In the same folder as your config file make a file called "autoexec.cfg" and open with a text editor and input: seta com_fixedtic "1"

I played Doom 3 several times over the years before I found that setting. This could help people new to the game(s).

As a side-note there is also a similar fix for quake 1 that i am currently using with dark places which is: set sys_ticrate 0.0166667

I'm running at 60hz

Edited by blockhead, 23 October 2013 - 01:27 AM.


#2 Bikerdude

Bikerdude

    Member

  • Banned
  • PipPipPipPipPip
  • 20320 posts

Posted 23 October 2013 - 02:47 AM

What are you full system specs..?

#3 mojmir

mojmir

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 23 October 2013 - 05:35 AM

I tried TDM yesterday and in the first place let me say that it looks very very good.

But I experience the stuttering too so I will try this variable later this evening and see if it helps.

Forgot my specs: Amd fx 8320 OC to 3800, bit OC geforce 580, 8Gb ram ddr3 1600, win7 on ssd, game too

Edited by mojmir, 23 October 2013 - 07:46 AM.


#4 Lydecker

Lydecker

    Member

  • Member
  • PipPip
  • 28 posts

Posted 23 October 2013 - 06:38 AM

On my elderly hardware set I too experience some stuttering, usually at the beginning of a mission. If it does not calm down in a minute or two, I just do Quick save & load and it's all right again. Does not happen often, latest mission was Lords & Legacy, I believe and even then only on very first run. Very mild annoyance.

Quick specs: 2nd gen i7, 660Ti, 12Gb RAM, SSDs for both OS and games.

#5 Bikerdude

Bikerdude

    Member

  • Banned
  • PipPipPipPipPip
  • 20320 posts

Posted 23 October 2013 - 12:35 PM

neither of you guys should getting any stutter on the systems you have :-/

#6 AluminumHaste

AluminumHaste

    Darkmod Contributor

  • Development Role
  • PipPipPipPipPip
  • 6317 posts

Posted 23 October 2013 - 03:58 PM

I'm not sure how many people get stuttering with this game but there is one solution which works for me in this and Doom 3.

In the same folder as your config file make a file called "autoexec.cfg" and open with a text editor and input: seta com_fixedtic "1"

I played Doom 3 several times over the years before I found that setting. This could help people new to the game(s).

As a side-note there is also a similar fix for quake 1 that i am currently using with dark places which is: set sys_ticrate 0.0166667

I'm running at 60hz


com_fixedtic is always on. You used to be able to disable it to, but Id removed that ability long time ago in patch 1.2 I believe.

com_fixedTic [-1,0,1] - If set to 0 (the default) Doom 3's ticrate is capped at 60FPS, meaning the game framerate cannot exceed this, except when running a timedemo. If you want to remove this cap, set com_fixedTic to -1. Setting it to 1 removes the cap, but causes the game physics to go out of sync. Removing the FPS cap doesn't necessarily improve performance, and can lead to more variable framerates. Note that com_fixedTic -1 doesn't work as of the latest patch.

I always assumed I'd taste like boot leather.

 

#7 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9518 posts

Posted 23 October 2013 - 04:23 PM

Not sure whether this even applies to the GPL code. Is it still disabled there too :)
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#8 Serpentine

Serpentine

    Uber member

  • Active Developer
  • PipPipPipPip
  • 2903 posts

Posted 23 October 2013 - 10:47 PM

Still applies, iirc you need ti disable fixed tic and then enable some other async thing. The result is : shit goes bananas.

Once again, it doesnt fix the stuttering problem at all. That said, after the gpl, and enabling the extra caching systems, TDM seems way smoother for me. Still a bit of tearing. The only real way to dig deeper is to really profile the hell out of everything and tighten the screws as far as possible. Hopefully this allows both a better general FPS and enough for people to enable double buffering by default.

These days with compositing windows managers and the like, double/triple buffering can also cause a lot of problems too. (I wouldn't be surprised if disabling nV's 'threading optimizations' made TDM feel a bit better too, since that is horribly broken with Aero.)

#9 mojmir

mojmir

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 24 October 2013 - 03:56 AM

are there some internal profiling tools in the doom sdk?

Edited by mojmir, 24 October 2013 - 03:57 AM.


#10 Serpentine

Serpentine

    Uber member

  • Active Developer
  • PipPipPipPip
  • 2903 posts

Posted 24 October 2013 - 05:04 AM

'Sort of'

In reality, they'll be more useless than external tools. Specially with fine grained timing and needing to know about hardware. It's a job for later on, once we have got past the whole porting to something less crap than the gpl release :)

Really need some guys that have a clue with graphics stuff. I will just be moving this stuff, I know nothing of the underlying bits. So long as it works... that's as much as I can do.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users