Jump to content


Missing libraries in Linux after update


70 replies to this topic

#1 ianrace

    Member

  • Member
  • PipPip
  • 20 posts

Posted 30 January 2014 - 06:40 PM

Hi all. Dark Mod had no troubles on my Linux box running Ubuntu before the update. The update itself ran smoothly, but the game now refuses to run. I tried to launch it from Terminal to see what was going on and it looks like it's missing the libcurl.so.4 library.

I then tried to run the updater again, but it now says that I don't have permission to run the program, even though all the Ubuntu permission are set properly for both the directory and file.

Any help would be appreciated. Thanks, as always.

Kevin

#2 grayman

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 8,029 posts

Posted 30 January 2014 - 08:07 PM

taaaki will hopefully be along soon to help out.

#3 lost_soul

    Advanced Member

  • Member
  • PipPipPip
  • 1,380 posts

Posted 30 January 2014 - 08:20 PM

I had this problem too. You need to install the package libcurl3:i386 if you are on 64-bit or libcurl3 if you are on 32-bit.
License Agreement: Before you can play the game you bought, you must sign up for 6 online profiles. This way we can gather all kinds of usage data about you whether you like it or not, sell your personal information, or just lose control of it to hackers when our database gets compromised some day. Although you purchased that game, nothing is really yours and we will revoke your right to play it whenever we feel like doing so.

#4 ianrace

    Member

  • Member
  • PipPip
  • 20 posts

Posted 30 January 2014 - 08:43 PM

Sorry if this a dumb question, but from where do I install that? While I've found mention of it online. I can't find the name of any packages that might actually have it. I did try to install exactly what you typed from apt-get, but no dice. Is there a special ppa I need to direct Ubuntu towards?

#5 ianrace

    Member

  • Member
  • PipPip
  • 20 posts

Posted 30 January 2014 - 08:45 PM

Never mind. I forgot to include the word "install" Silly me.

The game works again! Thanks for all the help thus far. The only thing I still haven't been able to figure out is why I no longer have permission to run the updater.

Edited by ianrace, 30 January 2014 - 08:47 PM.


#6 lost_soul

    Advanced Member

  • Member
  • PipPipPip
  • 1,380 posts

Posted 30 January 2014 - 10:03 PM

You can right-click on the file and see if it is marked executable under properties.

Edited by lost_soul, 30 January 2014 - 10:06 PM.

License Agreement: Before you can play the game you bought, you must sign up for 6 online profiles. This way we can gather all kinds of usage data about you whether you like it or not, sell your personal information, or just lose control of it to hackers when our database gets compromised some day. Although you purchased that game, nothing is really yours and we will revoke your right to play it whenever we feel like doing so.

#7 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 30 January 2014 - 11:04 PM

Glad you got it sorted out. I guess this should probably go into the wiki.
I am the bat. The night is mine.

#8 i30817

    Member

  • Member
  • PipPip
  • 443 posts

Posted 31 January 2014 - 08:57 AM

That library should be static you mean, not go into the wiki. If you ever want 'filesystem portability' of keeping a darkmod around across installs or portable, you need to statically link all required libraries.

Edited by i30817, 31 January 2014 - 08:58 AM.


#9 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 31 January 2014 - 10:41 AM

View Posti30817, on 31 January 2014 - 08:57 AM, said:

That library should be static you mean, not go into the wiki. If you ever want 'filesystem portability' of keeping a darkmod around across installs or portable, you need to statically link all required libraries.

Welp, that's probably my bad. It should be easy enough to fix that though. I think there are other libs (libpng springs to mind) that are dynamically linked so I'll have to comb through with ldd and move what I can to static libs (but using system provided static libs instead of those "maintained" in the project tree). Stuff like X libs will stay dynamic though.
I am the bat. The night is mine.

#10 ianrace

    Member

  • Member
  • PipPip
  • 20 posts

Posted 01 February 2014 - 10:26 AM

View Postlost_soul, on 30 January 2014 - 10:03 PM, said:

You can right-click on the file and see if it is marked executable under properties.

And that would do it. For some reason, the file had removed the executable checkmark. I put it back and it works fine now. Thanks for all the help.

#11 Araneidae

    Member

  • Member
  • PipPip
  • 119 posts

Posted 02 February 2014 - 06:17 AM

I think there may be an issue here with the updater: after running the updater (tdm_update.linux) I had exactly the issues reported here:
  • New libcurl dependency (no big deal)
  • Updated tdm_update.linux no longer marked as executable
Is this (2) already reported as a bug? If not, it *is* a bug!

P.S. How's the 64-bit build coming along?

#12 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 03 February 2014 - 04:44 AM

View PostAraneidae, on 02 February 2014 - 06:17 AM, said:

I think there may be an issue here with the updater: after running the updater (tdm_update.linux) I had exactly the issues reported here:
  • New libcurl dependency (no big deal)
  • Updated tdm_update.linux no longer marked as executable
Is this (2) already reported as a bug? If not, it *is* a bug!


P.S. How's the 64-bit build coming along?

1) I'm going to fix the updater for the next update to have libcurl statically compiled, so this shouldn't be and issue next time (not sure what possessed me to make it dynamic)
2) I will investigate this as well since I can't recall any changes to the updater that would cause this (I had a quick peek at the code and from what I saw, it should be getting marked as executable -- will have to look at it properly though).

64-bit build will come when we successfully merge dhewm3 changes into TDM. Will have to poke serp to see if he's made any further progress.
I am the bat. The night is mine.

#13 Grubber

    Member

  • Member
  • PipPip
  • 37 posts

Posted 04 February 2014 - 08:09 AM

I'm trying to run the game on arch linux x64. Lib32-curl 7.34.0-2 is installed (also lib32-openssl 1.0.1.f-1). But i get the following error:

./thedarkmod.x86: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./thedarkmod.x86)

As far as i can tell this means my version is too new? Any idea on how to get the correct version?

#14 lost_soul

    Advanced Member

  • Member
  • PipPipPip
  • 1,380 posts

Posted 04 February 2014 - 10:22 AM

Not sure, but if you're really desperate, you can:

A: Hunt down a copy of the required .so file from some other distro like Ubuntu 13.10. (It has the proper version)
B: place it in your darkmod folder
C: Use LD_LIBRARY_PATH to force it to use the local file instead of the default /usr/lib location.

See also: http://www.linuxques...preload-235321/

Edited by lost_soul, 04 February 2014 - 10:28 AM.

License Agreement: Before you can play the game you bought, you must sign up for 6 online profiles. This way we can gather all kinds of usage data about you whether you like it or not, sell your personal information, or just lose control of it to hackers when our database gets compromised some day. Although you purchased that game, nothing is really yours and we will revoke your right to play it whenever we feel like doing so.

#15 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 04 February 2014 - 10:40 AM

View PostGrubber, on 04 February 2014 - 08:09 AM, said:

I'm trying to run the game on arch linux x64. Lib32-curl 7.34.0-2 is installed (also lib32-openssl 1.0.1.f-1). But i get the following error:

./thedarkmod.x86: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./thedarkmod.x86)

As far as i can tell this means my version is too new? Any idea on how to get the correct version?

I'll see if I can't build a new bin file for you with the libs statically compiled. Will PM you with the details.

Edit: Didn't get enough time to sort this out. Will have another go tomorrow.
I am the bat. The night is mine.

#16 Grubber

    Member

  • Member
  • PipPip
  • 37 posts

Posted 04 February 2014 - 12:00 PM

@Taaaki, that would be great!

@Lost_Soul, seems like something that might work also, i'll just wait on the new file for now though.

Offtopic: about your signature: i got this in my xorg.conf to get the old zap X functionality back:

Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


#17 mathi_r

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 05 February 2014 - 10:44 AM

Same problem here also!!!!!!!! Also Arch x64!

#18 Grubber

    Member

  • Member
  • PipPip
  • 37 posts

Posted 06 February 2014 - 02:43 AM

Taaaki fixed it! With the new files i now have one of the best games out there on the best distro = win-win.
Hope this will be available for everyone soon.

Now i will have to do severe 'testing' on each and every map i haven't played so far. And perhaps the other ones as well.


PS: Had to install lib32 packages for ALSA and PULSE to get sound working.

#19 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 06 February 2014 - 11:57 AM

Well, the workaround bins I gave you just disabled the HTTPS download capability and reverted to the old static lib. I'm working on proper solution to the problem for the next release whenever that is.
I am the bat. The night is mine.

#20 Bastacyclop

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 20 February 2014 - 05:43 AM

View PostGrubber, on 04 February 2014 - 08:09 AM, said:

I'm trying to run the game on arch linux x64. Lib32-curl 7.34.0-2 is installed (also lib32-openssl 1.0.1.f-1). But i get the following error:

./thedarkmod.x86: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./thedarkmod.x86)

I have the same problem on Manjaro x64.

View Posttaaaki, on 06 February 2014 - 11:57 AM, said:

Well, the workaround bins I gave you just disabled the HTTPS download capability and reverted to the old static lib. I'm working on proper solution to the problem for the next release whenever that is.

Could I get these bins ? ^_^

#21 taaaki

    Advanced Member

  • Member
  • PipPipPip
  • 578 posts

Posted 20 February 2014 - 07:57 AM

Check your PM :smile:
I am the bat. The night is mine.

#22 Shadow53

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 23 February 2014 - 11:46 AM

Just thought I would mention for the Arch users here and who might find this page like I did - I submitted an AUR package that successfully builds and installs for Arch Linux (with help from taaaki's static bins). Look for it in the comments (I have the same username there) because as of now the maintainer has not updated it. Hope this helps someone.

PS - Users of other distributions can download the package and use the links in the PKGBUILD file to download the static bins as well.
-- Shadow53

#23 mips

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 01 March 2014 - 09:16 AM

View PostShadow53, on 23 February 2014 - 11:46 AM, said:

Just thought I would mention for the Arch users here and who might find this page like I did - I submitted an AUR package that successfully builds and installs for Arch Linux (with help from taaaki's static bins). Look for it in the comments (I have the same username there) because as of now the maintainer has not updated it. Hope this helps someone.

PS - Users of other distributions can download the package and use the links in the PKGBUILD file to download the static bins as well.

Hi,

I tried the pkgbuild you posted in the AUR comments section. The package builds and at the end of the installation of darkmod-2.01-1-x86_64.pkg.tar.xz I get the following errors,

/tmp/alpm_YYImnc/.INSTALL: line 2: [: missing `]'
chmod: missing operand after ‘g=rwx’
Try 'chmod --help' for more information.

If I launch the game all I get is a black screen with a mouse pointer which I cannot exit from.

Edited by mips, 01 March 2014 - 09:17 AM.


#24 Shadow53

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 01 March 2014 - 03:47 PM

View Postmips, on 01 March 2014 - 09:16 AM, said:

Hi,

I tried the pkgbuild you posted in the AUR comments section. The package builds and at the end of the installation of darkmod-2.01-1-x86_64.pkg.tar.xz I get the following errors,

/tmp/alpm_YYImnc/.INSTALL: line 2: [: missing `]'
chmod: missing operand after ‘g=rwx’
Try 'chmod --help' for more information.

If I launch the game all I get is a black screen with a mouse pointer which I cannot exit from.

I fixed the error. I forgot to specify which folder to chmod -- silly mistake. It is fixed now so you shouldn't have any more issues.
-- Shadow53

#25 mips

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 02 March 2014 - 05:45 AM

Just some feedback. I have got TDM running now using both the TDM installer with taaaki's static bins and Shadow53's pkgbuild.

Thanks guys!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users