Jump to content


Photo

Problems I had with TDM Installation on Linux w/ Solutions


  • Please log in to reply
8 replies to this topic

#1 bedhead

bedhead

    Member

  • Member
  • PipPip
  • 57 posts

Posted 29 October 2014 - 12:20 AM

This might be obvious to some people, but I'm still a noob and my TDM behavior was annoying me.

Running LInux Mint 17 and following the wiki to install TDM yields a few errors

after you enter "chmod +x tdm_update.linux" in terminal
you can install tdm with "sudo ./tdm_update.linux (not mentioned in wiki but might be something new users don't know)

here's the part that threw me off.
The training mission + Saint Lucia was invisible after the download was completed
TDM was also having some weird behaviors with some missions not installing causing CTD

The solution I found was that the permissions in the files + subfolders of main darkmod folder was not the same
Some items was under root privileges meaning you can't erase/modify it without being a superuser

After modifying all the user/group/permissions TDM was happy again.

Hope this helps someone.
  • WelchBack likes this

#2 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7527 posts

Posted 29 October 2014 - 12:09 PM

you can install tdm with "sudo ./tdm_update.linux (not mentioned in wiki but might be something new users don't know)

The solution I found was that the permissions in the files + subfolders of main darkmod folder was not the same
Some items was under root privileges meaning you can't erase/modify it without being a superuser


Not surprising, since you ran the updater with sudo. This should not be necessary. The updater only downloads content into its own directory, so you can easily install it as your normal user just by putting the updater into $HOME/darkmod and running it from there.

#3 bedhead

bedhead

    Member

  • Member
  • PipPip
  • 57 posts

Posted 29 October 2014 - 02:31 PM

Thanks i didnt know that. I guess it became a habit for me for x

#4 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 715 posts

Posted 02 November 2014 - 09:22 AM

I have created an software installationpackage (deb) for it.
It creates an darkmod-folder in the /usr/share/games, extracts the files with the right permissions and some shortcuts.
(sources included)
Check it out: topic / site

Edited by freyk, 02 November 2014 - 09:23 AM.


#5 Adrianho

Adrianho

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 24 November 2014 - 03:32 PM

This might be obvious to some people, but I'm still a noob and my TDM behavior was annoying me.

Running LInux Mint 17 and following the wiki to install TDM yields a few errors

after you enter "chmod +x tdm_update.linux" in terminal
you can install tdm with "sudo ./tdm_update.linux (not mentioned in wiki but might be something new users don't know)

here's the part that threw me off.
The training mission + Saint Lucia was invisible after the download was completed
TDM was also having some weird behaviors with some missions not installing causing CTD

The solution I found was that the permissions in the files + subfolders of main darkmod folder was not the same
Some items was under root privileges meaning you can't erase/modify it without being a superuser

After modifying all the user/group/permissions TDM was happy again.

Hope this helps someone.


Did u used catalyst or Radeon OSS?

I have problems starting the game with both of them.

If u used fglrx, which version was it?

Thanks.

#6 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 715 posts

Posted 26 November 2014 - 02:46 AM

Which userpermission do you use/prefer for the tdm files.
I will change them in my rpm/deb packages.

#7 bedhead

bedhead

    Member

  • Member
  • PipPip
  • 57 posts

Posted 29 November 2014 - 05:33 PM

I use catalyst. Radeon OSS results in a black screen where the menu screen should be. User permission is Owner: Can View and Modify Content. Groups and Others: Can View Content

#8 bedhead

bedhead

    Member

  • Member
  • PipPip
  • 57 posts

Posted 29 November 2014 - 05:38 PM

Adrianho - I used the latest beta catalyst version from AMD website and installed it by executing sh file. I forgot which version it was. I've recently upgraded my video card to nvidia gtx 970 so I can't help you there. Sorry. You should describe the problems you are having and maybe I can try to help.
  • Adrianho likes this

#9 Adrianho

Adrianho

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 01 December 2014 - 07:21 AM

@bedhead

Thanks for your reply man.

In my case TDM segfaults for both drivers. Indeed, I use 'unofficial Mesa builds' and the fglrx version is the one from the official 14.04 repo but regardless, I suspect having some sort of library incompatibility. I'll upgrade the OS these days and try again and see if I can make it work.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users