Jump to content


Photo

TDM Updater - Repeatedly Downloading

update failure loop

  • Please log in to reply
5 replies to this topic

#1 TheUnbeholden

TheUnbeholden

    Campaign Dev

  • Campaign Dev
  • PipPip
  • 149 posts

Posted 27 February 2015 - 03:24 PM

I have version 2.0 and It keeps trying to download TDM_update_2.00_to_2.01.zip, then restarting the download again once it finishes (29.3mb over and over again with a average download speed of 200kbps, there is no zip file in the darkmod folder apart from with with 2 underscores before its name and 0 bytes big). I've waited patiently but every download mirror it tries downloading from does the same thing, downloading keeps restarting but gives no zip file and just starts restarts the download for the next mirror in a continuous loop. Its already bad enough that I need the whole Darkmod installation folder with me to the internet cafe just to download a measly patch, but this is bizarre. I tried copypasting the download link from the logfile into the browser, which worked but honestly that took longer than it needed for me to figure out the updater isn't doing its job. But then.. ugh again an issue.

 

I extracted the patch from the zip, 2.00 to 2.01, overwriting.. but now its saying my version is "no exact match" and trying to download the zip again :/

 

I put the zip file in the darkmod folder so I would think that the updater would notice that the update package zip is already there and shouldn't be downloaded, no luck still tries to download it regardless. This is ridiculous, doesn't matter what way I do it, it still won't allow me to get the next 2 updates.

 

I tried downloading the updater manually from the website: http://www.thedarkmo...wnload-the-mod/

Same issue.

 

My system is XP SP3, same as I've always had for TDM.


Edited by TheUnbeholden, 27 February 2015 - 03:34 PM.


#2 Obsttorte

Obsttorte

    Scripting guru, Mapper

  • Active Developer
  • PipPipPipPipPip
  • 5710 posts

Posted 27 February 2015 - 03:57 PM

The update is definetely bigger then 29.3MB. Maybe something is wrong with the mirrors, or your connection. Can't really help you here, though.


FM's: Builder Roads, Old Habits, Old Habits Rebuild
WIP's: Several. Although after playing Thief 4 I really wanna make a city mission.
Mapping and Scripting: Apples and Peaches
Sculptris Models and Tutorials: Obsttortes Models
My wiki articles: Obstipedia
Let's Map TDM YouTube playlist: ObstlerTube
Texture Blending in DR: DR ASE Blend Exporter

End of shameless self promotion.

#3 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 27 February 2015 - 04:13 PM

I see in the updater's log file that the updater is checking the filesize of the 2.00->2.01 zip file after it's downloaded, finding that it doesn't match expectations, at which point it wipes the zip and tries again, endlessly.

 

I'm afraid there's no way around this short of fixing the bug in the updater in 2.04.

 

I'll see if there's a way of collecting the necessary zip files separately and making them available to you.

 

If I can't do that, then you'll need to do a full install of 2.03.



#4 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 27 February 2015 - 05:51 PM

Edit:  try again. The main 2.00->2.01 zip file has been corrected, and pushed to a couple mirrors. Other mirrors will get the update tomorrow. If the updater does a retry, hopefully at some point it'll find the correct version and stop looping. The 2.01->2.02 and 2.02->2.03 zip files work fine.

 

=============================================

 

Alternatively ...

 

taaaki has found that the 2.00->2.01 zip file has lost some weight since we released 2.01. Don't know why. Don't know if we can repair it. Still looking at the problem.

 

If you want to proceed with a cobbled-together solution, you can grab the 2.00->2.01 zip file here. Say yes when asked if you want to overwrite existing files.

 

After unzipping it to your 2.00 folder, you can grab the 2.01->2.02 zip file here. Say yes when asked if you want to overwrite existing files.

 

And, finally, after unzipping that to your 2.00 folder, you can grab the 2.02->2.03 zip file here. Say yes when asked if you want to overwrite existing files.

 

After unzipping that to your 2.00 folder, you should have 2.03. The new files will have been dropped into separate folders, rather than put into the pk4s, but it should work the same.



#5 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 20281 posts

Posted 27 February 2015 - 06:05 PM

Or....there is a full 2.02 archive on MODDB, download that and then run the 2.0.3 update.



#6 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 27 February 2015 - 06:06 PM

The 2.00->2.03 update now appears to be working correctly.







Also tagged with one or more of these keywords: update, failure, loop

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users