Jump to content


Photo

configure fails with boost_major_version error


  • Please log in to reply
5 replies to this topic

#1 MirceaKitsune

MirceaKitsune

    Advanced Member

  • Member
  • PipPipPip
  • 588 posts

Posted 22 October 2015 - 08:49 PM

I upgraded from openSUSE 13.2 to openSUSE Tumbleweed today. Darkradiant has apparently stopped compiling, and I get the following error during ./configure:

configure: error: invalid value: boost_major_version=

I checked my packages and should have all boost libraries installed. My boost version is 1.58.0. Any thoughts?


Edited by MirceaKitsune, 22 October 2015 - 08:51 PM.


#2 MirceaKitsune

MirceaKitsune

    Advanced Member

  • Member
  • PipPipPip
  • 588 posts

Posted 23 October 2015 - 05:31 PM

I googled this issue today. Apparently the problem lies on DarkRadiant's side, and the autogen / configure script might need some tweaking. I tried a fix of my own as follows:

 

In mp/boost.m4, I commented out lines 217 and 422, which are both errors that were encountered by ./configure. They are:

AC_MSG_ERROR([invalid value: boost_major_version=$boost_major_version])

AC_MSG_ERROR([cannot find the flags to link with Boost $1])

Configuration succeeded afterwards. I was able to compile Darkradiant for well over 15 minutes, until it eventually failed with the following error:

  CXXLD    darkradiant
/usr/lib64/gcc/x86_64-suse-linux/5/../../../../x86_64-suse-linux/bin/ld: cannot find -lboost_filesystem-d
collect2: error: ld returned 1 exit status
Makefile:2043: recipe for target 'darkradiant' failed
make[1]: *** [darkradiant] Error 1

Obviously I have libboost_filesystem installed, adding the file /usr/lib64/libboost_filesystem.so.1.58.0. The setup simply fails to see them apparently.



#3 MirceaKitsune

MirceaKitsune

    Advanced Member

  • Member
  • PipPipPip
  • 588 posts

Posted 24 October 2015 - 09:04 AM

Worked around this by downloading Boost 1.54.0, and using "./configure --with-boost=foo/bar/" to point the scripts to it. Didn't compile yet but I imagine it should fix this specific issue.

 

Also reported this as a bug on the tracker: http://bugs.thedarkm...iew.php?id=4239



#4 janexx

janexx

    Member

  • Member
  • PipPip
  • 11 posts

Posted 29 October 2015 - 07:36 AM

I have the same problem!

 

./configure throws this error:
configure: error: invalid value: boost_major_version=

I have installed boost 1.58.0-3

My OS is Arch Linux.



#5 Radegast

Radegast

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 03 January 2016 - 05:12 AM

I have Arch Linux and use boost 1.59. To bypass this bug until it gets fixed, I opened the configure script and simply changed the line to boost_major_version=159.

-    boost_major_version=`echo "$boost_cv_lib_version" | sed 's/_//;s/_.*//'`
+    boost_major_version=159

Also, I had to change the AUTOMAKE and ACLOCAL variables in the generated makefile, because they were set to aclocal-1.14 and automake-1.14 even though I have version 1.15 on my system. WTF? Maybe the DarkRadiant devs should consider using CMake.


Edited by Radegast, 03 January 2016 - 09:16 AM.


#6 greebo

greebo

    Heroic Coder

  • Root
  • 15919 posts

Posted 29 December 2016 - 04:41 AM

I know it's a long time since the thread has been started, but is this still an issue on your systems?

 

The automake problems typically go away if ./autogen.sh is invoked before compiling. It works for me regardless of the automake versions, be it 1.14 or 1.15.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users