Jump to content


Photo

Crucible of Omens: Behind Closed Doors - by Bikerdude & the Crucible Team (updated 18/12/2015)


  • Please log in to reply
294 replies to this topic

#26 Deadlove

Deadlove

    Advanced Member

  • Member
  • PipPipPip
  • 978 posts

Posted 19 December 2015 - 03:48 PM

Also perhaps point out that mission exceeds TDM normal standard requirements for optimal experience.

Plastik Musik - Andrew Nathan Kite, Owner

plastikmusik33@gmail.com

http://www.facebook.com/plastikmusik /

http://www.youtube.com/plastikmusik

http://www.plastikmusik.bandcamp.com

 

 


#27 Oldjim

Oldjim

    Uber tester

  • Member
  • PipPipPip
  • 1991 posts

Posted 19 December 2015 - 03:49 PM

This game is very heavy on video ram

Have you tried the settings recommended in the opening post



#28 Deadlove

Deadlove

    Advanced Member

  • Member
  • PipPipPip
  • 978 posts

Posted 19 December 2015 - 03:53 PM

Yes, I have my set to gravy. Just mention making note
For others.

Plastik Musik - Andrew Nathan Kite, Owner

plastikmusik33@gmail.com

http://www.facebook.com/plastikmusik /

http://www.youtube.com/plastikmusik

http://www.plastikmusik.bandcamp.com

 

 


#29 Thor

Thor

    Member

  • Member
  • PipPip
  • 42 posts

Posted 19 December 2015 - 03:59 PM

Yes. I even ran on a clean reboot. I got 8 GB of RAM, if that is not enough to run this FM then the phrase "less than optimal" is an understatement. I only got a couple of gigs free space on my drive though, but that isn't usually a problem with games either...
 

Edit: Tried to load in window mode, monitoring my drive and RAM - both basically stood where they were without even running the game. RAM only increased by ~8%.

Edit2: Downloaded from in-game downloader still crashes. I just don't have much bigger imagination than this. Tried to run A House of Locked Secrets - loaded quickly and beautifully.


Edited by Thor, 19 December 2015 - 04:44 PM.


#30 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 19 December 2015 - 05:34 PM

Do you have your language set to anything other than English?

Is EAX enabled? (It's broken since 1.08)

Please make sure that your darkmod directory isn't read only.

Also, if you have Nvidia GPU, disable Threading Optimization and set your power management to high performance and Single Display.


Please post your Darkmod.cfg.
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#31 Thor

Thor

    Member

  • Member
  • PipPip
  • 42 posts

Posted 19 December 2015 - 06:40 PM

Thanks for the suggestions. Tried them all but none worked. My Darkmod.cfg file is below, but I'm not sure what it'll help. Other missions load alright.

 

Spoiler

Edited by Thor, 19 December 2015 - 06:40 PM.


#32 lowenz

lowenz

    Advanced Member

  • Member
  • PipPipPip
  • 1502 posts

Posted 19 December 2015 - 07:06 PM

The use of these low resolution textures is intended?

 

The_Dark_Mod_2015_12_20_01_02_10_078.png
 
The_Dark_Mod_2015_12_20_01_02_42_713.png

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.


#33 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 19 December 2015 - 07:08 PM

Thanks for the suggestions. Tried them all but none worked. My Darkmod.cfg file is below, but I'm not sure what it'll help. Other missions load alright.

 

 

OK, I presume your GPU has more than 128MB so increase:

 

seta com_videoRam "128"

 

Nvidia doesn't like useIndexBuffers so set:

 

seta r_useIndexBuffers "0"

 

(you may need to revert this in a future TDM revision)

 

also, try these image downsize changes to reduce the GPU impact:

 

seta image_downSize "1"
seta image_downSizeLimit "1024"
seta image_downSizeBump "1"
seta image_downSizeBumpLimit "256"
 

 

Finally, try running TDM as "Administrator" (right click option)


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#34 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 330 posts

Posted 19 December 2015 - 09:34 PM

I have to corroborate with Thor here, the mission makes TDM CTD about 1/8th of the way through Generating World every time. I have the 4gb-patched version of the .exe, tried with the original one but it's still the same. I also tried starting both on Normal and Expert difficulty with no difference. I should've probably asked to beta-test when I had the chance :P

 

Here's the Windows error report:

Spoiler

 

e: and my .cfg too, just in case:

Spoiler

Edited by Spooks, 19 December 2015 - 09:50 PM.

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#35 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 19 December 2015 - 10:40 PM

Try the image_downsize changes I referred to above.

 

Also reduce your image ansiotropy:

 

seta image_anisotropy "8"

 

If that doesn't do it, try backing up your TheDarkMod.exe, gamex86.dll, and Darkmod.cfg then delete them and run your

tdm_updater to replace them.

 

Finally, it seems that my config has seta win_xpos "3" while yours is seta win_xpos "0"... on a lark you could try that.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#36 Deadlove

Deadlove

    Advanced Member

  • Member
  • PipPipPip
  • 978 posts

Posted 19 December 2015 - 11:49 PM

After blowing my mind off testing, I'm still excited to play the official release!

Here goes the next several hour of my life. Cheers!

 

 

Question, if we find bugs, should we report to this thread or the BCD in Beta Testing Forum"


Plastik Musik - Andrew Nathan Kite, Owner

plastikmusik33@gmail.com

http://www.facebook.com/plastikmusik /

http://www.youtube.com/plastikmusik

http://www.plastikmusik.bandcamp.com

 

 


#37 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 20 December 2015 - 12:45 AM

You can report them in the main thread now.

Beta forums are for bug reports that are so egregious that the author doesn't want players exposed to them in a widespread fashion.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#38 brethren

brethren

    Advanced Member

  • Member
  • PipPipPip
  • 544 posts

Posted 20 December 2015 - 02:07 AM

Just getting started on this (congrats on the release, btw), but I noticed not too far into the mission, there's a building marked "For Sale" and you can walk right through it from the north side.



#39 Melan

Melan

    Contest Winner, Wordsmith

  • Campaign Dev
  • PipPipPipPip
  • 4330 posts

Posted 20 December 2015 - 02:41 AM

 

The use of these low resolution textures is intended?

 

 

That building is a model, so yes. Until someone produces a higher-res skin, that is.


Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

#40 Thor

Thor

    Member

  • Member
  • PipPip
  • 42 posts

Posted 20 December 2015 - 03:37 AM

If that doesn't do it, try backing up your TheDarkMod.exe, gamex86.dll, and Darkmod.cfg then delete them and run your

tdm_updater to replace them.

That did it. Thanks!



#41 Sir Taffsalot

Sir Taffsalot

    Member

  • Member
  • PipPipPip
  • 1547 posts

Posted 20 December 2015 - 06:16 AM

Congrats on the release Biker. I know how much hard work you put into your FMs so I'm sure that if I expect this to be nothing short of extraordinary I won't be disappointed :smile:


"I believe that what doesn't kill you simply makes you... stranger"

The Joker

#42 Deadlove

Deadlove

    Advanced Member

  • Member
  • PipPipPip
  • 978 posts

Posted 20 December 2015 - 07:49 AM

Just getting started on this (congrats on the release, btw), but I noticed not too far into the mission, there's a building marked "For Sale" and you can walk right through it from the north side.

 

Sadly, there are still lots of bugs. I'm glad we made a holiday deadline, but it should really be revamped at some point....like after the rest of the campaign is finished.


Plastik Musik - Andrew Nathan Kite, Owner

plastikmusik33@gmail.com

http://www.facebook.com/plastikmusik /

http://www.youtube.com/plastikmusik

http://www.plastikmusik.bandcamp.com

 

 


#43 Cambridge Spy

Cambridge Spy

    Member

  • Member
  • PipPip
  • 249 posts

Posted 20 December 2015 - 08:25 AM

 

Sadly, there are still lots of bugs. I'm glad we made a holiday deadline, but it should really be revamped at some point....like after the rest of the campaign is finished.

Spoiler


"Let me guess - little blue men with three heads stole your sweetroll?"

#44 Oldjim

Oldjim

    Uber tester

  • Member
  • PipPipPip
  • 1991 posts

Posted 20 December 2015 - 08:34 AM

Why not just enjoy the mission and ignore the minor bugs

Spoiler



#45 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 330 posts

Posted 20 December 2015 - 10:55 AM

Deleting and redownloading the files through tdm_update does fix it but hell if I know which one actually made the map crash. I spent 2 hours of trial and error testing - it seemed the .cfg was doing it but after replacing every option line by line until the old and new .cfg were identical it still ran fine. Beats me. If anyone is having problems though, yeah, backup then delete the .cfg and start your .exe so it generates a new one. If you have any custom keybinds just copy them over from your backup and it should be fine.

 

Now that I could look around, I'd say the performance is pretty good! I was getting 30 FPS average on most large areas, which is very playable compared to the 10 FPS I've sometimes gotten on some other FMs.

 

Here's a couple visportal hitches I noticed:

 

edit: I've done more trial and error testing and I think I know what's causing the crash now. Setting your LOD settings below Normal will crash the map. I had mine set to Low and so had Thor judging by his .cfg. It will crash on Low or Lowest for me, if anyone can check if they can reproduce this behavior I'd be thankful. 


Edited by Spooks, 20 December 2015 - 12:31 PM.

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#46 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 18095 posts

Posted 20 December 2015 - 01:07 PM

Sadly, there are still lots of bugs.

Bar the above issue ,  if there are they are minor. Your beta testing was very thorough and went a lot further than most most folks would even notice.



#47 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 18095 posts

Posted 20 December 2015 - 01:19 PM

  • Now that I could look around, I'd say the performance is pretty good! I was getting 30 FPS average on most large areas, which is very playable compared to the 10 FPS I've sometimes gotten on some other FMs.
  • Here's a couple visportal hitches I noticed:
  • edit: I've done more trial and error testing and I think I know what's causing the crash now. Setting your LOD settings below Normal will crash the map. I had mine set to Low and so had Thor judging by his .cfg. It will crash on Low or Lowest for me, if anyone can check if they can reproduce this behavior I'd be thankful. 
  • sweet, I spent a shed lot of mapping time getting the perf as good as was possible.
  • Will fixed this during the week, or sooner if I have a fast enough connection
    • what am I looking at at?
    • will fix
    • will fix
    • simple fix.
  • Thank you for finding this!, I know what might be causing that. I had played around with setting min_lod_bias and must have forgotten to remove it from the few entites I placed it on. That said, this should NOT be causing TDM to crash. @Nbohr, does this sound like a mod bug? if so I will ask Spooks he he/she wouldnt mid filling a bug tracker.

@Jim, well said fella.

@SirTaff, thanks mista Im sure you wont be disappointed :-)



#48 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 20 December 2015 - 01:34 PM

Yeah, min_lod_bias shouldn't cause crashes. I'll look at that tonight. I did move the slider down to lowest after the map loaded

and it didn't crash so if it's confirmed then it's a bug in the map loading process.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#49 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 330 posts

Posted 20 December 2015 - 04:04 PM

@Bikerdude, it's the left side of the gable where the dormers are (top-left) in that first screenshot. Sorry, I did think of red circling it but I was in a hurry and I wanted to make sure to take a wide enough shot so the place in the map is recognizable. As an aside you can mantle onto the thatched roof leading to that gable and you'll go out of visportal bounds and the game will do its usual "freeze for a minute while all the visportals open".

 

@nbohr, indeed, it works okay when you lower it in game, it's when you set it at the menu and then attempt to start the mission is when it crashes.


Edited by Spooks, 20 December 2015 - 04:04 PM.

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#50 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7435 posts

Posted 20 December 2015 - 04:08 PM

Without looking at the map, I can imagine that an invalid or overlapping lod_bias range might cause a problem.

Other than that? Maybe it's tickling some weakness in spawn code for certain types of entities. I know SteveL had

to make a script to ensure that stale collision models are cleared (etc) so this might be another similar problem

(though there was no crash in that case, just invisible collision geometry).


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users