Jump to content


Photo

3D sound problem


  • Please log in to reply
10 replies to this topic

#1 Sgt-PieFace

Sgt-PieFace

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 01 March 2016 - 12:37 AM

So I just downloaded The Dark Mod and I can't set my sound to the surround option. It says the game couldn't find a 3D sound device. I use a Logitech gaming headset that uses the Logitech Gaming Software through USB to play surround sound, so its separate from the windows audio driver. Is there a way to make the game detect this, or is there a work around.

 

Thanks!



#2 Hiradur

Hiradur

    Member

  • Member
  • PipPip
  • 57 posts

Posted 01 March 2016 - 03:19 PM

If you are playing with headphones I suggest you try OpenAL Soft with HRTF first. 3D Audio should be better than with regular surround. Here is a guide for that: http://forums.thedar...etter-3d-audio/

 

Should you want to use surround sound instead you can enforce that in the OpenAL Soft config file.



#3 SeriousToni

SeriousToni

    Beginner Contest 2012 Winner

  • Member
  • PipPipPipPip
  • 2196 posts

Posted 01 March 2016 - 05:54 PM

Hiradur are you sure OpenAL works with an USB headset?? :huh:

 

For me and my USB Headset I had back in the day there was the same error message and even now with my 7.1. external sound card it is the same.. I used the solution written in the thread that Hiradur posted above my post but I think this will only work with a common stereo headset.


"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

#4 Hiradur

Hiradur

    Member

  • Member
  • PipPip
  • 57 posts

Posted 05 March 2016 - 04:56 PM

Hiradur are you sure OpenAL works with an USB headset?? :huh:

 

I haven't used an USB headset but I suspect they are just headphones+mic connected to a simple sound card.

I use a USB sound card where I connect my headphones to and it works.

OpenAL Soft should work with anything as long as you can set it as the default audio output in Windows.



#5 PJMaybe

PJMaybe

    Newbie

  • Member
  • Pip
  • 5 posts

Posted 09 July 2016 - 04:38 PM

I have 7.1 installed but the settings didn't recognise it and only offered stereo option. (Windows 10)

 

In device manager I had 3 sound devices installed. I only needed the Creative one for the surround sound so I uninstalled the other two.

 

Solved! Now both 5.1 and 7.1 options are now available in the game settings :D

 

Hope this helps someone...


  • SeriousToni and Anderson like this

#6 Lex

Lex

    Member

  • Member
  • PipPip
  • 35 posts

Posted 22 July 2016 - 09:54 AM

I have a 3d sound problem as well.

 

So, previously I have had 5.1 sound cofiguration. I was using this fancy Creative x-fi fatal1ty pro PCIe soundcard for output (using all these jack and stuff) and everything was just fine.

 

Now I have 5.1 as well, but I also have installed the receiver and the sound output comes to it via my videocard (Nvidia gtx750) using HDMI.

 

The problem is that in the Dark Mod all the sounds come only through frontal and central speakers, rear ones are inactive, even though I have selected 5.1 configuration in game settings. And the sounds which are supposed to come through rear speakers (like footsteps behind you) are played in frontal speakers as well. So it's just like simple stereo. The receiver shows that the imput signal is PCM. The other games work just fine, the problem only with the Dark Mod.

 

I have OpenAl installed, of course. Any ideas? Thanks in advance.

 

Upd: my idea is that for some reason in my case the game doesn't really send 5.1 sound to the output device. Or the receiver cannot recognise that it's 5.1 and send it to speakers correctly.

My idea is that for some reason the game

 

SOLVED: I reinstalled the game and it helped. Not sure what changed, though. Sorry I bothered you, guys.


Edited by Lex, 22 July 2016 - 11:37 AM.

  • Anderson likes this

#7 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 22 July 2016 - 11:45 AM

  • HDMI on nvidia/Ati cards only supports stereo and SPDIF/Digital pass-through.

If you want to get 5.1 surround your receiver will have to support analogue audio in for all channels from the sound card - front, center, rear, etc. And on a side note I don't know of any PC games that support any of the dolby digital protocols.



#8 Lex

Lex

    Member

  • Member
  • PipPip
  • 35 posts

Posted 08 August 2016 - 09:40 AM

 

  • HDMI on nvidia/Ati cards only supports stereo and SPDIF/Digital pass-through.

If you want to get 5.1 surround your receiver will have to support analogue audio in for all channels from the sound card - front, center, rear, etc. And on a side note I don't know of any PC games that support any of the dolby digital protocols.

 

Actually, I managed to get 5.1 sound via HDMI with no problem, Dolby Digital or not. After reinstalling the Dark Mod's sound works just fine that what's important for me. I also successfully tested the sound in the Witcher 2-3. Don't play much these days, anyway.



#9 Rejlive

Rejlive

    Member

  • Member
  • PipPip
  • 11 posts

Posted 25 March 2017 - 12:16 AM

I solved this by going to control panel, sound then right clicking your device (mine is soundblasterx g5) then configure i put it on 7.1, click next, then leave full range speakers unchecked (unless you have them of course), then finish, and when I started the game i was able to select 7.1

This game sounds great with an Audio Technica ADG1x plugged into the SBxG5, just using usb 2.0 for now. I can hear guards from all directions, its amazing.

 

But what is EAX 4.0?


Edited by Rejlive, 25 March 2017 - 12:17 AM.


#10 HMart

HMart

    Advanced Member

  • Member
  • PipPipPip
  • 539 posts

Posted 25 March 2017 - 07:10 PM

I solved this by going to control panel, sound then right clicking your device (mine is soundblasterx g5) then configure i put it on 7.1, click next, then leave full range speakers unchecked (unless you have them of course), then finish, and when I started the game i was able to select 7.1

This game sounds great with an Audio Technica ADG1x plugged into the SBxG5, just using usb 2.0 for now. I can hear guards from all directions, its amazing.

 

But what is EAX 4.0?

 

 

EAX is a dead hardware accelerated sound tech from Creative, if you had a Creative sound card with support for EAX 4 (like me) and you played a mission where the developer implemented EAX support, yes is not automatic you need to manually make individual EAX sound spaces for every "room" of your mission, if you add all that, then you would experience much better sound, reverb, sound occlusion effects, better 3D sound etc. Unfortunately none of TDM missions, aside from a old EAX test mission,  support EAX so turning on EAX 4 option does nothing and can cause instability and crash's.  

 

But all this will be history when the team implement EFX is a EAX like system but has the benefit that it works on all sound cards (in software mode). 

 

edit:  It seams you have a creative external sound card it also seams from the creative page on that card it doesn't support any EAX not even EAX 5.0.

 

 

 

This is thief 3 and uses EAX 3 i think

 


Edited by HMart, 25 March 2017 - 07:28 PM.

  • Anderson likes this

#11 Rejlive

Rejlive

    Member

  • Member
  • PipPip
  • 11 posts

Posted 27 March 2017 - 10:43 PM

 

 

EAX is a dead hardware accelerated sound tech from Creative, if you had a Creative sound card with support for EAX 4 (like me) and you played a mission where the developer implemented EAX support, yes is not automatic you need to manually make individual EAX sound spaces for every "room" of your mission, if you add all that, then you would experience much better sound, reverb, sound occlusion effects, better 3D sound etc. Unfortunately none of TDM missions, aside from a old EAX test mission,  support EAX so turning on EAX 4 option does nothing and can cause instability and crash's.  

 

But all this will be history when the team implement EFX is a EAX like system but has the benefit that it works on all sound cards (in software mode). 

 

edit:  It seams you have a creative external sound card it also seams from the creative page on that card it doesn't support any EAX not even EAX 5.0.

 

 

 

This is thief 3 and uses EAX 3 i think

 

Thanks for the explanation.  I noticed when I turned on EAX 4.0 it adds echo, even if my card doesnt support it.  I didnt like the effect, so I turned it off.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users