Jump to content


Photo

DarkRadiant 2.0.5 pre-release testing


  • Please log in to reply
126 replies to this topic

#1 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 07:07 AM

Here's the next 2.0.5 pre8 build for inclined mappers to test.

Installer x64: https://drive.google...MlVUMzdFUmUtc3M
Portable x64: https://drive.google...UkxpbXRyMGhqWUk

Installer x86: -
Portable x86: -

If you happen to run into a crash, please record a crashdump: How to record a crashdump

Changes since 2.0.4 can be seen on the Bugtracker, important stuff includes so far:

- Switched Windows toolchain to Visual C++ 2015
- Updated backend libraries
- Ported patch tesselation code from idtech4, completely replacing the one in DR

 

pre2:

- Fixed the black images appearing in the Entity Inspector list

- Rewrote the PreferenceDialog code, should resolve the blank preferences window

- Fixed the Objectives Numbers not being rendered in the list (Objectives Editor)

 

pre3 (2016-06-25):

- Added AAS File Visualisation. The dialog is available through the "View" menu and/or by pressing Ctrl-Shift-A (default mapping)

- Added feature to Pan the camera view by clicking Ctrl-RMB and dragging (#4333: 3d view port shortcut to pan while not in free look)

- Double-clicking tree view items now expands/collapses them

- Fixed #4325: Empty func_static entity after switching classname and hitting undo

 

pre4 (2016-09-19):

- Fixed #4280: Aspect ratio displayed incorrectly in particle editor

- Experimental Grouping code, see separate Grouping Feature Discussion thread

- Fixed: MoveSelectionUP command crashing DR when nothing is selected

- Inverted Y direction for PanCamera tool

- Tons of refactorings and back-end stuff

- Fixed various compilation errors in Linux

 

pre5 (2016-09-25):

- Fixed #4355: Problem with starting a new conversation with the conversation editor

- Fixed #4375: Moving objects to a hidden layer doesn't cause them to immediately disappear

- Fixed #4373: Connecting lines are created in Default layer

- Feature #4380: Allow EntityInspector to select/copy/paste multiple spawnargs at once

- Feature #4381: Add a clickable Checkbox next to boolean-valued spawnargs in EntityInspector list

- Fixed #4386: Projected lights don't rotate around their origin anymore

 

pre6 (2016-10-16)

- Improved Selection Group handling a bit. This should lead to better (expected) behaviour when inverting the selection or selecting elements through various features or by means of layers.

- Fixed #4355 better this time: Problem with starting a new conversation with the conversation editor

- Fixed #4373: Connecting lines are created in Default layer. Also, target lines of cloned nodes might appear hidden at first.

- Fixed #4391: Aimed particles have incorrect orientation or shape

- Fixed a crash when editing float-valued spawnargs

- Entity Inspector: The clickable checkbox next to boolean values can now be used to toggle inherited spawnargs as well

 

pre7 (2016-10-30)

- Fixed #4365: a few static warnings (llvm/clang static source code analysis)

- Fixed #4388: Undo respects grouping/ungrouping operations now

- Fixed #4387: Invert Selection problems

- Fixed #4404: The health field on the AI tab is capped at 1000.

- Fixed #4396: Error message when opening S/R editor

 

pre8 (2016-11-06)

- Added script to check for invalid visportals (i.e. portals with more than one sided textured with textures/editor/visportal)

- Fixed #4410: Particle distribution parameters not saved to the .prt file (ring parameter for spherical particles)

- Fixed #3870: Number of selected map items is now shown in the status bar

- Fixed #4391 again: Aimed particle stages were sized incorrectly


Edited by greebo, 06 November 2016 - 01:20 AM.
pre8


#2 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 07:08 AM

Particularly, since I've been changing so many things in the backend, I'd like to hear if people can successfully startup this build on their end. Just take the portable version, extract it and see if it comes up.



#3 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 11496 posts

Posted 11 June 2016 - 08:24 AM

Particularly, since I've been changing so many things in the backend, I'd like to hear if people can successfully startup this build on their end. Just take the portable version, extract it and see if it comes up.

 

Yes, it does. I opened up the Saint Lucia map w/it, and all looked fine.

 

I'm on Win7.

 

Will continue using it and report back.



#4 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 302 posts

Posted 11 June 2016 - 08:40 AM

I'll be glad to be looking over the next batch of pre-releases, greebo. Downloaded the portable version, starts fine. The Dark Radiant preferences window shows a blank screen (windows grey with no window elements inside it). Perhaps as a consequence, every time you restart DR it seems to ask you to setup your game location as it does not remember what you set up previously.


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#5 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 08:51 AM

 

Yes, it does. I opened up the Saint Lucia map w/it, and all looked fine.

 

I'm on Win7.

 

Will continue using it and report back.

Make sure to keep backups around, the patch code has been changed from the ground up. It should be fine, but better be safe than sorry.

 

 

I'll be glad to be looking over the next batch of pre-releases, greebo. Downloaded the portable version, starts fine. The Dark Radiant preferences window shows a blank screen (windows grey with no window elements inside it). Perhaps as a consequence, every time you restart DR it seems to ask you to setup your game location as it does not remember what you set up previously.

I can confirm that the preferences dialog is blank, strangely enough.



#6 7318

7318

    Member

  • Member
  • PipPip
  • 103 posts

Posted 11 June 2016 - 09:31 AM

on Ubuntu 16:04 I can't get it to start past the selection of engine and engine directory


Biel Bestué de Luna - Github

#7 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 09:56 AM

Well, aren't all those distro releases great? Real pleasure to work with.

 

Don't have Ubuntu 16 around here, and to be honest, I'm not terribly motivated to set up another VM to hunt that one down at the moment.



#8 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17861 posts

Posted 11 June 2016 - 09:57 AM

Downloading.



#9 7318

7318

    Member

  • Member
  • PipPip
  • 103 posts

Posted 11 June 2016 - 10:08 AM

Well, aren't all those distro releases great? Real pleasure to work with.

 

Don't have Ubuntu 16 around here, and to be honest, I'm not terribly motivated to set up another VM to hunt that one down at the moment.

no problem pal! :D


Biel Bestué de Luna - Github

#10 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 11496 posts

Posted 11 June 2016 - 10:30 AM

Make sure to keep backups around, the patch code has been changed from the ground up. It should be fine, but better be safe than sorry.

 

 

I can confirm that the preferences dialog is blank, strangely enough.

 

Backups readily available if needed.

 

Blank preferences dialogue confirmed here as well.



#11 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 11496 posts

Posted 11 June 2016 - 11:39 AM

I'm seeing little black squares in the entity property field for various func_static spawnargs.

 

Attached File  lights.jpg   270.99KB   0 downloads



#12 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 12:21 PM

I'm seeing little black squares in the entity property field for various func_static spawnargs.

 

attachicon.giflights.jpg

Hm, I can't repro that. My icons appear fine on my end.

 

edit: scratch, that. I can see the same, but only for inherited properties.



#13 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 11 June 2016 - 12:53 PM

Fixed the black icons in the Entity Inspector, which seems to be caused by the wxWidgets 3.1.0 upgrade. The same is probably true for the Preference Dialog, but this will be harder to work around.



#14 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 302 posts

Posted 11 June 2016 - 01:02 PM

If you import a map from the file menu, you get the two properties "editor_drLastCameraAngle" and "editor_drLastCameraPos" which aren't inherited, but also have black squares.

 

If anyone's encountering weird stuff like textures defaulting to 0 horizontal and vertical scale and their Textures pane having 1 pixel thumbnails, it seems that opening the blank preferences menu will mess up the information stored in your various xml files. If you want to be sure there's no cross-contamination if you're switching DR versions, go to your %appdata%/DarkRadiant folder, or wherever DR keeps its settings on your OS, and delete your user.xml etc. files. Make backups first, of course, or you'll lose your custom keybindings.


Edited by Spooks, 11 June 2016 - 01:03 PM.

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#15 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 12 June 2016 - 12:35 AM

The preferences dialog is actually messing up the xml files? That's weird, I'll see to having that one fixed soon.



#16 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 302 posts

Posted 12 June 2016 - 02:34 AM

I ran a file comparison and couldn't see anything obviously wrong between the xmls my two different DR versions generated. For sure though, some odd bugs cropped up that I was not able to reproduce once I cleaned up the %appdata% folder and let DR 2.0.5 pre1 generate them anew.


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#17 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17861 posts

Posted 12 June 2016 - 04:20 PM

Have yet to test this on 2.05 pre1, but under 2.04 - if the mapper has the entity inspector open when drag-selecting multiple items there is a massive delay while it selects each items etc. Close said inspector and speed is back to normal.



#18 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17861 posts

Posted 17 June 2016 - 04:00 PM

Ok testing 2.05pre1 - in the objectives editor the objectives numbers are missing -

 

Attached File  Untitled.jpg   16.45KB   0 downloads



#19 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 18 June 2016 - 09:45 AM

Ah thanks for spotting.



#20 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17861 posts

Posted 18 June 2016 - 11:01 AM

Nice one Greebo.



#21 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17861 posts

Posted 18 June 2016 - 03:48 PM

Found another bug, but haven't been able to reproduce on demand yet.

 

But the end result is that the texture inspector window itself becomes black, looses almost all of the textures used in a given map. The 2 times this has happened, I have been trying to copy a texture onto multiple faces.

 

I'll log a tracker once I can reproduce it on demand.



#22 greebo

greebo

    Heroic Coder

  • Root
  • 15910 posts

Posted 19 June 2016 - 01:13 PM

A new test build is up (pre2), see first post.



#23 Baal

Baal

    Hero Mapper

  • Campaign Dev
  • PipPipPip
  • 989 posts

Posted 19 June 2016 - 02:44 PM

Where would I find the sources for this release, if I wanted a linux build?



#24 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7294 posts

Posted 19 June 2016 - 03:15 PM

As I recall, this is the Git:

 

https://github.com/c...der/DarkRadiant


  • Baal likes this
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#25 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7294 posts

Posted 19 June 2016 - 10:21 PM

As another point of reference. No problems seen here. Win10 64-bit Nvidia GPU.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users