Jump to content


Photo

DarkRadiant 2.0.5 pre-release testing


  • Please log in to reply
126 replies to this topic

#26 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 366 posts

Posted 21 June 2016 - 12:33 PM

Just got this when pressing the Find and Replace textures button in the textures pane:
 
20:32:01: XRC error: 112: horizontal alignment flag "wxALIGN_LEFT" has no effect inside a horizontal box sizer, remove it and consider inserting a spacer instead
20:32:01: XRC error: 122: horizontal alignment flag "wxALIGN_RIGHT" has no effect inside a horizontal box sizer, remove it and consider inserting a spacer instead

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#27 PranQster

PranQster

    Advanced Member

  • Member
  • PipPipPip
  • 1756 posts

Posted 21 June 2016 - 04:40 PM

When running 

./configure --enable-darkmod-plugins --prefix=/usr

I get the following error regarding GLEW:

checking GL/glew.h usability... yes 
checking GL/glew.h presence... yes
checking for GL/glew.h... yes
checking for main in -lGLEW... no
configure: error: GLEW not found

I have the following packages installed: lib64glew-devel, lib64glew1.13, and lib64glewmx1.13. No other packages for glew are available. Mageia Linux 6 (Cauldron).


mageia_mini.png Linux pranqster 4.12.6-desktop-1.mga7 #1 SMP Sat Aug 12 15:32:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


#28 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 22 June 2016 - 02:56 AM

 

Just got this when pressing the Find and Replace textures button in the textures pane:
 
20:32:01: XRC error: 112: horizontal alignment flag "wxALIGN_LEFT" has no effect inside a horizontal box sizer, remove it and consider inserting a spacer instead
20:32:01: XRC error: 122: horizontal alignment flag "wxALIGN_RIGHT" has no effect inside a horizontal box sizer, remove it and consider inserting a spacer instead

 

Thanks, this is fixed.



#29 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 22 June 2016 - 03:02 AM

When running 

./configure --enable-darkmod-plugins --prefix=/usr

I get the following error regarding GLEW:

checking GL/glew.h usability... yes 
checking GL/glew.h presence... yes
checking for GL/glew.h... yes
checking for main in -lGLEW... no
configure: error: GLEW not found

I have the following packages installed: lib64glew-devel, lib64glew1.13, and lib64glewmx1.13. No other packages for glew are available. Mageia Linux 6 (Cauldron).

Sorry, can't help you there. For me, it appears that distro maintainers are changing or renaming their packages every 2 minutes. Stuff that has worked before is now broken due to a system-level change that is out of your control.



#30 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 22 June 2016 - 01:24 PM

Found another minor bug, problem with wigets code..? Got when doing a texture swap in DR -

 

Attached File  dr_text_swap_error_popup.JPG   29.29KB   0 downloads

 

 

 



#31 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 23 June 2016 - 12:22 AM

Yes, this is the same as spooks reported, I already fixed that in git.



#32 PranQster

PranQster

    Advanced Member

  • Member
  • PipPipPip
  • 1756 posts

Posted 23 June 2016 - 01:57 AM

Sorry, can't help you there. For me, it appears that distro maintainers are changing or renaming their packages every 2 minutes. Stuff that has worked before is now broken due to a system-level change that is out of your control.

No worries. I might look into an older build of glew but not sure what issues it will have with other programs.


mageia_mini.png Linux pranqster 4.12.6-desktop-1.mga7 #1 SMP Sat Aug 12 15:32:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


#33 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 23 June 2016 - 02:26 AM

Yes, this is the same as spooks reported, I already fixed that in git.

Grand.

 

For some feedback now instead of a bug report: When starting DR there is a weird delay were the divider between orthoview and the camera/entity windows readjusts itself to the last position it was in when DR was used - I can make a video of it, if that would help..?



#34 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 23 June 2016 - 09:37 AM

Found another bug, I think...

 

When in model/entity selector, I could have sworn you could double click on the folder to get them to open their respective tree. But atm I have to D/C on the arrow to the left.



#35 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 23 June 2016 - 12:25 PM

Grand.

 

For some feedback now instead of a bug report: When starting DR there is a weird delay were the divider between orthoview and the camera/entity windows readjusts itself to the last position it was in when DR was used - I can make a video of it, if that would help..?

Yes, I know what you mean. It's exactly the behaviour it is supposed to show, the dividers should readjust themselves to the last position they were when you closed DR. By design, so to say.

 

 

Found another bug, I think...

 

When in model/entity selector, I could have sworn you could double click on the folder to get them to open their respective tree. But atm I have to D/C on the arrow to the left.

In 2.0.4, nothing happens if I double-click a folder in the "Create Entity..." dialog, at least not on my end.



#36 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 23 June 2016 - 12:51 PM

  • Yes, I know what you mean. It's exactly the behaviour it is supposed to show, the dividers should readjust themselves to the last position they were when you closed DR. By design, so to say.
  • In 2.0.4, nothing happens if I double-click a folder in the "Create Entity..." dialog, at least not on my end.
  • Fair enough, not really an issue then :-)
  • Ah maybe in DR181 one could, how hard would it be to enable that function..?


#37 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 23 June 2016 - 01:36 PM

You want it to expand the item you double-clicked on only, or the whole tree below that item too?

 

Should another double-click collapse the item again, or should it stay expanded?



#38 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 23 June 2016 - 03:02 PM

  • You want it to expand the item you double-clicked on only, or the whole tree below that item too?
  • Should another double-click collapse the item again, or should it stay expanded?
  • The same way as it does when you doublie click on the arrow to the right. And the same the way the windows gui for most apps normally works, you double click to open up each step of the tree.
  • yes please.

 

Oh and regarding the delay when opening DR related to the orthoview devider, just now when I opened DR it took several seconds to open. The entity box, ortho and the camera windows were all black.



#39 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 23 June 2016 - 11:41 PM

I'll see what I can do about the tree items double-clicking.

 

During DR startup a lot of stuff is happening, and it's partially happening in the background (multi-threaded). Some stuff like the openGL and/or shader subsystem is not yet ready when the main window is created, that's why it's waiting there to paint the views for the first time. The only thing I can do is to hide the whole window until everything is ready, but I'm not sure that's solving anything. Unless it's a real problem (not only aesthetics) I probably won't (be able to) do much about it.



#40 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 24 June 2016 - 04:16 AM

Just fired it up now for the first time today and it did the same thing and after I closed DR I got a pop up say DR had crashed - which it had not.

 

Every subsequent run of DR is back to normal speed and no error popups.



#41 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 24 June 2016 - 12:12 PM

Next time you run into that crash popup try to record a dump. Even if it is during application shutdown causing no harm, these crash reports are very important to me.

 

I've added the double-click behaviour to the treeviews now.



#42 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 24 June 2016 - 02:48 PM

Will and thanks.

 

here yer go -

 

- mega

 

Attached File  DR_205_ctd.JPG   65.07KB   0 downloads

 

It seems I can make it happen on demand now I just have to shutdown to the PC,  then after it has booted to desktop and I fire up DR it will do the black windows and error popup etc.



#43 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 25 June 2016 - 03:53 AM

Hm, couldn't see anything DR-related in the crashdump, not a single one of the DarkRadiant.exe or its .dll files are mentioned in the dump. Did you save the dump using your Task Manager, or in a different way?

 

(Still, thanks for uploading.)



#44 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 25 June 2016 - 04:19 AM

The next build is up for preview (pre3), adding an AAS File Viewer and the Pan Camera View mouse shortcut.



#45 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 25 June 2016 - 06:20 AM

Hm, couldn't see anything DR-related in the crashdump, not a single one of the DarkRadiant.exe or its .dll files are mentioned in the dump. Did you save the dump using your Task Manager, or in a different way?

After I clicked on the red X, the crash popup came up and I created a dump at that point from the task manager. At a guess it seems to be related to vfspk3.dll, but a google search doesn't reveal much



#46 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 25 June 2016 - 06:26 AM

vfspk3.dll is a DR module manging the virtual filesystem, but strangely enough I couldn't see that module being present in the dump. Maybe it has already been unloaded and the crash happened in another DLL that was loaded in the same DarkRadiant process (often there are shared Windows modules, or mouse drivers, these are loaded by your process and is out of our control). But I'm only speculating here.



#47 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 25 June 2016 - 07:22 AM

Its only been happening in 2.05, is there anything I can do so you see what DR is doing from start to finish..?



#48 greebo

greebo

    Heroic Coder

  • Root
  • 15975 posts

Posted 25 June 2016 - 08:09 AM

Can you have a look at your DarkRadiant.log file in the Roaming user folder? It should say something like this as the very last line in that log file:

 

2016-06-25 14:47:29 (14016) 2016-06-25 14:47:29 Closing log file.

 

If it doesn't say "Closing log file", I'd like to see the whole file.



#49 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 26 June 2016 - 05:19 AM

Morning

 

So I deleted the log file so as to get DR to create a fresh one (see below) but annoyingly DR is behaving itself on startup and close down. So I am gfonna have to wait for it to mis-behave again and then give you another copy of the log.

 

Spoiler


#50 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18643 posts

Posted 26 June 2016 - 05:58 AM

And found another medium bug -

 

Texture inspector windows goes black and can only be fixed by shutting down and restarting DR

  • multi select a bunch of brushes
  • then with them selected, middle click on another surface
  • then press S for surface inspector, to press press natural
  • but then when you go into the texture inspector, the windows is black.

The issue is I can't reproduce it untill it happens once.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users