Jump to content


Photo

Patch For DarkRadiant Compilation (32-bit Slackware)


  • Please log in to reply
1 reply to this topic

#1 NightStalker

NightStalker

    Linux hero

  • Development Role
  • PipPip
  • 156 posts

Posted 02 January 2017 - 08:27 PM

Attached is a simple patch to 'include/irenderable.h' that allows DarkRadiant (both 2.1.0 and the latest code from SourceForge github) to compile under Linux (specifically, 32-bit Slackware 14.2).

With this patch, I was able to compile and run DarkRadiant, but it immediately crashes.  More on that in a separate thread.

Attached File  DarkRadiant-compile-under-Linux.patch.txt   579bytes   3 downloads


Edited by NightStalker, 07 January 2017 - 03:45 PM.

  • Bikerdude likes this

#2 NightStalker

NightStalker

    Linux hero

  • Development Role
  • PipPip
  • 156 posts

Posted 07 January 2017 - 03:43 PM

Just to close the loop on this... With recent changes to the DarkRadiant code in github, it now successfully compiles under 32-bit Slackware 14.2 without the need for the patch attached above. My thanks to greebo for the fix!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users