Jump to content


Photo

Frustrating issues with new DR 2.2.1x64


  • Please log in to reply
7 replies to this topic

#1 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 482 posts

Posted 14 March 2017 - 08:12 AM

Hi,

I've managed to install the latest versions of both TDM and DR from the downloaders from the main page.

However, since doing this there have been nothing but problems in DR (TDM seems to work fine).

When attempting to start work on a new level - something simple as the first brush to start sketching out a building layout, there are many errors thrown the respond in DR hanging and force-killing the process, eg:

[shaders] materials/tdm_epi_shader.mtr: shader transformer_gauge already defined.
[shaders] materials/tdm_epifire_furniture.mtr: shader leather_chair_001 already defined.
[shaders] materials/tdm_stone_natural.mtr: shader textures/darkmod/stone/natural/rough_greyblue01 already defined.
[SoundManager]: SoundShader with name tdm_ai_commander_there_you_are already exists.

[shaders] Unable to load texture: _default

All modules appear successfully loaded and

This happens no matter what texture I use, although some fail harder than others. Not a single one appears in the textures box none appear in the camera view except to say, "shader not found".

The result is that, after the brush is placed and the tdm folder texture is applied to one or more faces (before hollowing), that DR either displays it as "nodraw" or outright crashes.

This is a fresh install of both TDM and DR after hiatus and I'm pretty sure I've not entirely forgotten how to use the kit...

I've even nuked the prefs. file in roaming.

After spending 5-6 hours on trying to figure this out yesterday and another 4 today - I can't sort it...

Is there something very different about this version that I'm missing, or is there an older version with which I am used to using that is available to download for building, etc..?

What is odd is that the few older maps I have kept on an archive drive load up find and work well, except the lighting is missing entirely from all sections...

Any advice as to what I'm missing out or doing wrong here would be greatly appreciated.



Thanks.


 

#2 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 482 posts

Posted 14 March 2017 - 08:20 AM

omfg... I forgot to apply the shader to the brushes and meshes using surface inspector.

Yet it is not playing footsteps on wood surface...

[shaders] Unable to load texture: _default
[shaders] ShaderLibrary: definition not found:

Think I'd better go back to Fidcal's A-Z...

:rolleyes:

#3 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 366 posts

Posted 14 March 2017 - 08:26 AM

Check that you do not have epifire's custom materials in your TDM's directory. In the 2.05 update a fair amount of his models got added in so now you'll be having two different .mtr files defining the same thing, which throws an error.

 

Don't worry about "Unable to load texture: _default", these are arguments that make automatic textures in the material files. _black, _white and _flat produce uniform black, white and normalmap colors, respectively. _default either isn't supported or isn't defined in TDM, yet some .mtr file somewhere still probably refers to it.


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#4 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 482 posts

Posted 14 March 2017 - 11:30 AM

Something's definitely screwey... even made a new partition just for this, no trace of the old versions left.

Is there anywhere I can download a previous version of DR?
Mine seems to have gone walkies...

This new one crashes often and has a lot of red writing appearing when performing simple tasks.
Maybe it's necessary for 2.05 TDM, though?



#5 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8043 posts

Posted 14 March 2017 - 11:35 AM

Older versions are hosted here:

 

http://darkradiant.s...et/download.php

 

AFAIK they should all work with TDM 2.05, you'll just lose newer editing enhancements if you revert to older versions.

As I recall, we had a group of authors who stuck with 1.8.1 because the 2.x versions seemed to cause them problems.


  • teh_saccade likes this
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#6 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 482 posts

Posted 14 March 2017 - 11:53 AM

thanks nbohr1more



#7 stumpy

stumpy

    Advanced Member

  • Member
  • PipPipPip
  • 1675 posts

Posted 15 March 2017 - 06:48 AM

if this is the windows version, then some files get stored in users/<name>/AppData/Roaming/DarkRadiant/



#8 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 482 posts

Posted 22 March 2017 - 11:19 AM

Aye, I cleared that out, Stumpy - thanks:)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users