Jump to content


Photo

really loud music?


  • Please log in to reply
10 replies to this topic

#1 Sneaker

Sneaker

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 27 March 2017 - 01:42 PM

Hello all, I've just played through a few missions for the first time (bundled ones and 3/4 of thief's den series) on version 2.05.  This is a blast!

 

On my system certain music is really loud.  It seems to be the "looping" track music stuff for some reason.  The ambient slider doesn't seem to do anything and the main sfx volume does work but it scales everything down.  I'm currently running it with sfx turned down but it isn't ideal.

 

I noticed it most egregiously in the Chapel Room in Thief's Den 3: Heart of the Lone Salvation.  It is deafening with headphones on.

 

Is this a known issue?  Or only my system? 



#2 Bikerdude

Bikerdude

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 17963 posts

Posted 27 March 2017 - 02:13 PM

hmmm, what OS and sound card are you running..?



#3 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 963 posts

Posted 27 March 2017 - 02:58 PM

Maybe this is related to the problem described by Gerberox here (post #9)? Although, I believe it was not resolved...



#4 Sneaker

Sneaker

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 27 March 2017 - 07:24 PM

This is an older pc... I'm on linux (fedora 24) and onboard realtek ALC662 "6-Channel" HD Audio.

 

I gave a shot at looking in the pk4 and found the sound file for the chapel: "gregorian03_loop" and set the "s_volume" down to "-10" from "33" just to see what would happen...   I didn't notice any difference at all, but I don't know what I'm doing. :)

 

I did notice that lowering ambient volume to 0 does lower the volume a bit, but it's not zero... and, afaict, didn't affect the chapel music at all.



#5 Sneaker

Sneaker

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 27 March 2017 - 07:55 PM

After a few more tests, the ambient volume slider does seem to work.  It's just only for some "sounds/music" but not others, which is what probably confused me.  I haven't found a way to reduce the chapel music which is quite jarring.



#6 freyk

freyk

    Member

  • Member
  • PipPip
  • 383 posts

Posted 27 March 2017 - 11:37 PM

Can you make a log and post its content in a spoiler?

Edited by freyk, 27 March 2017 - 11:38 PM.


#7 Sneaker

Sneaker

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 28 March 2017 - 05:08 PM

no problem. 

Spoiler



#8 demagogue

demagogue

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 5124 posts

Posted 29 March 2017 - 05:57 AM

0 means native volume.
Negative numbers decrease vol.
The falloff is decibles (log scale), so every 10 is like half the previous volume. -60 is off.
Positive numbers very quickly break the system. 33 would be like standing under a rocket launch (basically native volume cubed), so it gave up. Never use positive numbers, except maybe 1-4.

The slider applies to the location system, but I don't think to speakers.
An early confusion on my part led to bad tutorial info that led to early FMs using positive values that was later corrected.

I think that's most of the relevant info, that I know anyway. Not sure it helps or not.
Posted Image

#9 freyk

freyk

    Member

  • Member
  • PipPip
  • 383 posts

Posted 29 March 2017 - 08:58 AM

when i look at the tdm log and hear your complaints, i think its a driver issue.
I found on google several issues combining doom 3 and the brand of the onboard audiocard.

Edited by freyk, 29 March 2017 - 09:00 AM.


#10 Sneaker

Sneaker

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 30 March 2017 - 08:02 PM

The slider applies to the location system, but I don't think to speakers.
An early confusion on my part led to bad tutorial info that led to early FMs using positive values that was later corrected.

I think that's most of the relevant info, that I know anyway. Not sure it helps or not.

 

Got it.  Thank you.  This is very helpful.

 

I found out that loading a saved game overrides the maps original values, so the s_volume changes I made weren't taking.  *slaps forehead*

 

A lot of the s_volumes in heart are set to positive values and chapel, as said, is way up at 33, and does use the classname "speaker".  Setting it to -10 worked once I restarted the map.... much better.  So I guess this is just incorrect values being set in the map itself.  I'm assuming I'm hitting the same issue in other maps as I'm playing through some older content first.  thanks!



#11 Lex

Lex

    Member

  • Member
  • PipPip
  • 29 posts

Posted Today, 12:41 PM

I have similar problem. I play using 5.1 sound and everything is fine except the LFE channel (subwoofer). It's extremely loud (while playing music) comparing to not only other in-game sounds but comparing to other games as well.

Lowering the ambient slider doesn't help much as it lowers the music yes, but LFE channel appears so strong that it still outstands. Only if I set the ambient slider close to 0 it's ok, but I hear no music at all. I don't want to play without music as it would hurt the atmosphere.

Oh, I can of course control the subwoofer volume on the device itself (physically, I mean), but it's just strange that I play all games and watch movies with it set to 100% and playing the Dark Mod I have to set it to around 33%. Not to mention that it's tiresome to set it back and forth every time I play.

What I ask is - is there a way to configure somehow multichannel output for the game? See what's in charge for the LFE channel's strength? How does the game decide to make it so strong?


Edited by Lex, Today, 12:41 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users