Jump to content


Photo

Skin problem

skins texturing

10 replies to this topic

#1 charisma

charisma

    Member

  • Member
  • PipPip
  • 30 posts

Posted 29 March 2017 - 01:44 PM

Hello everyone.

 

I recently started to make my own map and it seems I encountered a problem that I can't solve on my own. :blush:

 

I made a skin for a default model (it is an outdoor sign with chains). I used the wood texture that also comes with TDM. The skin looks as it should be in the 'Choose Skin' window, but in-game it is completely black. Does it have something to do with the vertex colours? Or is it because the default model uses two textures? (one for chains and another - for the shield itself)

 

Here's my *.skin file:

//shield shape//

skin sign_shield_lucky_leaf
{
model models/darkmod/decorative/signs/sign_shieldshape01.lwo

tdm_sign_shield01 textures/darkmod/wood/boards/pier_platform
}

  • Anderson likes this

#2 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36585 posts

Posted 29 March 2017 - 01:55 PM

The skin entry looks fine.  Are you using the default textures/darkmod/wood/boards/pier_platform entry, or did you make your own?



#3 charisma

charisma

    Member

  • Member
  • PipPip
  • 30 posts

Posted 29 March 2017 - 02:12 PM

It's the default one



#4 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1303 posts

Posted 29 March 2017 - 03:44 PM

Edit: Made a mistake, please delete


Edited by Destined, 29 March 2017 - 03:49 PM.


#5 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36585 posts

Posted 29 March 2017 - 03:49 PM

Skin files work fine for models.  That's what they're for.



#6 stumpy

stumpy

    Advanced Member

  • Member
  • PipPipPip
  • 1680 posts

Posted 29 March 2017 - 10:20 PM

the texture needs to be the dds version, the tga versions don't work on props. it uses the dds folder structure else it cant find the texture and displays it as a black image.

 

if you want to verify it then the city watch shield skin points to a jpg file  for the editor and a dds file for the skin and hence the model, there is no tga version of the city watch shield texture.



#7 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36585 posts

Posted 30 March 2017 - 07:28 AM

the texture needs to be the dds version, the tga versions don't work on props. it uses the dds folder structure else it cant find the texture and displays it as a black image.

 

 

 

Where did you get this information from?  All our textures were .tga at one point and they worked fine.

 

 

charisma, if you want to bundle the relevant files together I'll take a look.  Since it works in DR but not in TDM, I suspect it's where you've put the skin file.  



#8 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18941 posts

Posted 30 March 2017 - 08:58 AM

charisma, if you want to bundle the relevant files together I'll take a look.  Since it works in DR but not in TDM, I suspect it's where you've put the skin file.  

or the skin def has a typo.



#9 charisma

charisma

    Member

  • Member
  • PipPip
  • 30 posts

Posted 30 March 2017 - 09:19 AM

Weird. It works when I'm saving the default texture as *.tga! :blink: I'm confused


Edited by charisma, 30 March 2017 - 09:20 AM.


#10 stumpy

stumpy

    Advanced Member

  • Member
  • PipPipPip
  • 1680 posts

Posted 30 March 2017 - 12:44 PM

I looked in the pk4 files and tried to find the tga versions of some textures that are used on models and just could not find them, I only found the _ed.jpg version for darkradiant and the .dds files for the models.



#11 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36585 posts

Posted 30 March 2017 - 01:15 PM

I looked in the pk4 files and tried to find the tga versions of some textures that are used on models and just could not find them, I only found the _ed.jpg version for darkradiant and the .dds files for the models.

 

 

 

We replaced most of the .tga files (at least for diffuse and specular stages) because .dds files are smaller than .tga.  It has nothing to do with them not working on models.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users