Jump to content


Photo

SVN: Problem with textures/glass/dull_opaque01 and skybox


  • Please log in to reply
66 replies to this topic

#26 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 03 May 2017 - 01:14 PM

Hmm.

 

Simple ambient just uses RGB vertex color arguments in the material.

 

http://bugs.thedarkm...iew.php?id=4498 ?

{
                if (global5 == 1)
                blend add
                map                             textures/darkmod/your_file_folder/your_texture_name
                scale                   1, 1
                red                             global2
                green                   global3
                blue                    global4
        }

Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#27 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 03 May 2017 - 01:22 PM

My bad.

Simple ambient does not work on Intel either.



#28 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 03 May 2017 - 03:16 PM

Tried glprocs one by one until replacing texcoord with attrib[8] in heatHaze.vfp fixed the waves.


  • AluminumHaste and nbohr1more like this

#29 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 10:13 AM

@Grayman: Test revison 6909 and see if it's fixed (not home to test right now).
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#30 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 10:59 AM

@Grayman: Test revison 6909 and see if it's fixed (not home to test right now).

 

Both the skybox and the glass were fixed on May 3rd. I assume further changes were made that needed testing, but 6909 shows that the problem remains fixed.



#31 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 11:02 AM

Thanks!

I noticed that the Hourglass texture (and other glass) was too bright in SVN builds and that it uses a texgen
along with explicit GL blend operations. Duzenko pushed a fix in the last commit. Does the hourglass match v2.05 now?
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#32 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 11:23 AM

I noticed that the Hourglass texture (and other glass) was too bright in SVN builds and that it uses a texgen
along with explicit GL blend operations. Duzenko pushed a fix in the last commit. Does the hourglass match v2.05 now?

 

No.

 

The SVN version is too bright.

 

2.05, in darkness:

 

Attached File  hourglass205dark.jpg   64.25KB   0 downloads

 

2.05, lit up:

 

Attached File  hourglass205light.jpg   122.53KB   0 downloads

 

SVN: in darkness:

 

Attached File  hourglassSVNdark.jpg   71.33KB   0 downloads

 

SVN: lit up:

 

Attached File  hourglassSVNlight.jpg   109.64KB   0 downloads

 

I didn't alter the brightness of these pics in Photoshop.


  • nbohr1more likes this

#33 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 11:28 AM

Alright. More work to do (or revert...)

To be sure, you updated your darkmod folder too?

(new glprogs may be needed).
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#34 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 12:48 PM

To be sure, you updated your darkmod folder too?


Yup
  • nbohr1more likes this

#35 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 23 May 2017 - 01:19 PM

Where are these screenshots from?

Here's how it looks for me in TD2

 

Attached Files


  • nbohr1more likes this

#36 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 01:23 PM

@Grayman, did you build new executables at rev 6909 or are you using the current SVN files?
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#37 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 01:30 PM

Another mission to look at is Lords & Legacy.

The transparent windows in the opening poor section of town are now a mix of things: okay, rainbow-colored, bright blue, etc. A good example is where the open window where the female is wandering around is clear, but the closed window on the other side of the door from it is blue.

Go to the central part of the map where the guard station is and look at the surrounding transparent windows. They're all black.

Lots of problems in this map.



#38 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 01:33 PM

Where are these screenshots from?

Here's how it looks for me in TD2

 

 

TD2?

 

My screenshots are from my current WIP. I just dropped the hourglass (models/darkmod/decorative/hourglass.ase) into it in two locations.

 

@Grayman, did you build new executables at rev 6909 or are you using the current SVN files?

 

I rebuilt from 6909.

 

The darkmod assets are at 14822.



#39 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 01:41 PM

TD2?


Thief's Den 2: Chalice of Kings
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#40 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 23 May 2017 - 02:02 PM

Another mission to look at is Lords & Legacy.

The transparent windows in the opening poor section of town are now a mix of things: okay, rainbow-colored, bright blue, etc. A good example is where the open window where the female is wandering around is clear, but the closed window on the other side of the door from it is blue.

Go to the central part of the map where the guard station is and look at the surrounding transparent windows. They're all black.

Lots of problems in this map.

I can't repeat any of this.

Can I ask for darkmod.cfg and savegame?



#41 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 23 May 2017 - 03:03 PM

Can I ask for darkmod.cfg and savegame?

 

Let's start at the start.

 

Savegame.

 

When the savegame loads, there are 3 colored windows above you. (See the quicksave image.)

 

There's another one behind you.



#42 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 23 May 2017 - 08:54 PM

There is no sense or logic to this.

 

The glass crown pedestal is fixed now but the hourglass is still broken in TD2.

 

@Duzenko, is environment.vfp the only shader that was updated?


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#43 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 24 May 2017 - 01:51 AM

There is no sense or logic to this.

 

The glass crown pedestal is fixed now but the hourglass is still broken in TD2.

 

@Duzenko, is environment.vfp the only shader that was updated?

Maybe bumpyEnvironment.vfp needs the same fix. I will look.

Or maybe it's simple vs. enhanced ambient.



#44 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 24 May 2017 - 06:18 AM

What is the material for that window? It can't be just textures/darkmod/glass/clear_warp, there must be something else



#45 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 24 May 2017 - 06:42 AM

I think the problem is the material textures/darkmod/window/pebbly_glass_noframe01_lit.

It's used on the window and is lit by design.

...

Or is the unlit windows on the other wall?

Here's how it looks to me, with your .cfg:

 

@nbohr1more, does it happen for you too?

@grayman, what is your system config?

Attached Files



#46 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 24 May 2017 - 07:25 AM

I'll test when I get home tonight.
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#47 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 24 May 2017 - 12:46 PM

I tried on work AMD and home intel - both look ok to me :blush:



#48 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8170 posts

Posted 24 May 2017 - 12:51 PM

Not sure if it'll be workable but perhaps a vendor check and alternate glprogs for nvidia?


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#49 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 900 posts

Posted 24 May 2017 - 12:55 PM

Not sure if it'll be workable but perhaps a vendor check and alternate glprogs for nvidia?

We still don't know if it's a vendor issue.



#50 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12075 posts

Posted 24 May 2017 - 01:02 PM

@grayman, what is your system config?

 

Windows 7

NVIDIA GeForce GTX 960






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users