Jump to content


Photo

3D artist wants to help


  • Please log in to reply
31 replies to this topic

#26 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18924 posts

Posted 03 August 2017 - 08:43 AM

So had a look at this for Momoderator -

  1. material defs had typos and were missing some info, \ instead of / etc. So I created a single def with the correct info and changed a few things.
  2. some typo's in the textures names, spec but had specular in the material def. and normal instead of local.
  3. missing the qer_editorimage in material defs and image files.
  4. I changed the texture paths in the .ASE file to match the changes I made.

So I created a model in DR and used your textures and its appears fine in-game so that would indicate there is an issue with the exporeting process. I see your using ASCII export 2.51, I dont know if there is an issue with this.

 

@Attached log as per Springs post above -

 

 

Attached Files


Edited by Bikerdude, 03 August 2017 - 08:49 AM.


#27 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 669 posts

Posted 03 August 2017 - 08:46 AM

You don't have to convert your model to tris for .ase, in fact you can even leave all stack modifiers without converting poly to mesh. At least 3dsmax exporter is fine with this.

#28 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36580 posts

Posted 03 August 2017 - 10:25 AM

If the export process does it automatically, that's fine.  But the engine won't display an untriangulated mesh.  That's the only thing I've encountered before that would explain a model that can be loaded but not displayed.

 

86 contained polygons removed

 

 

That's the only unusual thing I see in the condump.


  • Bikerdude likes this

#29 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18924 posts

Posted 03 August 2017 - 11:13 AM

@Springheel.

 

I have corrected and re-jigged his test FM fpor him/her, for the correct paths, naming convention and such.

 

This will enable him/her to learn our naming conventions & standard paths, before doing a test export of an .LWO model instead.



#30 Momoderator

Momoderator

    Member

  • Member
  • PipPip
  • 21 posts

Posted 03 August 2017 - 11:26 AM

So I guess it really is something wrong with my mesh then. I made a simple cube with a simple texture all inside 3DS Max and exported it, and it worked fine.

 

EDIT: Huzzah, I somehow fixed all the crates! The first 2 times I imported my crates in Max and then exported to ase didn't work, but now on the third try, it worked. Thank you very much for all your help! I guess it was all the Blender plugin's fault...

 

Anyway, now that I'm relatively familiar with the whole process, I want to get to work. What models are needed currently?


Edited by Momoderator, 03 August 2017 - 02:09 PM.


#31 Momoderator

Momoderator

    Member

  • Member
  • PipPip
  • 21 posts

Posted 04 August 2017 - 01:49 AM

Is there an SVN for the game assets? There seems to be one for the source code, but that's it.


Edited by Momoderator, 04 August 2017 - 02:00 AM.


#32 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18924 posts

Posted 04 August 2017 - 04:56 AM

Anyway, now that I'm relatively familiar with the whole process, I want to get to work. What models are needed currently?

Drop New horizon/Grayman a Pm for read-only permission to our SVN repo, you can then have a look through what we have atm and come up with suggestions.


Edited by Bikerdude, 04 August 2017 - 04:56 AM.

  • Momoderator likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users