Jump to content


Photo

Beta Testing 2.06


  • This topic is locked This topic is locked
1031 replies to this topic

#51 lowenz

lowenz

    Advanced Member

  • Member
  • PipPipPip
  • 1799 posts

Posted 09 November 2017 - 07:19 PM

Uhm, searching for references in "ExtLibs" I see that Soft OpenAL is already present in  the packaged DLL.

So the "default" is this (Soft OpenAL+Windows default/chosen audio device) ?

Up :P


Edited by lowenz, 09 November 2017 - 07:19 PM.

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.


#52 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 943 posts

Posted 09 November 2017 - 09:41 PM

Uhm, searching for references in "ExtLibs" I see that Soft OpenAL is already present in  the packaged DLL.

So the "default" is this (Soft OpenAL+Windows default/chosen audio device) ?

I believe there is no way to use anything but embedded software renderer of OpenAL, and I guess it is good because it avoids any hardware issues.

 

As for devices, the default one chosen by OpenAL is usually used.

You can change device by setting its name to "s_device" CVar (see the beginning of console for OpenAL messages), although on my installation the reported names are very long and contain undisplayable russian letters, which makes it completely impossible to specify their names. If you successfully set the name of a device to s_device, then you should see "(ACTIVE)" near that device in console.

 

Could you explain what is the benefit of being able to choose another device?



#53 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8865 posts

Posted 09 November 2017 - 11:49 PM

Disabling AA in-game fixes it provided I entirely restart the program afterwards.
 
My GPU is an integrated Radeon HD 8400 and the only settings I can find in the 'AMD VISION Engine Control Center' deal with stuff like power usage.


I went back to look at this. It seems that AMD does offer APU drivers:

http://www.amd.com/e.../game/downloads

"Latest AMD Drivers for the Radeon HD 8000 – HD 8400, HD 7000 – HD 7600, HD 6000, and HD 5000 Series"
 

Windows 10 32-bit Driver

Windows 10 64-bit Driver

Windows 8.1 32-bit Driver

Windows 8.1 64-bit Driver

Windows 7 32-bit Driver

Windows 7 64-bit Driver

RHEL 32 Bit

RHEL 64 Bit

Ubuntu 32 Bit

Ubuntu 64 Bit

Linux (32/64 Bit)

 

Have you tried this driver?

 

If you get this working, AMD's version of FXAA is MLAA or "Morphalogical AA"


  • VanishedOne likes this
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#54 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19971 posts

Posted 10 November 2017 - 03:37 AM

This is weird, r_showportals dosent appear to be working.


  • stgatilov likes this

#55 lowenz

lowenz

    Advanced Member

  • Member
  • PipPipPip
  • 1799 posts

Posted 10 November 2017 - 05:18 AM

I believe there is no way to use anything but embedded software renderer of OpenAL, and I guess it is good because it avoids any hardware issues.

 

As for devices, the default one chosen by OpenAL is usually used.

You can change device by setting its name to "s_device" CVar (see the beginning of console for OpenAL messages), although on my installation the reported names are very long and contain undisplayable russian letters, which makes it completely impossible to specify their names. If you successfully set the name of a device to s_device, then you should see "(ACTIVE)" near that device in console.

 

Could you explain what is the benefit of being able to choose another device?

Not the device, the driver!

But tipically in OpenAL setup you must choose the couple driver+device.

 

Soft OpenAL is an excellent choice (the best), so I must worry no more :P


  • stgatilov likes this

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.


#56 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 37245 posts

Posted 10 November 2017 - 08:33 AM

Anyone using 5.1 sound?  Mine is broken in 2.06 but I haven't had anyone else confirm this yet:  http://bugs.thedarkm...iew.php?id=4629


TDM Missions:   A Score to Settle   *   A Reputation to Uphold   *   A New Job   *    A Matter of Hours
 
Video Series:   Springheel's Modules   *   Speedbuild Challenge   *   New Mappers Workshop  *   Building Traps

#57 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19971 posts

Posted 10 November 2017 - 09:03 AM

Anyone using 5.1 sound?  Mine is broken in 2.06 but I haven't had anyone else confirm this yet:  http://bugs.thedarkm...iew.php?id=4629

I am and will test



#58 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 466 posts

Posted 10 November 2017 - 09:05 AM

I can second most all cubic light related issues VanishedOne has mentioned, they're borked on the temporary glprog files, I am also getting materials with cubemap stages not interacting with their normalmaps. I'll hold off on doing in-depth stress testing until something more stable comes along.

 

I get an on-mission-load crash in one of my WIPs every time, I've narrowed it down to Multicore Enhancement being on.

EDIT: I also get a guaranteed crash every time I dmap/testmap while in-game. I can load a map but I have to escape to the menu in order for it to work without crashing. I experienced rare crashes when switching between maps from the console in 2.05, this seems to have increased.

 

@greyman Please fix the following materials that were released in 2.05 with bad definitions:

 

textures/darkmod/stone/brick/red_sloppymortar_01 

 

problem:     "bumpmap            textures/darkmod/stone/brick/red_sloppymortar01_local" =/= "red_sloppymortar_01_local.tga"

 

I see "textures/darkmod/wood/boards/planks_worn_brown" has already been fixed, good. There might've been more textures with bad defs, but I can't remember any right now. Must be paranoid.

 

I also noticed r_softshadowsRadius seems to be capped by the strength cvar. Is that intentional? Might be more flexible if this wasn't the case. More testing shows me the softening is dependant more on player distance rather than light distance to a surface. I suppose that makes sense from a performance standpoint.

 

This is weird, r_showportals dosent appear to be working.

 

It's working on my end. Have you messed with hiding the UI or the rescaling? I haven't, but that may be the problem.


Edited by Spooks, 10 November 2017 - 09:42 AM.

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#59 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19971 posts

Posted 10 November 2017 - 09:14 AM

It's working on my end. Have you messed with hiding the UI or the rescaling? I haven't, but that may be the problem.

Will check.



#60 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 10 November 2017 - 09:22 AM

@greyman Please fix the following materials that were released in 2.05 with bad definitions:

 

textures/darkmod/stone/brick/red_sloppymortar_01 

 

problem:     "bumpmap            textures/darkmod/stone/brick/red_sloppymortar01_local" =/= "red_sloppymortar_01_local.tga"

 

 

 

Where are you seeing this?

 

My expanded 2.05 isn't broken like this, nor is SVN trunk nor is SVN 2.06 branch.



#61 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 466 posts

Posted 10 November 2017 - 09:38 AM

I'm looking it up from DR's media browser (I have set my work environment to my TDM beta test folder) and the freshly downloaded .pk4's (I did a clean 2.06 install). The black wall in this image is supposed to be the texture:

 

O8bbeF2.png


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#62 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 466 posts

Posted 10 November 2017 - 09:59 AM

UI Bug: The up and down arrows for the default briefing GUI don't show, so you cannot scroll the text if it is more than a page.


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#63 VanishedOne

VanishedOne

    Advanced Member

  • Member
  • PipPipPip
  • 819 posts

Posted 10 November 2017 - 11:07 AM

More cubemap trouble. This is Epi's test map from the parallax cubemaps thread:

 

Attached File  206cubemaps.jpg   84.68KB   0 downloads


Some things I'm repeatedly thinking about...

- louder scream when you're dying


#64 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 10 November 2017 - 04:52 PM

I'm looking it up from DR's media browser (I have set my work environment to my TDM beta test folder) and the freshly downloaded .pk4's (I did a clean 2.06 install).

 

 

 

How do you "look it up" from DR's media browser? I have a full install and the shader looks correct.



#65 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 37245 posts

Posted 10 November 2017 - 07:58 PM

textures/darkmod/stone/brick/red_sloppymortar_01 

 

problem:     "bumpmap            textures/darkmod/stone/brick/red_sloppymortar01_local" =/= "red_sloppymortar_01_local.tga"

 

 

The material shader had a typo.  It's now fixed on SVN.


  • Spooks likes this
TDM Missions:   A Score to Settle   *   A Reputation to Uphold   *   A New Job   *    A Matter of Hours
 
Video Series:   Springheel's Modules   *   Speedbuild Challenge   *   New Mappers Workshop  *   Building Traps

#66 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8865 posts

Posted 10 November 2017 - 09:50 PM

@VanishedOne and Spooks:

 

Are some of the cubicLight problems being seen for projected lights?

 

As I recall, only "point lights" were implemented in GLSL. (After much begging...)

We weren't aware of any real compelling use case for projected lights with cubemaps so it

wasn't worth the battle at the time. If you really need projected cubicLights, I'll go back and

argue the case to Duzenko.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#67 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 943 posts

Posted 10 November 2017 - 11:08 PM

I tested out the new briefing video feature, dropped in a .mov into an existing mission setup and it worked perfectly without any further setup required. Very impressed with that! woohoo :)

If you simply replaced .roq-file with .mov-file, then you have not tested the feature completely  :P

 

With some additional setup, you can make TDM play both video and sound from a single video file, and you can make TDM end the cutscene at proper time without specifying length explicitly.

I have just wrote a wiki article about new cinematics.

 

P.S. Also note that .mov file won't play properly from inside .pk4.

We have a whitelist of things which "are not to be compressed", currently it contains only mp4, m4v, avi, and roq.


  • RPGista likes this

#68 demagogue

demagogue

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 5380 posts

Posted 10 November 2017 - 11:58 PM

Issues so far:

- There is no scroll bar for default briefings, and of course the arrows are gone now. Mother Rose was the last FM I saw this, but it was affecting others too.

- The lowest setting of soft shadows turns the lights completely off. I just have the Intel GPU circa late 2015.


Posted Image

#69 lowenz

lowenz

    Advanced Member

  • Member
  • PipPipPip
  • 1799 posts

Posted 11 November 2017 - 05:05 AM

 

The material shader had a typo.  It's now fixed on SVN.

Thanks!

 

So we can have a new packaged glprogs to download? Cause without it the lights can't do anything :P


Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.


#70 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 643 posts

Posted 11 November 2017 - 06:26 AM

For the ones who's stuck updating from 2.05 to 2.06 (when the updater update himself):
read "Windows, 2.05 to 2.06 Upgrade" in the startpost. (because i didnt and got stuck.)

To me, tdm 2.06 works great.
(but got a updater-logfile without a filename (".log") from it)

And maybe change the interface of the tdmupdater-windows a bit:
Add a second percentage bar, to show the final status.
Firstbar shows the final status, second bar to show working status.
Put the status text in a textbox, if people have update/download problems, people can copy the text.
And put another scrollable textbox, to put the advanced log text in it. (because im to lazy to open a txt file)

Edited by freyk, 11 November 2017 - 07:33 AM.


#71 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 11 November 2017 - 07:29 AM

I should note that tdm_update causes some confusion atm. The program changed, but the version number didn't.

 

So if you conclude you don't need to run the updater because it appears to just reinstall the same version, please don't do that. Let the updater update itself.

 

This confusion should be removed in the next package build.



#72 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 11 November 2017 - 07:31 AM

So we can have a new packaged glprogs to download? Cause without it the lights can't do anything :P

 

This problem will be corrected in the next package build.

 

If you can't wait, please see this post.



#73 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 11 November 2017 - 07:35 AM

Put the status text in a textbox, if people have update/download problems, people can copy the text.
 

 

It's prolly been pointed out before, but the updater keeps a log (darkmod/tdm_update.log).

 

Folks can attach the log when asking for help.



#74 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 11 November 2017 - 07:37 AM

Issues so far:

- There is no scroll bar for default briefings, and of course the arrows are gone now. Mother Rose was the last FM I saw this, but it was affecting others too.

- The lowest setting of soft shadows turns the lights completely off. I just have the Intel GPU circa late 2015.

 

Please file bugtracker issues.



#75 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12564 posts

Posted 11 November 2017 - 07:38 AM

@VanishedOne and Spooks:

 

Are some of the cubicLight problems being seen for projected lights?

 

As I recall, only "point lights" were implemented in GLSL. (After much begging...)

We weren't aware of any real compelling use case for projected lights with cubemaps so it

wasn't worth the battle at the time. If you really need projected cubicLights, I'll go back and

argue the case to Duzenko.

 

Please file a bugtracker issue for light problems.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users