Jump to content


Photo

DR 2.4.0 - objects not rotating on origin


  • Please log in to reply
8 replies to this topic

#1 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19166 posts

Posted 18 November 2017 - 07:28 AM

I know there is a button in DR to force object to rotate on thier origin, but even with that selected thing are pinning out into the void when Im trying to do an axis rotate,



#2 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 863 posts

Posted 18 November 2017 - 08:13 AM

Hmm, I have it enabled all the time (Ctrl+R), and it works with both brushes and meshes.



#3 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19166 posts

Posted 18 November 2017 - 02:35 PM

Ok its a bug then, will file a bug tracker.



#4 Obsttorte

Obsttorte

    Scripting guru, Mapper

  • Active Developer
  • PipPipPipPipPip
  • 5375 posts

Posted 18 November 2017 - 02:42 PM

Maybe your installment is corrupted. Did you try to reinstall DR?


FM's: Builder Roads, Old Habits, Old Habits Rebuild
WIP's: Several. Although after playing Thief 4 I really wanna make a city mission.
Mapping and Scripting: Apples and Peaches
Sculptris Models and Tutorials: Obsttortes Models
My wiki articles: Obstipedia
Let's Map TDM YouTube playlist: ObstlerTube
Texture Blending in DR: DR ASE Blend Exporter

End of shameless self promotion.

#5 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19166 posts

Posted 18 November 2017 - 03:02 PM

Will try that also.



#6 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1336 posts

Posted 18 November 2017 - 03:28 PM

Maybe it is the bug Springheel and I have observed sometimes, where deselcting another brush/entity somehow has the former brush still selected while rotating, so it rotates around their shared origin. If the two entities are far apart, it might show the behaviour described by you. Unfortunately, I could not reliably reproduce the error and have no idea what might cause it.



#7 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 249 posts

Posted 19 November 2017 - 03:24 PM

I get the same bug, where I go to rotate a func_static (typically) and the rotate widget ends up somewhere else, sometimes stuck on the last object I had selected. 


Edited by kingsal, 19 November 2017 - 03:24 PM.


#8 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 19166 posts

Posted 19 November 2017 - 04:12 PM

Ok this is defiantly a bug, added the info from this thread -

 

- http://bugs.thedarkm...iew.php?id=4678



#9 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 419 posts

Posted 19 November 2017 - 06:55 PM

It is a bug and it happened in 2.3.0 but I've never been able to figure out the conditions for it to manifest with any sort of consistency. :/


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users