Jump to content


Photo

Having trouble putting readables into my mission`

beginner help readables

No replies to this topic

#1 some1stoleit

some1stoleit

    Member

  • Member
  • PipPip
  • 17 posts

Posted 04 January 2018 - 10:06 AM

I've just started mapping, and using the Sotha videos I've managed to create most of the basic elements of my mission, however, I'm receiving an error when trying to put a readable into my environment. 

 

What I've done so far is spawned a readable entity from the list, and gone to 'Readable Editor' in the Entity submenu, with the readable entity selected. Here I receive an error 'Mod Path not Defined using Base Path', even if I ignore the error and try to write anything on the paper, I receive the same error when attempting to save it and my only option is to cancel. 

 

Can anyone tell me what's going wrong and what I can do to fix it? Whilst I theoretically could finish my mission without readables, I'd obviously like to add them in to provide players clues and flesh out the characters.

 

Edit: I made this thread without realising that there was a newbie question thread where this question was meant to go. I made some progress on my issue but I still can't get the readables to work, I posted this on the question thread

 

So far I've managed to create everything in my mission smoothly, but I can't make readables. I followed the instructions on the wiki and specified custom folder for my xdata files (a folder in my darkmod/map), and I can create a readable in the editor and save the xdata file. However in game I receive the error "Non-Existant xdata declaration: readables/(MyMissionName)/mybook" as well as "num_pages not definined on readable" followed by the entity name, upon loading my mission. Attempting to read or pick up the readable locks up my character making it impossible to change equipment or items. I even poked around my files and opened the xdata file in notepad, and the contents match what I got in the editor and structure itself seems fine.

 

Does anyone know a solution, so far the mapping has been going smoothly and it's quite frustrating to get stuck on readables. I don't technically need them but, they I couldn't make the mission I want without them.

 

 

Sorry for the double post, but any answer would be very much appreciated.

 

Edit: 

 

My issue got solved in the newbie questions thread, so is there anyway this thread can be deleted?


Edited by some1stoleit, 06 January 2018 - 07:57 AM.




Reply to this topic



  



Also tagged with one or more of these keywords: beginner, help, readables

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users