Jump to content


Photo

newbie skybox problem

newbie help

8 replies to this topic

#1 Zen3001

Zen3001

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 16 March 2018 - 05:07 PM

I never used dark radiant before and am currently just trying to get used to it's features.

 

I took a skybox from this site: http://www.custommap...rg/skyboxes.php, named and placed the files properly according to the wiki(http://wiki.thedarkmod.com/index.php?title=Skybox_Tutorial) except I also copied the forward facing texture, put it in textures/skies/custom an renamed it to "nightsky.tga"(this was mention on this thread: https://web.archive....ic.php?t=3571). I can find the the texture in darkradiant but when I create a skybox with it the info_portalsky always ends up leaking.



#2 Obsttorte

Obsttorte

    Scripting guru, Mapper

  • Active Developer
  • PipPipPipPipPip
  • 5579 posts

Posted 16 March 2018 - 06:36 PM

You need a material for it to work.


FM's: Builder Roads, Old Habits, Old Habits Rebuild
WIP's: Several. Although after playing Thief 4 I really wanna make a city mission.
Mapping and Scripting: Apples and Peaches
Sculptris Models and Tutorials: Obsttortes Models
My wiki articles: Obstipedia
Let's Map TDM YouTube playlist: ObstlerTube
Texture Blending in DR: DR ASE Blend Exporter

End of shameless self promotion.

#3 Zen3001

Zen3001

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 17 March 2018 - 10:01 AM

Isn't that the Customskies.mtr I created in the materials folder?

Here's how it looks like:

textures/skies/custom/nightsky
{
      qer_editorimage   textures/skies/custom/nightsky.tga
   noFragment
   noshadows
   nooverlays
   forceOpaque            // so transparent windows can draw on top of it
   {
      blend      add      // so transparent windows can draw on top of it
      cameraCubeMap   env/custom/nightsky
      forceHighQuality
      texgen      skybox
      texgen         wobblesky .0 .0 .0
   }
}

If that's not it I really don't know what you're talking about



#4 HMart

HMart

    Advanced Member

  • Member
  • PipPipPip
  • 634 posts

Posted 20 March 2018 - 02:39 PM

Hum i don't really see anything wrong with your skybox material, personally i don't use the "forceHighQuality" keyword on mine, Doom3 didn't either, could that cause a problem? Btw i know a leak can be caused by this things, geometry not sealing the void, sometimes the hole is really really small and you can't see it, the origin of some entity being outside in the void, even tho the visible object is inside the level, a invisible material (like caulk) used to seal the void but without the forceOpaque keyword and so not really selling the void. 



#5 Zen3001

Zen3001

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 22 March 2018 - 10:40 AM

I decided to try again creating the skybox in the same map(without modifying any of the skybox files) just like i did previously and it randomly just decides to work this time.

the only noticable thing I did was changing the grid size to 8 before creating the skybox material but I'm sure I did that in my previous tries too and I tried making the skybox again with grid siize 2 and it was still working.

 

I guess it really just randomly started to work



#6 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7471 posts

Posted 22 March 2018 - 11:14 AM

I don't suppose it was random. Most likely you had a small leak due to not aligning the brushes correctly, which was fixed when you re-created them with a larger grid size. Leaks are not usually caused by materials, they are caused by having brushes that do not completely seal the interior of the map.



#7 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 1284 posts

Posted 22 March 2018 - 11:22 AM

 

texgen skybox
texgen wobblesky
.0 .0 .0

 

AFAIR, you don't need two texgen declarations. The difference between skybox and wobblesky is that the latter can be rotated to around a given axis (x, y, z). If you don't need to translate your skybox, just use texgen skybox.


Edited by Judith, 22 March 2018 - 11:22 AM.


#8 HMart

HMart

    Advanced Member

  • Member
  • PipPipPip
  • 634 posts

Posted 22 March 2018 - 04:07 PM

I decided to try again creating the skybox in the same map(without modifying any of the skybox files) just like i did previously and it randomly just decides to work this time.

the only noticable thing I did was changing the grid size to 8 before creating the skybox material but I'm sure I did that in my previous tries too and I tried making the skybox again with grid siize 2 and it was still working.

 

I guess it really just randomly started to work

 

No nothing in DR is random, the cause was obviously a geometry leak, when you have a leak and the point file, red line, points to some place that seems to be fine, then it means one of two things, or some entity has its origin on the void or the hole is really tiny and you can't see it, one way to prevent this small holes is to make the brush's that will seal the void at level 8 like you discovered, one way to solve really small leaks is to select all world brush's (no need to select entities for this) bring the grid size to the lowest value 0.125, and click on "snap selection to grid", that way you solve any hole without the geometry moving away from place. 

 

Btw from my experience very thin brush's can also cause light leaking, this means a light in one room shining into the adjacent room through the wall. 


Edited by HMart, 22 March 2018 - 04:11 PM.


#9 Zen3001

Zen3001

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 23 March 2018 - 01:14 PM

i'm sure that the skyboxes were aligned correctly, (if I remember correctly) the pointfile showed me a red line going right trough the middle of a skybox material and not trough any edge, something with the material must have been wrong.

 

and also I tried erasin and recreating the skybox multiple times before in different grid sizes, it only worked when I did it after a 3 days break.





Reply to this topic



  



Also tagged with one or more of these keywords: newbie, help

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users