Jump to content


Photo

Loud electric light sound tones in certain missions

sound loud

  • Please log in to reply
18 replies to this topic

#1 Dinosorceror

Dinosorceror

    Member

  • Member
  • PipPip
  • 10 posts

Posted 26 March 2018 - 12:10 PM

Hello, everyone!  I've done some searches in the forums, and looked in the troubleshooting on the wiki, but there's a problem that's been in Dark Mod for the past version or two that's now prevalent enough for me to log in and report.  Not sure if it's an issue with the Dark Mod itself or just one model of light that someone developed and is using in more and more missions, but it's driving me nuts.  :)

 

In several missions, electric lights are used and the tone the game has them emanate...well, I'm supposing it's supposed to be a soft hum, but instead it's a piercingly loud sine wave kind of tone, like you'd hear if you were taking a hearing aid test.  It's literally deafening compared to the sounds in the rest of the game, and as more and more levels use this light, it's really cutting down on the levels I want to play.  Since no other users seem to be reporting this, I'm wondering if it's because of my particular audio configuration.  I am using EAX (through Creative ALchemy) on Windows 10 on a current Sound Blaster card, so I'm wondering if somehow the EAX processing is making the sound so damn loud.

 

The latest mission that seems to have this sound is "In The Black."  I'm including a screenshot of one of the lamps in question.  This one is in kind of an odd spot on an internal balcony railing, and I can hear it buzzing from well down the hall in another room.  There are other rooms that have several of these lamps as well.

 

Is there any kind of tweaking I can do in the .pk4 files to silence this model of lamp until the issue is resolved?  I really want to be able to play these missions without being deafened.  I'm up for any kind of troubleshooting, or if you'd like me to make a recording from a USB mic of how loud the tone is compared to other sounds in the game to hear exactly what I'm experiencing.

Attached Files


Edited by Dinosorceror, 26 March 2018 - 12:11 PM.


#2 stumpy

stumpy

    Advanced Member

  • Member
  • PipPipPip
  • 1934 posts

Posted 26 March 2018 - 12:53 PM

the lamp doesn't have a default volume setting so they will be playing at the highest volume the sound files were recorded at.

I don't know of a way to alter them without the map maker fixing the volume settings on each light.

so you might have to play with EAX turned off on those maps which have those lights.

 

volume is 60db to - 60db, with 60db being the highest volume and -60db being silent or quiet.



#3 Goldwell

Goldwell

    Team Member

  • Active Developer
  • PipPipPipPip
  • 2502 posts

Posted 26 March 2018 - 03:48 PM

You could probably track down the original sound files, lower the volume or change them completely and then replace the ones in your core TDM folder with those new ones. Provided the maps are using the default settings that will provide a lower level of sound. I know i've always had to turn them down in my missions by quite a bit because I too found them incredibly piercing.


The Accountant
Part 1: Thieves and Heirs | Part 2: New In town

 

Shadows of Northdale Campaign

ACT I | ACT II
 
Stand Alone Missions
Lord Edgar's Bathhouse | Spring Cleaning


#4 HMart

HMart

    Advanced Member

  • Member
  • PipPipPip
  • 821 posts

Posted 27 March 2018 - 08:57 AM

the lamp doesn't have a default volume setting so they will be playing at the highest volume the sound files were recorded at.

I don't know of a way to alter them without the map maker fixing the volume settings on each light.

so you might have to play with EAX turned off on those maps which have those lights.

 

volume is 60db to - 60db, with 60db being the highest volume and -60db being silent or quiet.

 

Never tried it on TDM but on idtech4 you can edit individual sounds in game, this is done with the game running in window mode, for example at 800x600 rz, if you want to save the edit permanently, i assume the map should be out of the PK4 or I think you will not the able to save it or perhaps the editor makes a copy? I don't know, try it, just bring the console down type "editSounds" the sound editor opens and the sound (and for some reason lights) origins become visible, you then can select a sound (green boxes) by getting near them (use noclip if necessary) till it's name shows up and just click action (left mouse button) and edit its properties in the editor, then is just a matter of clicking the save map in the sound editor. 

 

You can also edit the sound shader of that particular sound, but that i don't recommend, first because will change all sounds using that sound shader and second will not work if the map developer, implemented a volume spawnarg in the sound entity, that overrides the volume keyword on the sound shader itself, i'm not sure if this last fact also effects the sounds edited with the sound editor, afaik the sound editor edits the sound entity, not the sound shader it self, so when you change the volume on the sound editor i assume you are changing the volume spawnarg not the volume keyword on the sound shader, but i could be wrong. 

 

Btw Volume zero is the original sound volume! That caused some confusion to me at first. :D 


  • stgatilov and Dead Rat like this

#5 Epifire

Epifire

    Advanced Member

  • Active Developer
  • PipPipPip
  • 576 posts

Posted 28 March 2018 - 10:12 PM

Shouldn't you be able to override it by adjusting the db levels from the sound shader file? That should fix it even if it's only a local file modification. Downside is that you'd have to do that every time you updated, unless it's a mission specific asset. In which case you could just tweak the soundshader and call it a day.


You need a model? Epi does you a model.

 

Toss me a PM I promise I don't bite.

 

 


#6 Bikerdude

Bikerdude

    Member

  • Banned
  • PipPipPipPipPip
  • 20320 posts

Posted 29 March 2018 - 04:06 AM

There is a much simpler solution -

 

"set s_volume on light" "-20"

 

This is part of a bunch of args that can be used on fixed model light entites -

 

"set light_radius on light" "100 100 100"
"set light_radius on flame" "100 100 100"
"set color on light"
"set color on flame"
"set s_volume on flame" "-20"


  • HMart likes this

#7 Dead Rat

Dead Rat

    Member

  • Member
  • PipPip
  • 13 posts

Posted 13 April 2018 - 06:01 AM

I was having this problem too - the crazy intense OOO! from lights in too many missions was making me abandon them as the sound makes me feel physically ill. Pretty sure this could result in actual hearing damage if you were exposed to that sound for too long.

 

But thanks very much to HMart - I followed his editSounds procedure on the console (required exiting from full screen mode) and set the sound of the yellow lights in Full Moon Fever (one of the worst offenders) to -50, saved it, and now they're completely silent. Should work whenever you encounter overly intense noises from lights or other sources.


  • HMart and Dinosorceror like this

#8 Bikerdude

Bikerdude

    Member

  • Banned
  • PipPipPipPipPip
  • 20320 posts

Posted 13 April 2018 - 06:25 AM

Yeah, this has annoyed me as a mapper also. I always apply "set s_volume on flame/light" "-20"



#9 Dinosorceror

Dinosorceror

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 12:54 PM

Hate to be a pest, but I'm still having the issue with the sounds...afraid I don't have any experience with the editors in Dark Mod.  I have used editSounds and noclip to find the source of one of the sounds in the latest mission I'd like to play, "Lords and Legacy", and the yellow box identifies the light as:

 

lights/biground1_streetlamp_4fold_snd

 

I can't seem to find in the sound editor dialogue where that entry is...any help?

 

To take the issue back to the source, am I right in thinking that the reason I hear the tones for certain lights in the game is that the sound files are missing from my install, so it's playing that awful howling default tone?  If so, instead of trying to fix every instance of missing sound files, is there a way to tell Dark Mod to simply play no sound when there's a missing sound?  I understand the value of having an annoying placeholder for a sound that's missing to alert developers, but it would be nice to be able to disable that.

 

Is there a reason these sound files are missing?  Is there a way I can find where these files are and replace them?  Just trying to wrap my head around a problem that I guess hasn't gotten a lot of attention since not a lot of folks care about EAX or have EAX-capable sound cards anymore, but I'd be willing to put in a little bit more effort if someone can point me in the right direction.  Thanks!



#10 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7648 posts

Posted 14 April 2019 - 01:28 PM

To take the issue back to the source, am I right in thinking that the reason I hear the tones for certain lights in the game is that the sound files are missing from my install, so it's playing that awful howling default tone?   

 

That seems unlikely. A missing sound should just not play at all. Doom 3 never had a "default sound" as far as I know, and I can't see why anyone would have added one in TDM unless it was some tool to help mappers find missing sounds (like the deliberately ugly "jorge" texture in Dromed).

 

Never mind, it turns out there is a default sound, as Springheel and other later posts have confirmed.



#11 Dinosorceror

Dinosorceror

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 03:47 PM

That seems unlikely. A missing sound should just not play at all. Doom 3 never had a "default sound" as far as I know, and I can't see why anyone would have added one in TDM unless it was some tool to help mappers find missing sounds (like the deliberately ugly "jorge" texture in Dromed).

 
Well, I was thinking that may be the case, as when I'm in that editSounds screen, a lot of the entries under it play a tone that sounds a lot like the constant tone emitted from the troublesome lights.  

 

I'm attaching a picture of the screenshot of one of the many lights in "Lords & Legacy" that emits the tone, and also a link to a video capture of me in the Sound Editor, clicking on the various sounds in the one section that play the tone.  You can also hear the constant tone of the lights/biground1_streetlamp_4fold_snd lamp in the background, underneath my clicking the sections, as the game is running.  This really leads me to believe my install is missing base package sound files that a lot of these levels that have electric lights in them may be referring to.

 

As a way to test, is there way for me to place dummy sound files in a location inside the level's folder, or inside my base install, to see if I can get them to show up?  Again, still not really familiar with how the innards of Dark Mod works at all, but willing to put in more effort to get this resolved!  DM didn't always have this problem, but couldn't say at what point (OS or DM upgrade) it started happening.

 

Attached File  _temp.jpg   46.99KB   0 downloads

 

http://download.lava...soundeditor.mp4

 



#12 Dinosorceror

Dinosorceror

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 03:51 PM

I was having this problem too - the crazy intense OOO! from lights in too many missions was making me abandon them as the sound makes me feel physically ill. Pretty sure this could result in actual hearing damage if you were exposed to that sound for too long.

 

But thanks very much to HMart - I followed his editSounds procedure on the console (required exiting from full screen mode) and set the sound of the yellow lights in Full Moon Fever (one of the worst offenders) to -50, saved it, and now they're completely silent. Should work whenever you encounter overly intense noises from lights or other sources.

 

I'd especially be interested in hearing more detailed instructions from Dead Rat, as he seems to have had the exact same problem and successfully solved it.  I just wasn't able to follow the instructions, I think I need a little more detail.  I know what the name of the light is that makes the sound, but don't know how to find that in the Sound Editor screen.  The instructions mentioned something about left-clicking on the light in the game window, but most times I try that, the game just freezes when I try to get close to the yellow box and then just left click.



#13 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7648 posts

Posted 15 April 2019 - 04:58 AM

Yes, that is weird. What it sounds like to me actually is a very short loop, only a few samples long, which only contains a few cycles of a waveform and therefore results in a continuous tone with some higher harmonics. I suppose this might happen if a file was truncated and the game is only playing the first part of it rather than the whole file.

 

You could try installing DarkRadiant and seeing if you can locate the problematic sounds in the Sound Chooser, which also has a playback function. This might cast more light on what low-level file is actually giving the sound.



#14 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 37756 posts

Posted 15 April 2019 - 07:41 AM

If so, instead of trying to fix every instance of missing sound files, is there a way to tell Dark Mod to simply play no sound when there's a missing sound?  I understand the value of having an annoying placeholder for a sound that's missing to alert developers, but it would be nice to be able to disable that.

 

 

 

I don't know if that's the cause of your issue, but yes, there is a sound like that and for some reason it got turned on by default for some people in 2.07.  I forget what the cvar is to turn it off at the moment, but do a search for "sound" related posts over the last few months and you should find it.


TDM Missions:   A Score to Settle   *   A Reputation to Uphold   *   A New Job   *    A Matter of Hours
 
Video Series:   Springheel's Modules   *   Speedbuild Challenge   *   New Mappers Workshop  *   Building Traps

#15 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1694 posts

Posted 15 April 2019 - 03:43 PM

Found it here:

http://forums.thedar...und#entry435482



#16 Dinosorceror

Dinosorceror

    Member

  • Member
  • PipPip
  • 10 posts

Posted 15 April 2019 - 10:51 PM

 

I don't know if that's the cause of your issue, but yes, there is a sound like that and for some reason it got turned on by default for some people in 2.07.  I forget what the cvar is to turn it off at the moment, but do a search for "sound" related posts over the last few months and you should find it.

 

Thank you so much, Springheel!  It certainly does seem to be a case of a missing sound file reference, and the game having a default tone to play instead, and although I can see it being a useful development tool, sure was driving me batty!

 

The link to the forum post that Destined found (again, very helpful, thank you!) actually didn't have the correct text of the line to change in darkmod.cfg to fix the issue (unless it changed in some revision).  The link reported:

 

The beep plays on missing sound files if s_playDefaultFile cvar is 1.

 

...but in reality, the line in darkmod.cfg to change is:

 

seta s_playDefaultSound "0"

 

It had been previously set to 1 on my install, and this was causing the default sound replacement tone.  I made the change and tested Lords & Legacy and the tone is gone!  Man, now I have to go through and try and find the dozen or more levels I've been avoiding.  :)  

 

Thanks everyone...I only wish I had remembered to follow up sooner on my original post, because I'm so thankful for everyone's quick responses.  I'm a huge Thief fan, and I've gone as far as watching some of Springheel's videos on level creation, because one of these days I want to pay everyone back by contributing some content, and this is just even more motivation to do so.


  • Springheel and stgatilov like this

#17 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1694 posts

Posted 16 April 2019 - 12:30 AM

Sorry, I wans't clearer. The line "The beep plays on missing sound files if s_playDefaultFile cvar is 1." actually states what you have written: "s_playDefaultSound" is a so called cvar and was found to be set to 1. With the line you provided you set the cvar to 0. Should have cleared that up.



#18 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1722 posts

Posted Yesterday, 04:54 AM

Could someone please write down what the issues turned out to be?

 

Was it only the default sound (s_playDefaultFile) which was loud and annoying?

Or there are some sounds which are too loud?

If there are, which are they?



#19 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1694 posts

Posted Yesterday, 05:57 AM

As far as I understood, the issue was that the default sound for finding empty speaker during play testing was playing. Apparently, the cvar "s_playDefaultFile" that is supposed to be set to 0 was turned to 1 for some installations.


  • stgatilov likes this





Also tagged with one or more of these keywords: sound, loud

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users