Jump to content


Savegame issue after restarting game.

  • Please log in to reply
2 replies to this topic

#1 ERH+


    Advanced Member

  • Member
  • PipPipPip
  • 817 posts

Posted 12 April 2018 - 07:52 AM

I've encountered a big problem with my wip map 'Seed of the Lodestar' - it starts and works without problems, but an error (malloc error 1048576) occurs while loading savegame after restarting TDM.

But - if I start the map from the beginning and then load savegame, it works well.


I've tried deleting whole sections of the map (it have five: the city, sea bottom/surface and ship's exterior, ships interior, arctic wreck, buried ruins) and removing only one section didn't fix the problem, even if entity limits seems to be in the safe zone afterwards. Also removing almost all of model files from /models folder makes fresh load-save work - so it may be related to model complexity. I've tried making all func_static no solid and it didn't help, so its not a collision limit problem.


Here's download link:



#2 Obsttorte


    Scripting guru, Mapper

  • Active Developer
  • PipPipPipPipPip
  • 5823 posts

Posted 12 April 2018 - 03:51 PM

When you say 'restarting TDM', do you mean a restart via pressing the restart button in the options menu or the console respectively or does the error also occour if you close TDM and start the application anew. If it only happens in the first case, I would fairly doubt it has anything to do with model complexity or entity limit. And even in the latter case it is very unlikely.


From my unqualified point of view I would assume that there is an issue with TDM (dangling pointer etc...) which just gets triggered by you mission due to its quantity, but which may also be possible to happen with smaller missions (it may only require more restarts there). I experience odd behaviour or crashes from time to time, too if I keep restarting TDM over and over again (for example when editing in game entities, materials or other stuff which require a restart or reload of certain parts of the engine).


If I am not completely mistaken a malloc error simple means, that the application tries to access memory it isn't allowed to (hence the dangling pointer assumption) or if the system is running out of memory. There are other guys here who probably know better, though.

FM's: Builder Roads, Old Habits, Old Habits Rebuild
WIP's: Several. Although after playing Thief 4 I really wanna make a city mission.
Mapping and Scripting: Apples and Peaches
Sculptris Models and Tutorials: Obsttortes Models
My wiki articles: Obstipedia
Let's Map TDM YouTube playlist: ObstlerTube
Texture Blending in DR: DR ASE Blend Exporter

End of shameless self promotion.

#3 ERH+


    Advanced Member

  • Member
  • PipPipPip
  • 817 posts

Posted 12 April 2018 - 04:11 PM

When I start the TDM, start the mission from the beginning, or start the mission from the beginning and then load a savegame - it works fine. When I close TDM, start it again, and try to load a savegame - I have an error. The mission is pushed to the entity and collision limits, maybe loading mission and all changes written in the save file simultaneously is too much? Can I bypass it in some way (other than "please start the mission and THEN load a save file")?

Edited by ERH+, 12 April 2018 - 04:16 PM.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users