Jump to content


Photo

Run TDM in windowed mode


  • Please log in to reply
12 replies to this topic

#1 Fieldmedic

Fieldmedic

    Advanced Member

  • Member
  • PipPipPip
  • 908 posts

Posted 28 May 2018 - 02:52 PM

How do I run TDM in windowed mode...It won't change when I set Fullscreen to "No"... This is a big deal for me when I map and jump between DarkRadiant and TDM...



#2 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8873 posts

Posted 28 May 2018 - 02:55 PM

r_nvidiaOverride 0

r_useFBO 0
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#3 Fieldmedic

Fieldmedic

    Advanced Member

  • Member
  • PipPipPip
  • 908 posts

Posted 28 May 2018 - 03:07 PM

Ahh, nice...too bad I'll have to switch between the modes to see the nice soft shadows :)

Thanks



#4 Fieldmedic

Fieldmedic

    Advanced Member

  • Member
  • PipPipPip
  • 908 posts

Posted 28 May 2018 - 03:10 PM

As a sidenote, the sounds are still present, even when the game window is unselected...any fixes for this? In 2.05 the game went silent when going back to DarkRadiant so to speak...



#5 Fieldmedic

Fieldmedic

    Advanced Member

  • Member
  • PipPipPip
  • 908 posts

Posted 28 May 2018 - 03:16 PM

I'll just noclip out in the void before switching...



#6 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8873 posts

Posted 28 May 2018 - 03:23 PM

Bind a key to toggle s_noSound:


bind "<preferred key>" "toggle s_noSound 0 1"

in Darkmod.cfg or the console.
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#7 Fieldmedic

Fieldmedic

    Advanced Member

  • Member
  • PipPipPip
  • 908 posts

Posted 28 May 2018 - 03:34 PM

The binding works, but still not muted



#8 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8873 posts

Posted 28 May 2018 - 03:51 PM

Hmm. I guess you could try "s_volume_dB" but the toggle would need to be some positive integer other than 1?
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#9 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 943 posts

Posted 29 May 2018 - 12:17 PM

r_nvidiaOverride 0
r_useFBO 0

Nbohr1more, could you please elaborate which this is necessary? or at least why it helps?

I have TDM running in windowed mode almost always, with FBO, nvidia, soft shadows. Never had any problems.

It is bad that it does not work for someone, especially since we plan to switch to FBO-enabled only in 2.07.

 

As a sidenote, the sounds are still present, even when the game window is unselected...any fixes for this? In 2.05 the game went silent when going back to DarkRadiant so to speak...

I think this is caused by migration to OpenAL.

If you find the new behavior annoying, the best thing would be to post a feature request in bugtracker --- then it can happen by 2.07  ;)


  • Judith likes this

#10 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8873 posts

Posted 29 May 2018 - 12:21 PM

r_useFBO forces "Native Resolution" in win_glimp as I recall.

 

I have no trouble alt-tabbing to the deskop but I think that doing so when the game is fullscreen-sized when windowed is confusing

and may not work as expected if you have Windows 10 "fullscreen optimizations" or DPI behaviors applied.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#11 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 943 posts

Posted 29 May 2018 - 12:21 PM

bind "<preferred key>" "toggle s_noSound 0 1"

Toggling this cvar in-game does not change anything.

I believe it only matters during game startup: if this cvar is disabled, then the whole sound system is not initialized, and there is no way to get any sound afterwards.

 

Toggling volume should work well as a workaround:

toggle s_volume_dB -1000


#12 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1275 posts

Posted 29 May 2018 - 03:00 PM

What is the problem exactly? Alt-enter switches between FS and W for me just fine, with SS and all.



#13 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 943 posts

Posted 31 May 2018 - 12:24 PM

Ok, I can reproduce it on my machine on 2.06 x64 build.

 

I simply set "Fullscreen" to "No", then "Screen Size" to something like "1280x720" and click "Restart Game".

It restarts and shows a properly sized window initially (for half a second), but then it quickly switches back to fullscreen with original resolution.

If I stop the game and then start it freshly, it also does the same: switches to fullscreen.

 

Indeed, the game is alt-tabbable.

But it covers full screen and it is not possible to see it alongside other stuff, e.g. DR.

 

This happens for me only when r_useFBO and antialiasing are both enabled.

When I disable either of them and restart engine, it runs in windowed mode.

The situation is further complicated by the fact that disabling r_useFBO is not easy for NVIDIA user  :D, because he also has to disable soft shadows beforehand (and the only way to guess it is to read the 2.06 release notes :wacko: )

 

Given the mess with configurations which we have in 2.06, I think this is not an urgent issue.

I'm glad that everything works properly and nothing crashes  :laugh:

I suppose that instead of fixing this with introducing yet another hack, we should move steadily to FBO-only renderer with proper multisampling support.

On the other hand, this issue is probably worth tracking anyway.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users