Jump to content


Mouse Binding settings for Aux1 do not work

mouse bindings paste shader settings

  • Please log in to reply
4 replies to this topic

#1 Jesps


    FM Creator

  • Member
  • PipPip
  • 423 posts

Posted 17 June 2018 - 03:14 AM



If I change the setting "Edit" -> "Mouse Settings" -> "Camera View" -> "Paste Shader Natural" to SHIFT + AUX1, I cannot use the Paste Shader Natural functionality.


AUX1 is the button used for 'go back' in browsers. It works in other programs.


It seems to be the same issue for AUX2 ('go forward').

I also tried changing other MMB bindings to AUX1 (Pick Shader, Paste Shader Projected) with the result that they did not work.

Also tried with another mouse, with same result.


If I set it to something else, e.g. shift + right mouse button, it works as expected.


On Windows 10, 64 bit.

DarkRadiant 2.6.0 x64



Attached Files

Edited by Jesps, 17 June 2018 - 03:16 AM.

#2 LDAsh



  • Member
  • PipPip
  • 101 posts

Posted 17 June 2018 - 11:52 PM

This might be worth looking into:-


#3 Jesps


    FM Creator

  • Member
  • PipPip
  • 423 posts

Posted 18 June 2018 - 10:07 AM

Thanks for the suggestion LDAsh.


I have never heard of that program before, so I am not comfortable installing it though. Then I would rather stick to MMB :)


Plus, it is not a question of DarkRadiant being unable to detect the mouse button. It clearly is, since I can change the mapping.

#4 greebo


    Heroic Coder

  • Root
  • 16059 posts

Posted 18 June 2018 - 10:34 PM

I can confirm that problem, it seems there are a few events not handled by the respective windows. Please report this on the bugtracker.

#5 Jesps


    FM Creator

  • Member
  • PipPip
  • 423 posts

Posted 18 June 2018 - 11:22 PM



Also tagged with one or more of these keywords: mouse bindings, paste shader, settings

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users