Jump to content


Photo

Crash when restarting engine in 2.06


  • Please log in to reply
7 replies to this topic

#1 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 25 June 2018 - 11:30 AM

Hey Everyone,

 

I can't figure out whats going on but sometimes when I reloadEngine the game crashes. Its often enough to be annoying. I think it has to do with anytime I reload after I changing values to the renderer or reload textures/ models, but I can't be sure.

 

Anyone else have this? Suggestions?

 2.06 x64. Multicore / uncapped/ soft shadows on. Windows 10.

 



#2 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1797 posts

Posted 25 June 2018 - 02:26 PM

Try to set multi core off for starters.

 

Hey Everyone,

 

I can't figure out whats going on but sometimes when I reloadEngine the game crashes. Its often enough to be annoying. I think it has to do with anytime I reload after I changing values to the renderer or reload textures/ models, but I can't be sure.

 

Anyone else have this? Suggestions?

 2.06 x64. Multicore / uncapped/ soft shadows on. Windows 10.

 



#3 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9096 posts

Posted 25 June 2018 - 03:19 PM

Yes, Multi-Core and r_useFBO (for Soft Shadows) are likely culprits.

We have a bug report open about the latter.

http://bugs.thedarkm...iew.php?id=4697
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#4 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 25 June 2018 - 08:03 PM

Great! Ill try this out. Thanks guys.



#5 Spooks

Spooks

    Advanced Member

  • Member
  • PipPipPip
  • 508 posts

Posted 26 June 2018 - 04:34 PM

I can confirm this, I don't have multi-core on and I am pretty sure I don't have FBO on either because of the warp glass issue. Still get crashes on reloadEngine every time.


My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#6 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 29 June 2018 - 07:34 PM

I can confirm this, I don't have multi-core on and I am pretty sure I don't have FBO on either because of the warp glass issue. Still get crashes on reloadEngine every time.

 

Yeah I am getting in even after turning off multi-core and FBO. Its a bummer.



#7 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1118 posts

Posted 30 June 2018 - 04:23 AM

Is it related to 4697 ?

What about toggling r_skipRender as workaround (described for quickloading here) ?



#8 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 15 July 2018 - 01:33 PM

Yep its related. r_skipRender stills creates a crash for me.

 

As Judith mentioned this is a high priority bug as we are constantly reloading images and the engine itself when adding new files or changing stuff. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users