Jump to content


Photo

Help - Not launching in Full Screen?


  • Please log in to reply
13 replies to this topic

#1 Wallace

Wallace

    Member

  • Member
  • PipPip
  • 72 posts

Posted 07 July 2018 - 06:08 AM

I have the latest version of TDM, but the game launches windowed despite enabling full screen in the options. Any ideas what could be causing this?



#2 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 683 posts

Posted 07 July 2018 - 06:56 AM

--> techsupport.

Dont know.

Please select a low screen resolution, like 800X600, set full screen and restart the game.

Test if it get on full screen. If so, set the screen resolution and aspect ratio to your taste.

 

Which screenresolution and aspect ratio do you want to select?


Edited by freyk, 07 July 2018 - 06:56 AM.


#3 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1632 posts

Posted 07 July 2018 - 09:46 AM

A screenshot might help.

Also, try Alt-Enter.



#4 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1632 posts

Posted 08 July 2018 - 02:49 AM

Also, try to disable AA from the video settings.



#5 Wallace

Wallace

    Member

  • Member
  • PipPip
  • 72 posts

Posted 10 July 2018 - 05:40 AM

Here's some images -

 

https://i.imgur.com/YavETAo.jpg

 

https://i.imgur.com/8D8iWw1.jpg

 

Alt-enter worked but stretches my screen beyond the proper 4:3 aspect ratio.



#6 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1632 posts

Posted 10 July 2018 - 08:08 AM

Try setting the resolution in TDM to be the same as the desktop



#7 Dyger

Dyger

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 13 July 2018 - 01:25 AM

I had the same problem with my 4k. Since all programs became too small for me, I increased Windows' own scaling. TheDarkMod probably can't handle this.

#8 AluminumHaste

AluminumHaste

    Darkmod Contributor

  • Development Role
  • PipPipPipPipPip
  • 6208 posts

Posted 13 July 2018 - 03:25 PM

Here's some images -

 

https://i.imgur.com/YavETAo.jpg

 

https://i.imgur.com/8D8iWw1.jpg

 

Alt-enter worked but stretches my screen beyond the proper 4:3 aspect ratio.

 

1920x1080 isn't 4:3, it's 16:9.

Are you using an onboard intel GPU?

 

If you are, then you'll have to set TDM to use your monitor's native res in fullscreen or it will do what you're seeing. At least, I have this same problem at work on the iGPU.


I always assumed I'd taste like boot leather.

 

#9 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1632 posts

Posted 14 July 2018 - 12:25 AM

I had the same problem with my 4k. Since all programs became too small for me, I increased Windows' own scaling. TheDarkMod probably can't handle this.

It might actually



#10 Wallace

Wallace

    Member

  • Member
  • PipPip
  • 72 posts

Posted 29 August 2018 - 06:17 AM

 

1920x1080 isn't 4:3, it's 16:9.

Are you using an onboard intel GPU?

 

If you are, then you'll have to set TDM to use your monitor's native res in fullscreen or it will do what you're seeing. At least, I have this same problem at work on the iGPU.

 

Im using a GTX 950m - Is there a setting in the GTX control panel that will get around the problem I am having?



#11 AluminumHaste

AluminumHaste

    Darkmod Contributor

  • Development Role
  • PipPipPipPipPip
  • 6208 posts

Posted 29 August 2018 - 07:01 AM

Yeah, under Display -> Adjust Desktop Size and Position->Scaling Mode set to Aspect Ratio

Scaling Performed on GPU

And if you have the option, Application scaling override, set to ON

 

EDIT: And if you can and do have the option, disable Optimus tech. It works okay with DX games, but OpenGL not so much, so it's possible that the laptop is using the intel GPU.


I always assumed I'd taste like boot leather.

 

#12 ChronA

ChronA

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 01 September 2018 - 07:04 AM

I'm having the same problem for a much more frivolous reason.

I have a 3840x2160 (4K) monitor, and really enjoy the extra resolution for day-to-day usage and gaming when possible. However, I usually prioritize maintaining a solid 60 Hz frame rate, and enjoying a game's best graphical flourishes (in that order), over squeezing a pixel-perfect rendering out of my hardware. TDM 2.06 has actually proved to be really fantastic in that respect. The game for the most part looks and runs great in 4K. The only problem factor is the Soft Shadows. My GTX970 can't quite hold 60 fps in 4K with them turned on.

 

Given my priorities, I'd prefer to reduce resolution to 1920x1080 in order to fully enjoy the beautiful lighting. But like the OP said, TDM does not properly respect the full screen option. The Alt-Enter fix "works" but, judging by the frame rate hit, it does so by covertly increasing the game's rendering resolution to match the monitor's native, instead of up-scaling the picture to the proper dimensions.

 

Does anyone have any suggested fixes? Manually changing my display resolution in Windows 10 options, each time I want to play TDM with Soft Shadows, is not my cup of tea.


Edited by ChronA, 01 September 2018 - 07:04 AM.


#13 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1632 posts

Posted 01 September 2018 - 11:40 AM

I'm having the same problem for a much more frivolous reason.

I have a 3840x2160 (4K) monitor, and really enjoy the extra resolution for day-to-day usage and gaming when possible. However, I usually prioritize maintaining a solid 60 Hz frame rate, and enjoying a game's best graphical flourishes (in that order), over squeezing a pixel-perfect rendering out of my hardware. TDM 2.06 has actually proved to be really fantastic in that respect. The game for the most part looks and runs great in 4K. The only problem factor is the Soft Shadows. My GTX970 can't quite hold 60 fps in 4K with them turned on.

 

Given my priorities, I'd prefer to reduce resolution to 1920x1080 in order to fully enjoy the beautiful lighting. But like the OP said, TDM does not properly respect the full screen option. The Alt-Enter fix "works" but, judging by the frame rate hit, it does so by covertly increasing the game's rendering resolution to match the monitor's native, instead of up-scaling the picture to the proper dimensions.

 

Does anyone have any suggested fixes? Manually changing my display resolution in Windows 10 options, each time I want to play TDM with Soft Shadows, is not my cup of tea.

If you have AA on, turn it off. Otherwise, try

r_fboResolution 0.5

in game console.



#14 ChronA

ChronA

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 02 September 2018 - 03:28 PM

Thanks duzenko. Although that tip didn't directly solve my problems, it did lead me to the right documentation.

 

For anyone having similar issues, what ultimately did the trick for me was going to TheDarkMod.exe>Properties>Compatibility > Change_high_DPI_settings > High_DPI_Scaling_Override where I checking the box for "override high dpi scaling behavior" and selecting "application" from the pull down menu.

Prior to this I had also turned off AA in TDM, in favor of forcing AA through the nvidia control panel, and I set r_nvidiaOverride 0 and r_useFBO 0 in the game console. (In case any of those were contributing factors.)

 

Currently I'm running in 1920x1080 fullscreen, on all maxed settings (except AA of course), and getting good performance. I have noticed some minor shadow flickering from turning off FBO, but it's not a big deal. Considering turning off FBO also cleared up a graphical glitch I was getting where some water surfaces had periodic horizontal black lines and extra layer of texture, I consider this a win. Plus it sounds like a lot of these issues will be getting fixes for the next update. So thanks again. ^_^






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users