Jump to content


Photo

AA + other visual problems in 2.06


  • Please log in to reply
38 replies to this topic

#26 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1805 posts

Posted 21 July 2018 - 03:41 AM

 

Please fix visual regressions that happened after Rev 7565

Please try revision 7587



#27 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 15 August 2018 - 02:39 PM

Hi there, I did not want to make another thread so here goes my question - I do have same problems as OT, but I also have some performance issues (just tried Volta 2 and more open spaces are causing frame drops). My rig is i7 3820, 8 GB DDR3 and GTX1080, I am on Win 7 SP. In-game settings - everything cranked to max. Is there anything I should switch off or something? I guess my rig would be enough for max settings. Thank



#28 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1805 posts

Posted 15 August 2018 - 02:54 PM

Hi there, I did not want to make another thread so here goes my question - I do have same problems as OT, but I also have some performance issues (just tried Volta 2 and more open spaces are causing frame drops). My rig is i7 3820, 8 GB DDR3 and GTX1080, I am on Win 7 SP. In-game settings - everything cranked to max. Is there anything I should switch off or something? I guess my rig would be enough for max settings. Thank

Start with less AA and SS



#29 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 15 August 2018 - 11:12 PM

Hi there, I did not want to make another thread so here goes my question - I do have same problems as OT, but I also have some performance issues (just tried Volta 2 and more open spaces are causing frame drops). My rig is i7 3820, 8 GB DDR3 and GTX1080, I am on Win 7 SP. In-game settings - everything cranked to max. Is there anything I should switch off or something? I guess my rig would be enough for max settings. Thank

 

Hmm with your rig you shouldn't be having those kinds of problems. I am working on a new version of Cauldron that might fix some of these issues. 

Could I possible get you to test some things out on your PC? It shouldn't take too long, just want to see if this is a mission problem or a 2.06 problem. 



#30 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 22 August 2018 - 01:36 PM

Okay I will try with less AA and SS. Also, Kingsal, where do I get new version? In-game downloader?

#31 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 22 August 2018 - 03:37 PM

Okay I will try with less AA and SS. Also, Kingsal, where do I get new version? In-game downloader?

 

Yep, Cauldron 2.1 

I dont think 2.1 is in the downloader yet, but you can just grab the .pk4 and put it in your darkmod/fms folder. 



#32 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 24 August 2018 - 07:20 AM

So I tried with less AA, but the performance seems to drop still - right at the start in the small alley, mainly when looking to the left. 



#33 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 1724 posts

Posted 24 August 2018 - 08:45 AM

Did you change anything it your drivers specifically for TDM? More importantly, do you use in-game AA or driver level AA?



#34 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 25 August 2018 - 03:53 AM

Only things I have changed for TDM specifically are - Power Management (maximum performance) and Vertical Sync (adaptive). I have lowered AA to 8x, but it still dips down. Maybe I should try lowering soft shadows next. But the question is - is GTX1080 not powerful enough for TDM? Or are these new graphical features not optimized yet? If you want more info, let me know.



#35 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9101 posts

Posted 25 August 2018 - 04:33 AM

2.06 doesn't have true AA when you enable Soft Shadows. It instead does a sort of SSAA via resolution scaling. Disable in-game AA, set r_fboResolution to 1 then use FXAA in your driver settings. Alternatively, use the VBO beta build at Moddb which does support real AA. See here:

http://wiki.thedarkm...new_in_TDM_2.06
  • stgatilov likes this
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#36 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 1724 posts

Posted 25 August 2018 - 05:34 AM

I play TDM in 1440p i 60 fps on GTX 1060, your card is more than enough IMO. The problem is TDM needs a lot CPU power, rather than GPU. As Nbohr said, disable in-game AA, and force FXAA in your drivers. You might want to switch other options to default too (like Threaded optimizations).



#37 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 25 August 2018 - 03:19 PM

Thanks for the answers and troubleshooting fellow shadow lovers.


  • silverjoel likes this

#38 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 356 posts

Posted 26 August 2018 - 03:40 PM

I get a massive slow down in 2.06 if my screen resolution is not set to the native ratio and im using AA and/or vertical sync. Try disabling vertical sync and AA then try out a few screen resolutions in both windowed and fullscreen. See if that helps.  

 

Are you on a laptop?

GTX1080 should do fine with TDM.



#39 Friendly_Taffer

Friendly_Taffer

    Member

  • Member
  • PipPip
  • 36 posts

Posted 29 August 2018 - 12:52 PM

Desktop PC. Everything works smooth now. Problem was in-game AA.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users