Jump to content


Photo

Current SVN paints nearly black screen


  • Please log in to reply
10 replies to this topic

#1 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 31 August 2018 - 02:42 PM

Using my normal config settings, which worked fine a couple months ago, I'm now getting a nearly dark screen when starting a mission with SVN assets/code.

 

I built the Windows binaries from the current SVN source, so it's up-to-date.

 

The presentation is as if there is no lighting from in-game lights, and ambient is very very low.

 

Anyone else seeing this?

 

SVN is supposed to be kept bug-free, so that folks can work with the latest assets and code.

 

If this isn't already being worked on, could the devs pls take a look at it and bring SVN back to expectations?

 

Thanks.



#2 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9101 posts

Posted 31 August 2018 - 03:56 PM

Sounds like your GPU doesn't like the latest shader?

 

If you invoke reloadGLSLprograms do any errors pop-up?

 

To be clear, you have:

 

r_testARBProgram 1

r_shadows 1

 

set in your config?


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#3 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 31 August 2018 - 04:34 PM

reloadGLSLprograms - no errors

 

The 2 cvars - yes



#4 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9101 posts

Posted 31 August 2018 - 04:38 PM

Yeah, sounds like your driver doesn't like something in there.

 

If you disabled soft shadows and set r_useGLSL 0 does the scene render?


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#5 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 31 August 2018 - 04:48 PM

Soft shadows was already off.

 

cvar change made no difference.



#6 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 31 August 2018 - 05:07 PM

Strange ...

 

After trying to capture in-game screenshots for comparison between 2.06 and SVN, and taking Windows screen captures for comparison, the problem has morphed to:

 

SVN is darker than 2.06, but the "nearly-all-black screen" condition that I saw has changed to a "noticeably darker, but not all-black" condition.

 

Since I invoked SVN by accident while working with my WIP in 2.06, I'm willing to let this go until we get into 2.07 beta and see how other existing missions behave.

 

Perhaps it was some unexplained momentary glitch on my end.



#7 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1805 posts

Posted 01 September 2018 - 01:55 AM

Try higher r_gamma and advanced ambient

#8 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 20281 posts

Posted 01 September 2018 - 06:52 AM

Whats the make/model of your video card Grayman..?



#9 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 12727 posts

Posted 01 September 2018 - 07:16 AM

Whats the make/model of your video card Grayman..?

 

NVIDIA GeForce GTX 960



#10 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9101 posts

Posted 01 September 2018 - 08:34 AM

SVN uses "Soft Gamma" http://forums.thedar...9-soft-r-gamma/

 

which means that it no longer directly controls the monitor.

 

This is meant to fix the longstanding issue of exiting TDM causing the Desktop to have the wrong Gamma (etc)

and other Windows 10 gamma control problems.

 

The unfortunate side effect of the changes is that if you previously had in-game settings cranked down to compensate for your Desktop

settings then you'll have an overly dark screen. We'll probably need to issue a warning about this change.


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#11 AluminumHaste

AluminumHaste

    Darkmod Contributor

  • Development Role
  • PipPipPipPipPip
  • 6222 posts

Posted 01 September 2018 - 11:32 PM

It's working fine for me on windows 7, nvidia 980ti


I always assumed I'd taste like boot leather.

 




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users