Jump to content


Photo

launching DR gets unhanded exception


  • Please log in to reply
3 replies to this topic

#1 joebarnin

joebarnin

    Member

  • Member
  • PipPip
  • 285 posts

Posted 13 March 2019 - 04:42 PM

I just ran into the problem discussed in this older thread: http://forums.thedar...dled-exception/

 

I checked darkradiant.log and it said:

 

2019-03-13 14:19:54 (13600) XMLRegistry: Importing XML file: C:/Users/user/AppData/Roaming/DarkRadiant/filters.xml
2019-03-13 14:19:54 (13600) Unhandled Exception: Unable to load file: C:/Users/user/AppData/Roaming/DarkRadiant/filters.xml
 
I looked at filter.xml and it was an empty document (well, a bunch of spaces). I deleted it and then DR started up fine.
 
So all is well. Attached is the bad 'filters.xml' file, if anyone is interested. Seems like a pretty minor bug.
 

Attached Files



#2 kingsal

kingsal

    Member

  • Member
  • PipPip
  • 374 posts

Posted 27 March 2019 - 09:19 PM

This has happened to me a couple times as well. It can be sort of annoying. Ill fill out a bug report if there isnt one already. 



#3 Epifire

Epifire

    Advanced Member

  • Active Developer
  • PipPipPip
  • 576 posts

Posted 28 March 2019 - 02:37 AM

Yeah last I recall, the general thing I was told was to delete the DR temp folder in AppData and restart. Not sure what causes it myself but I think it's been a persistent (if primarily annoying) bug that's been around for a while.


You need a model? Epi does you a model.

 

Toss me a PM I promise I don't bite.

 

 


#4 joebarnin

joebarnin

    Member

  • Member
  • PipPip
  • 285 posts

Posted 28 March 2019 - 10:39 AM

One of these days when I’m bored I’ll take a look at the code and see if I can find the problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users