Jump to content


Photo

Error: Dependancy is not satisfiable: libboost-filesystem1.34.1


  • Please log in to reply
9 replies to this topic

#1 Taoye

Taoye

    Member

  • Member
  • PipPip
  • 40 posts

Posted 31 August 2008 - 06:50 PM

Hey,

Just downloaded the .deb for the darkradiant 0.9.7, and when I try to install the package it gives me the error that libboost-filesystem1.34.1 is not satisfied.

But I have libboost-filesystem1.34.1 installed... I just reinstalled it and still won't install.

Something up with the package?

#2 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7409 posts

Posted 01 September 2008 - 03:17 AM

What version of Ubuntu are you using? The package is compiled for 8.04, and works fine on my distribution.

#3 Tels

Tels

    Mod hero

  • Member
  • PipPipPipPipPip
  • 15024 posts

Posted 01 September 2008 - 11:49 AM

Hey,

Just downloaded the .deb for the darkradiant 0.9.7, and when I try to install the package it gives me the error that libboost-filesystem1.34.1 is not satisfied.

But I have libboost-filesystem1.34.1 installed... I just reinstalled it and still won't install.

Something up with the package?


Do you have a 64bit version of Ubuntu?
"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

"Remember: If the game lets you do it, it's not cheating." -- Xarax

#4 Taoye

Taoye

    Member

  • Member
  • PipPip
  • 40 posts

Posted 01 September 2008 - 03:18 PM

I'm using Ubuntu 7.10, 32-bit.

That's strange though, that it would think the libboost package is broken just because it's not Hardy?

#5 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7409 posts

Posted 02 September 2008 - 03:40 AM

Dependencies can specify a version, not just a package name. The version from the DarkRadiant DEB I have on this system specifies ">= 1.34.1-2.1", which is presumably newer than what 7.10 is providing.

It's fairly easy to build a DEB package yourself, using a tool such as pbuilder or just using dpkg-buildpackage. However, I recall there may be a problem with compiling with older Boost versions due to the use of newer API calls, but maybe this was fixed.

#6 Taoye

Taoye

    Member

  • Member
  • PipPip
  • 40 posts

Posted 02 September 2008 - 04:34 PM

So I guess it's time to upgrade then!

#7 Tels

Tels

    Mod hero

  • Member
  • PipPipPipPipPip
  • 15024 posts

Posted 02 September 2008 - 04:47 PM

So I guess it's time to upgrade then!


If you can, that should solve it.

I think we could also build a DR package which works back in Ubuntu 7.10, but it would take some time - we presumable need first a VMware container or something with that specific Ubuntu. Both my computers already run 8.04 (and soon 8.10 :)
"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

"Remember: If the game lets you do it, it's not cheating." -- Xarax

#8 Taoye

Taoye

    Member

  • Member
  • PipPip
  • 40 posts

Posted 02 September 2008 - 08:03 PM

Hey, so the upgrade finished and guess what... DR works, so that must be it.

Maybe there should be a note on the darkradiant download site that points out the .DEB was compiled for Ubuntu 8.04 or something to that effect?

#9 greebo

greebo

    Heroic Coder

  • Root
  • 15987 posts

Posted 03 September 2008 - 01:17 AM

I can add a troubleshooting section to the FAQ that deals with the most common installation issues. Either that or we open a troubleshooting section on our wiki and hotlink that from the website.

#10 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7409 posts

Posted 03 September 2008 - 03:47 AM

I can quite easily build DEBs for any version of Ubuntu (within reason, if it's too old stuff won't compile) using PBuilder, the only tweak would be that the version number would have to be something like 0.9.7~dapper1 or 0.9.7~hardy1 in order to distinguish the downloads.

Of course compiling for every version since 6.06 would be quite a lot of work, it might be best to pick a couple of major distributions and use these (maybe the latest release + the previous release, or the latest release + the most recent LTS release).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users