Jump to content
The Dark Mod Forums

Leaderboard


Popular Content

Showing content with the highest reputation on 06/20/20 in Posts

  1. 2 points
    Though I'm not available to debug elevator problems, I can make a suggestion that has nothing to do with moving AI or trying new elevators or moving buttons, etc. Back when St. Lucia was getting a facelift, the guards refused to use the small elevator in the mission. Nothing I did involving the elevator or guards would solve the problem. Then I noticed that pathfinding, which likes to calculate distances and reachability between the centers of AAS clusters, was setting the center of a cluster at the bottom floor of the elevator high up on a worldbrush piece of door trim. Way up off the floor, and denying reachability to that cluster when evaluating a path with an elevator in it. We changed that worldbrush to a func_static, and the cluster center shifted down onto the floor and the guards started using the elevator. So here's my suggestion ... 1. Look at the rooms around each stop of the elevator. Filter out all entities, and allow monsterclip to be displayed. 2. Now examine all horizontal worldbrush surfaces (except the actual floor) and see if you spot any that don't have m/c sitting on them, extending up to the ceiling above. It's surfaces like these that dmap considers reachable by AI, and it will assign AAS areas to them. Cover these surfaces with m/c. (Or if the brush is a piece of trim, convert it to a func_static.) 3. Now make sure that ALL m/c in the room extends up to the ceiling. Otherwise, dmap will consider the tops of those short m/c brushes as walkable surfaces, which you don't want. 4. Dmap and see if the guards start using the elevator. If not, I have no further suggestions. Good luck.
  2. 2 points
    @PranQster, just by way of empathy, we're also having a problem getting AI to use a elevator, under 2.07. This was a new, very tall elevator with just 2 stops. Worked fine for the player. The AI never used it, even in a map that had ONLY the elevator, and its two landings. Still, you might try creating a similar map to shed light on your hypothesis that it's the alternative path that's interfering in your case.
  3. 1 point
    Damn, the same exact thing happened to me and here I was searching the map over and over on how to open that desk :(! Is there any way to get the key by a console command? Also as you certainly would want to fix that, the prisoner is named "Unconcious guard" when carrying him which is probably wrong, and why did you make almost all the food not edible?
  4. 1 point
    If you want to detect visual differences between two sets of cvars, the best thing would be to automatically switch them back and forth every second. Well, if the switching works reliable enough
  5. 1 point
    I just picked it up and played about 2 hours. It's a special game.
  6. 1 point
    Yes. Everyone go play that game! To think when I first started this topic it was because: Now it pretty much won every game of the year award, and deserved every single one.
  7. 1 point
    Ahhh! But of course! I did make changes to the bookshelves, replacing simple shelves with full bookcases. And I have been lazy and right-clicking on models and choosing to surround with m/c. I have not been extending those to the ceiling, though I had when originally making siege. Thank you in advance. I'm sure that's it... about to find out. And thank you after having fixed the problem. I will be much more careful with m/c in the future. Now I can get back to making it look better. This would also explain why AI have sometimes been hesitant to exit the elevator platform.
  8. 1 point
    Interesting. I think I'll delete the new doors and block off the ends of the new hallway with solid brushwork and see if the bottom stop works again.
  9. 1 point
    Injustice: Gods Among Us Ultimate Edition is free on Steam till the 26th.
  10. 1 point
    Ooops, apologies. I'll post the rest in the appropriate thread.
  11. 1 point
    For those of you hating on Epic, this game is now finally on Steam. Do yourselves a favor and just try this masterpiece of an indie game!
  12. 1 point
    Oh, hey I missed this post. OK I'll set one up with bobbing only.There is a value for the timing, not on the top of my head right now. I'll check in a bit.
  13. 1 point
    Annoying bug. There's a subtle dependency of the order in which certain objects get deleted because they can reference each other, but it's so implicit that you basically can't see it in the code. I hope I fixed it, but I can't be 100% certain. Would appreciate it if you could test this executable, and let me know if you do find more crashes: https://ci.appveyor.com/api/buildjobs/q614b4ojrmat3umc/artifacts/TheDarkMod.7z
  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...