Jump to content
The Dark Mod Forums

Bikerdude

Member
  • Content Count

    20134
  • Joined

  • Last visited

  • Days Won

    63

Posts posted by Bikerdude


  1. Found what looks like a typo in a texture material def for "textures/darkmod/stone/sculpted/tiling_1d/trim_marble_grapevine" from - tdm_textures_base01.pk4

    
    textures/darkmod/stone/sculpted/tiling_1d/trim_marble_grapevine
    {
    
        stone
    
        qer_editorimage     textures/darkmod/stone/sculpted/trim_marble_grapevine_ed
        diffusemap          textures/darkmod/stone/sculpted/trim_marble_grapevine
        bumpmap             textures/darkmod/stone/sculpted/trim_marble_grapevine_local
    	specularmap			textures/darkmod/stone/sculpted/trim_marble_grapevine_s
    
        {
            if ( parm11 > 0 )
            blend       gl_dst_color, gl_one
            map         _white
            rgb         0.40 * parm11
        }
        {
            if ( parm11 > 0 )
            blend       add
            map         textures/darkmod/stone/sculpted/trim_lime_longpanel
            rgb         0.15 * parm11
        }
    
    	// TDM Ambient Method Related 
    	{							
    		if (global5 == 1)		
    		blend add				
    		map				textures/darkmod/stone/sculpted/trim_lime_longpanel
    		scale			1, 1		
    		red				global2	
    		green			global3	
    		blue			global4	
    	}							
    	{							
    		if (global5 == 2)		
    		blend add				
    		program	ambientEnvironment.vfp	
    		vertexParm		0		1, 1, 1, 1		// UV Scales for Diffuse and Bump	
    		vertexParm		1		1, 1, 1, 1	// (X,Y) UV Scale for specular		
    		vertexParm		2		global2, global3, global4, 1	
    																
    		fragmentMap		0		cubeMap env/gen1				
    		fragmentMap		1		textures/darkmod/stone/sculpted/trim_marble_grapevine_local			// Bump				
    		fragmentMap		2		textures/darkmod/stone/sculpted/trim_marble_grapevine			// Diffuse			
    		fragmentMap		3		textures/darkmod/stone/sculpted/trim_marble_grapevine_s			// Specular			
    	}
    }
    

    The following line doesent look like they should be in there -

     

    textures/darkmod/stone/sculpted/trim_lime_longpanel

  2. The windows updater is caught in a loop. It finds that the available rev is 2.07, and that the current rev is 2.06.

    I have seen this bahvour in the past, and my work around was -

    • let the updater download the new version, which from memory the file name is ' _tdm_update.exe '
    • I then killed the current tdm_update processed in task manager.
    • then rename _tdm_update.exe to tdm_update.exe and run that

    The update then works as expected.


  3. I have a very odd issue with an elevator, when it reaches a floor (in this case the 3rd) the Ai takes damage and the elevator goes back down without stopping at the floor. The same dosen't happen when the elevator reaches the 2nd floor (its only works on the 2nd floor sometimes under 2.07, other times the Ai take damage), and under 2.06 the elevator can go to the 3rd floor and Ai exits just fine...

    Greyman discovered that my elevator speed was higher than normal and was causing an issue with the physics, so reducing from 50 back down to 30 should fix the issue. Dont know what I was getting away with it under 2.06...


  4. I dont think thats Its not 2.07 related, i think its an issue with that texture - broken normal..? I added that texture a long time ago, but have only recently started seeing that effect, I think exporting as a model removes the issue.

    Confirmed, exported as model fixes it -

     

    post-496-0-09685000-1546121484_thumb.jpg

     

    Didnt you have this same issue a month or so ago on your WIP..?


  5. I have a very odd issue with an elevator, when it reaches a floor (in this case the 3rd) the Ai takes damage and the elevator goes back down without stopping at the floor. The same dosen't happen when the elevator reaches the 2nd floor (its only works on the 2nd floor sometimes under 2.07, other times the Ai take damage), and under 2.06 the elevator can go to the 3rd floor and Ai exits just fine....

     

    Also that link above isnt publicly viewable


  6. BD reported a missing texture last page, I can confirm that too but it's not 2.07 specific, I saw it before the beta.

    I created a new material def from the one for that model that replaces the grill texture with see-through grill texture Springheel created ages ago and it works quite well -

    utility_grate_001
    {
        metal
       
        {blend diffusemap   
        map   textures/darkmod/metal/grate/grate_rusted_mesh
        alphatest .5
        red  .6
        green  .8
        blue  1
        }
    
        bumpmap         textures/darkmod/metal/grate/grate_rusted_mesh_local
    
        {
            if ( parm11 > 0 )
            blend       gl_dst_color, gl_one
            map         _white
            rgb         0.40 * parm11
        }
        {
            if ( parm11 > 0 )
            blend       add
            map         textures/darkmod/metal/grate/grate_rusted_mesh
            rgb         0.15 * parm11
        }
    
    	// TDM Ambient Method Related
    	{
    		if (global5 == 1)
    		blend add
    		map				textures/darkmod/metal/grate/grate_rusted_mesh
    		scale			1, 1
    		red				global2
    		green			global3
    		blue			global4
    	}
    }
    
    • Like 2

  7. Way before the scaling tool was added to DR, the way to reduce the size of a model was to just change the rotation amount. So in this case from 1 0 0 0 1 0 0 0 1 to 0.75 0 0 0 0.75 0 0 0 0.75, but I didnt know the export file type for the scaler tool could be changed before now.


  8. I just had a go at this and for me there were no problems resizing the model in DR. It may be that your scaled models are in a format that causes the error. For me the format is LWO. If your setting is different, maybe DR is having trouble converting from one format to another.

    When you use the scaling tool it exports models to.ASE (or it did in my case).

     

    Sso I manually resized them using the rotation trick (0.75 0 0 0 0.75 0 0 0 0.75) to reduce them in size by 75% and then exported them as .LWO and that did the trick!


  9. Morning

     

    Got another model request, need the following model scaled down to 75% please -

     

    - models/darkmod/architecture/awnings_roofs/awning_cloth_standing.lwo

     

    I tried using the scaling tool in DR but am am seeing weird shadow effects on it - same in 2.06/2.07.


  10. The following model -

    • models/darkmod/mechanical/factory_machines/utility_fan_frame_002.lwo,

    Is missing its mesh/grate texture -

    • utility_grate_001

    Looking at the material def for the grate textures I can see the issue, its empty -

    utility_grate_001
    {
    
    		// 	Mesh used for Epifire's fan 002
    		//	void needs path correction
    
    
    }
    
    

    And the texture utility_grate_001 dosen't look like its present.

×
×
  • Create New...