Jump to content
The Dark Mod Forums

Search the Community

Showing results for 'black screen' in content posted in TDM Tech Support.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. Thanks duzenko. Although that tip didn't directly solve my problems, it did lead me to the right documentation. For anyone having similar issues, what ultimately did the trick for me was going to TheDarkMod.exe>Properties>Compatibility > Change_high_DPI_settings > High_DPI_Scaling_Override where I checking the box for "override high dpi scaling behavior" and selecting "application" from the pull down menu. Prior to this I had also turned off AA in TDM, in favor of forcing AA through the nvidia control panel, and I set r_nvidiaOverride 0 and r_useFBO 0 in the game console. (In cas
  2. Hello! I've been having a host of weird AA/ graphics problems with 2.06. Ill post them here and create bug reports when necessary (sorry if these are redundant in other threads) Windows 10. NVIDIA GeForce GTX 980. (Latest drivers) TDM 2.06 (Both 32 and 64 bit) Problem 1- AA forces fullscreen - While in windowed mode + (advanced render features off / SS/ Post/ect) - If I click AA on, it forces fullscreen mode even after restart. I have to disable AA and then restart to get back into window mode. Problem 2- AA and my skyboxes -While AA is turned on + (forced fullscreen, advanced render f
  3. I unpacked the contents of the zip file to my darkod directory. The main screen works both ways, r_fullscreen 0 or 1. I have successfullystarted the training mission and it looks like this https://we.tl/t-ME5PVgzRWg Abayo.
  4. The OpenGL programmer in me thinks that looks like the underwater effect is supposed to be rendered to an FBO for some post-processing to be applied, but the FBO is not being bound correctly and the render is happening to the screen instead.
  5. So I fiddled with this last night and found that I'm not able to properly validate vsync. It seems that my monitor must automatically do some sort of buffering of it's own. I was not able to get screen tearing no matter how much I punished my FPS and turned off all vsync. It's a crappy little LCD TV that also can be used as a monitor and it has a resolution of 1366 x 768 but it's defacto input resolution is 1080p which it auto-downscales so I'm guessing there's all sorts of funky DSP manipulation to the HDMI input I'm sending it. Going by FPS alone, both r_swapInterval 1 and -1 cap FPS a
  6. Yeah, looks like it. The only things that can be done are: r_finish 1 (super slow but forces correct buffer management) Adaptive Sync: Recent GL drivers implement a new WGL/GLX extension called EXT_swap_control_tear. This extension brings "adaptive vsync" as featured in modern gaming consoles to the PC. Adaptive vsync enables v-blank synchronisation when the frame rate is higher than the sync rate, but disables synchronisation when the frame rate drops below the sync rate. Disabling the synchronisation on low frame rates prevents the common problem where the frame rate syncs to a inte
  7. I dont see any this-problemrelated-errors in the log. Could you create another log using full screen? Set r_fullscreen from 0 to 1 in darkmod.cfg Then run tdm with arguments: thedarkmod.exe +condump pbhallamlog2.txt +quit upload the new log To solve this screen problem, i think you have to change the screenresolution(s) of the game to lower settings. But first you have to detect the screenresolution that works. First set a small screensize in darkmod.cfgChange to following values in darkmod.cfg: seta r_customHeight "600" seta r_customWidth "800" seta r_fullscreen "1" If this works
  8. Goog Evening I just loaded Dark Mod like an hour ago, and got this Problem with the missing Textures or missing dynamic light not shure, and the Smoke being just black squares. And i know there is another thread with about the same Problem, but i have the 2.0 standalone and as far as i understood i dont have to install doom to play this one, so the other thread is not realy helping me either. I tried about every button in my settings and i followed the faq Textures are missing, screen mostly black Look into your darkmod.cfg inside your darkmod folder and check that the following se
  9. according to the inventory script the compass hud model is drawn in its gui window each frame, its probability this that's throwing off the video capture software. would depend on which order the capture software picks up on frame draw order. Although you would think the video capture software would stay on the bigger screen size. Think of all the games that have extra small screen items drawing each frame inside the bigger main screen.
  10. I can't repeat that compass background bug. Please attach your .cfg and if easy a test map or a map name where this plays up. I can see however a compass offset on the screen with r_fboResolution < 0.
  11. Yes. You can go that far. Most folks wouldn't wanna lose bump map altogether but it's an option. If you use regular image_downsize make sure Postprocess is off or the screen will be black.
  12. I have similar issues unless I run TDM in the max resolution of my monitor (1920x1200). My former resolutions of 1440x900 and 1680x1050 both display improperly. The nvidia-settings utility used to have options for how full-screen programs were handled...whether to stretch or center the display with black borders, etc. That seems to have disappeared, so I can't test fixing it with that method. BTW. this has been going on for quite a while now and has nothing to do with TDM 2.0. I think it is mostly to do with changes to X, and not the nvidia driver specifically. I normally would not suggest
  13. Ok, I finally got it to work, but it didn't involve either of the fixes you guys were talking about. First, I would change only these options: Screen Ratio: 16x9 Resolution: 1920x1280 Fullscreen: Yes Are you sure you want exit (Ask every time?) No (in other words, I told it not to ask me every time). Then the next time I started dark mod, black screen. Although I saw the fps counter (which by the way is rather odd in my opinion to have enabled by default..) So I went into my doomconfig.cfg and started changing everything back to default settings. Still black screen. (Weird, huh?) Nex
  14. Edit: of course I mean TDM 2.06. Sorry for messing up the thread title. Some code change in TDM 2.06 seems to have caused a few hickups in the internal downloader. Ever since I upgraded to TDM 2.06, the internal downloader no longer automatically removes the missions I just downloaded. And if you download multiple missions/updates, then some missions will even be displayed multiple times on the list of availlable updates. It looks like the list on the screen doesn't get cleared properly: if you downloaded 3 out of 5 entries then the 2 remaining entries will move to the top, but 3 more 'dea
  15. I would like to add my problems report too! - The new shadows simply dont work at all, they just create fields of black spots. I have an onboard card, so it might just be a compability thingy, old shit n stuff. - The rope arrow is suddenly broken... As soon as i climb on it, it freaks out and lashes itself into the first wall it can find. Unclimbable. Thats all i care for :3 The update brought alot of new performance! And the SFX update really made a huge entrance <3 thx
  16. ... and it works!! only TDM 2.06 now runs with a blank screen. * whoops put it in the old tdm 2.05 directory. Works fine in the right directory. Thanks heaps for the help
  17. Yes, that was just for the test. You can make it 1. One nice thing about TDM's screenshot facility is you can take a s/shot much larger than your screen. The s/shot does a separate render, it doesn't copy directly from your screen. If you choose a huge size, like 16000x9000, you'll see bits of the scene rendered as separate tiles that fit on your screen. Then it all gets put back together again in your resulting file.
  18. SVN uses "Soft Gamma" http://forums.thedarkmod.com/topic/19239-soft-r-gamma/ which means that it no longer directly controls the monitor. This is meant to fix the longstanding issue of exiting TDM causing the Desktop to have the wrong Gamma (etc) and other Windows 10 gamma control problems. The unfortunate side effect of the changes is that if you previously had in-game settings cranked down to compensate for your Desktop settings then you'll have an overly dark screen. We'll probably need to issue a warning about this change.
  19. I'm having the same problem for a much more frivolous reason. I have a 3840x2160 (4K) monitor, and really enjoy the extra resolution for day-to-day usage and gaming when possible. However, I usually prioritize maintaining a solid 60 Hz frame rate, and enjoying a game's best graphical flourishes (in that order), over squeezing a pixel-perfect rendering out of my hardware. TDM 2.06 has actually proved to be really fantastic in that respect. The game for the most part looks and runs great in 4K. The only problem factor is the Soft Shadows. My GTX970 can't quite hold 60 fps in 4K with them turned
  20. Hello everybody, I'm RS-STALKER and I just joined. I have to say what you guys did with this mod is simply amazing, nothing short of brilliant. Every single one of you who worked o this mod is awesome and I simply love it. However I do have some problems and hope some of you guys might help. Some fan missions won't start, I haven't tried all of them but I have run into two fan missions that won't start. One is Alberic's curse where no loading screen comes up, and the mission simply won't start. Another is the mission, Business as usual, the game freezes and crashes every time I try to play t
  21. Kano - This is a fresh install, I have never installed before. Below is an image of what I see after doing freyk's fix. Also below is a screen shot of my video hardware. I bought the laptop in 2011 so It is kind of old, but it seems like it has the right specs for this game. Thanks again guys!
  22. (the screen went black for a few seconds and Dark Mod didn't actually started, just saying, because I don't know if that was supposed to happen) logmysound.txt: http://pastebin.com/XCDPQUxa
  23. It's not just you. I challenge everyone to compare the readability of the top (unselected) line to the bottom (selected) line in this typical mission "purchases" screen: It gets even worse when you're trying to select the screen resolution in the video configuration menu and the current resolution happens to be something other than your LCD monitor's native resolution. White text on a tan background is just a horrible choice.
  24. It would be nice to have sub-titles displayed on the screen for the spoken dialogue in the missions. The man who narrates the first "Training" mission speaks pretty softly, iirc. Or, it's just because the air conditioner next to my room makes a lot of noise. So, to make it easier to know what's going on in certain environments (noisy ones) or where a person has to keep the volume down low for a sleeping spouse (or whatever reason) subtitles for the narration and spoken dialogue in missions would be a nice feature update. Thanks for reading!
  25. Envshot is broken: http://bugs.thedarkmod.com/view.php?id=4868 I created a new bug but I suspect once this is fixed it will also be the fix for 4085 since the screen already includes the skybox we just need all 6 axis back.
×
×
  • Create New...