Jump to content
The Dark Mod Forums

Search the Community

Showing results for 'black screen' in content posted in TDM Tech Support.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. It was easy enough to find the relevant code so I took a first look at this. Here's what I found: On Windows, there's a function to get the current desktop screen resolution and use it on first run. On other platforms that function is a no-op and you end up with an 800x600 resolution by default. Without going into details, this function is called too early in the startup process for it to work on Linux. I've got 2 possible ways to work around this that I'm trying out. The current mode-setting code for choosing a resolution uses the original, old-school X API calls. The
  2. I've actually got the same situation with dual-monitors on my Linux desktop. I was recently reminded that this happens out-of-the-box by wiping settings for the 2.08 beta (where it does still happen). The workaround I've always used is to run it windowed at the full resolution of my monitor. Then (in KDE at least, I'm sure others have similar settings), apply window- or application-specific properties to select a monitor, remove the window border, and disable compositing. This also has the benefit of letting you access your other monitor whenever you open the in-game console. I be
  3. This just started today with my update of SVN to 15737/8388 followed by a rebuild. Some textures (not limited to the door texture shown) are painted black in-game. (Working fine prior to the latest update.) For textures on frobable items, normal highlighting appears when the item is frobbed. For textures on non-frobable items, the texture remains black regardless of distance from the object. Backing away to turn off highlighting paints the texture normally. Anyone else seeing this?
  4. ***SOLVED*** See Steps Quoted in bottom post Hi, I am running Linux Mint 17.1, MATE desktop and compiz. My system (64 bit) has onboard Intel HD3000 video chip. I used the updater downloaded from the site to install the darkmod updater into a darkmod folder in home as per the instructions. I checked and my system does have the ia32-lib installed. The install seemed to go without hitch, on running the updater, files just began appearing in my darkmnod folder. However, when I try to start TDM by doubleclicking thedarkmod.x86, I hear the sounds and can hear my mouse scrolling over options and
  5. duzenko, on 06 Feb 2019 - 3:26 PM, said: Did you try other graphics drivers? https://ark.intel.com/products/71141/Intel-Celeron-Processor-B830-2M-Cache-1-80-GHz- Yes, I have the latest drivers. I tried to force install newer drivers and even Bikerdude tried to help make a hack to let Windows install it but they don't work on this laptop. Which we tried on another issue in this thread: http://forums.thedarkmod.com/topic/19450-fan-missions-stop-loading-and-go-back-to-menu-solved stgatilov, on 06 Feb 2019 - 2:38 PM, said: You said that 32-bit and 64-bit versions behave differentl
  6. I can repeat this BUT black is resolved by quick save\load, i.e. it's only black between map start and first load. Also, I can see the quick save/load adds draw calls and tri count. Is this what you see too? If so, it's probably related to BFG-style area\portal culling changes.
  7. This matches what I’ve been seeing. Consecutive game starts w/o rebuilds might blacken the same textures, or the previously black sections might render normally and new sections turn black.
  8. That's a really poor analogy, since car mirrors are one of the core functionalities of a car. It's more like an FM being shipped with light gem being dark all the time. You seem to be great at dogmatic theories from decades ago, but you're out of touch with modern practice. That's how development works these days, for quite some time now. Project scopes change all the time. Deadlines move, people have to abandon functionalities or settle for less. They leave half-working things in the background, move items to the backlog, so they can work on them when time / client allows. There are s
  9. I updated SVN to see if I could confirm the problem, but when I try running the game all I see is a black screen. I can hear the music and the sounds of the options, but can't see anything, even when trying to pull down the console.
  10. I've a black screen when I start the training mission, I can hear the sounds but no graphics. My system specs are: Pentium IV 1.6 GHz 512 RAM 64 MB Video Card I can run Doom 3 fine, albeit with low settings and a few tweaks on the configs here and there. Were my config tweaks the problem? Or is it because of the fact that TDM doesn't have Quality options? If so, how can I fix this?
  11. I have two screens, one bigger and one smaller. Unfortunately my hardware selects the smaller one as the primary one, which seems to translate over into some full screen applications, which then always run on the smaller screen (which uses DVI, as opposed to the larger screnn which uses HDMI). This is the case for TDM. I have taken a look through the Darkmod.cfg, but there seems to be no way to set a preferred screen or something like that. Is there any way to specify which monitor I want to play TDM on? I've got an NVidia GeForce GTS 250 and am playing on Debian testing. Selecting a primary
  12. Thanks so much for getting back to me regarding this! I was able to grant full permission for the application, however it's still not allowing the installation of maps (both the maps that came downloaded with the game, and the ones that are downloadable via the mission archive). Should I just re-download TDM entirely, following the steps listed on the wiki, or was there another possible solution to try (I checked both my internet access and mirror for the missions, both of which seem fine)? Thanks again for your help with this, freyk! I greatly appreciate it! *Also, here'
  13. Downloaded 2.07 update, neither the x64 launcher nor the normal x32 launcher work. The x64 launcher only gives me a black screen and then goes back to desktop. The usual x32 launcher gets me a black screen with the TDM mouse in the center and nothing more, if I click around the game goes into not responding mode and crashes as well. Tried deleting and redownloading the game but still doesn't work. Is the forum working correctly? Can't upload any files from my game directory, but I can upload the DxDiag file (it says "Error You aren't permitted to upload this kind of a file"). DxDiag_laptop
  14. Playing in several different missions, it seems that black or very dark areas of the screen seem to take on a bluish-gray tinge, and stand out very strongly. This is visible in a variety of places - dark portions of wall near windows or sky; the spaces between cobblestones or other patterns and guards in shadow are especially so. It's less apparent in sections of the screen near my character, and also more apparent on the top half of my monitor than the bottom half. I've fiddled with my ingame brightness and gamma, turned the LOD up and down, recalibrated my monitor's display, and installed
  15. Do you know where to find vcrun2015? It doesn't seem to be among the other components. The video problem (the black screen) remains when I launch the game in windowed mode with low screen resolution. The screen also stays black when I try to start the game using start argument "+set r_customHeight 600 +set r_customWidth 800 +set r_fullscreen 0" I created a log (I think) using your instructions: [game\DarkModGlobals.cpp ( 374):INI (INIT) FR: 0] LogFile created at 2018.10.08 13:37:14[game\DarkModGlobals.cpp ( 377):INI (INIT) FR: 0] Executable last cleaned and rebuilt on May 16 2018 15
  16. Hey guys I just installed TDM for the first time, after seeing it released as a standalone game. I am running Win 8.1 on an older pavilion g7 hp laptop with intel hd graphics and an i3 core. At first the game seemed to work, I was able to get to the main menu and even change the resolution settings. However as soon as I tried restarting the game to make the changes happen, it returned to leave me with a black screen. Just to reiterate: when I start the game now, the screen turns black, the resolution of the screen changes to 640x480 and a few seconds in I can hear the menu music and the scrol
  17. First thanks for providoing such great game! Following the instruction at www.thedarkmod.com/download-the-mod/ I download the tdm_update.linux. It looks ok in updating process because no error message found. When launching the game, the screen becomes blank/ black, but the sound is playing. It looks like texture problems or something from the log below, but I am not sure. How can I fix it? My environment is lenovo t420s with debian testing. TDM 2.02 #5994 linux-x86 Jul 7 2014 11:50:02 found interface lo - loopback found interface eth0:avahi - 169.254.6.228/255.255.0.0 found int
  18. So I just installed Dark Mod for the first time, and the first time I launched it, it was fine except for the fact that it was windowed instead of fullscreen. I changed the resolution to 1920x1080, and I think I changed the option that said "automatically open unlocked doors", and then I quit the Dark Mod so that the resolution changes would take effect. Now, whenever I restart Dark Mod, all I get is a black screen : ( I don't know what in the world is going on.. I even deleted my doomconfig.cfg file out of the darkmod folder because I figured that Dark Mod would just put a default confi
  19. Can someone reproduce this bug? See screenshots - when I have finished a mission, it´s not showing the "finished" mark, even if it is finished, as you can see on the shots. It´s always the same line on screen, where the mission has no "finished" mark. Maybe something to revise in one of the next TDM-updates, if not already known/worked on?
  20. Hey guys, So i have an issue that keeps happening, and after investigating all the logic possibilities, i have not clue what this is about. First, there is a room that all the inside walls appear void when looking from outside of it. When i get inside, the surfaces are rendered, but the place i come from becomes void (black). I removed ALL the visportals from that region. (From outside) (From inside- Lighting adjusted) Second, a wall used by 2 rooms also becomes invisible, but you can see the inside of the rooms from outside. When inside these rooms, everything is just fine. Then aga
  21. Well, I'm wondering if anyone can help me here. Here's the problem: - Installed Doom 3, patched it to 1.3.1.1304 (checked with console), also installed Resurrection of Evil. Note that I can run Doom 3 at pretty high graphics settings without any problems, so I guess I meet the hardware requirements for TDM, too. - Downloaded torrent version of TDM, extracted it into specified directory. Also downloaded some of the missions and put them into the proper directory. - Started up TDM, and at this point it still worked fine. - Chosen to install the Tutorial. The program restarts, but this time I h
  22. When a user run the updater, the developer of the updater inspects the user that uses a stable to internet and tdm mirrors. You could create code to download files from a mirror, change the weight of some mirrors in the the tdm-mirror list. Does the tdm updater for linux, generates screen-output, a tdm-mirror file and tdm-log? If so, check the screen output, content tdm_update.log. And change mirror selection in the tdm-mirrors.txt. (dont forget to use the startup arguments of the updater) My advice is to read the installation manual on the wiki, check my code on my github page
  23. Hi there! I bought a new PC (my old one was from 2001, so there's a lot of new stuff for me now ^^) and just installed TDM, but after starting it the title screen won't show properly. The upper left part of it takes up the whole screen, leaving only the first letters of some of the menu entries on the far right side. I guess this is a resolution problem, but I can't fix it. I already checked the graphic card drivers, tried other Windows resolution (can't change them ingame because I can't see the options menu) and tested various compability modes. The title screen stayed the same. Anyone got
  24. The system is 32 bit Fedora Linux 19 with Xfce, on a laptop that isn't exactly gaming, with intel graphics but the errors aren't related to poor gl implementation from intel. I've downloaded the game from this torrent: https://thepiratebay...torrent/9024163 that I've found on one of threads here. All seems well after download but when I start the game I must go to tty2 and manually ps and kill the process because it's just black screen and music and I can't/didn't find the way to quit it. It's as if all fonts and gui assets are missing. I get hundreds of warnings such as WARNING:Couldn't l
  25. Rather than necro couple year old thread I figured I should just make a new post in case others had the same issue I was and couldn't find an answer. I had the issue a couple months ago when I got Doom3 to try it and decided to give up figuring it was something with Steam version etc. Trying the Stand Alone 2.0 I had the same issue. I was able to launch the game and change game settings (which were muddied) but after I chose to restart the game the screen would be black and could hear the flicking over menu options with the mouse. In order to see the game again I had to delete darkmod.cfg
×
×
  • Create New...