Jump to content
The Dark Mod Forums

Search the Community

Showing results for tags 'oss'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Ever since I first installed TDM on my Linux machine, there has been just one problem that would never let me enjoy the game in peace: The audio system. Sound will either simply not work, work but constantly flicker, or lag behind as the game goes on. Every now and then I had to adjust the sound settings to get better results... and in doing so I got a hang of what the possible configurations are. I decided to share this info here, for others who are struggling with untangling the buggy sound system. In essence: If you are running The Dark Mod on Linux, you have 3 options for sound, each with its own potential set of problems: PulseAudio, ALSA, or OSS. PulseAudioThis is what TDM will try to use by default, when s_driver = "best" and s_alsa_pcm = "default". This is theoretically using ALSA, but the PulseAudio device instead of specifying your own. Sticking with this option should guarantee that the correct audio device is used, but it has one problem: Sound flickers and lags. Solution: The only easy solution is increasing the PA latency for the console you're running TDM in, by modifying an environment variable. Simply run the engine as follows... you can also put this in a TDM.desktop shortcut to do it automatically: "export PULSE_LATENCY_MSEC=60;./thedarkmod.x86". ALSAIf the above doesn't work out for you, the second best option is selecting your ALSA device manually. It should guarantee that there are no sound issues and you get the best playback. The downside is that pointing it to the right audio device can be tricky and might not work at all sometimes. Solution: First make sure that s_driver = "alsa". Then up open bash and type "aplay -l" or "aplay -L" to get a list of your audio devices. Identify the name of the one you wish to use, then set s_alsa_pcm to it. For example, you will want to have something like this: s_alsa_pcm = "front:CARD=Intel,DEV=0". Alternatively you can use device numbers directly, such as "plughw:0,0" or "hw:0,0". Simply using "sysdefault" instead of "default" is also said to have solved the problem for some. You might have to try all of these options and devices until you find the one that works. OSSIf both of the above options fail, OSS is the third path to take. The good part is that it might work at all... the bad part is that it's mostly deprecated nowadays, meaning your distribution might not support it or it can produce sound issues of its own. Therefore this should be considered the last resort. Solution: Set s_driver = "oss" in the settings. You must also run TDM through aoss for audio to work now, so set your TDM.desktop shortcut to: "aoss ./thedarkmod.x86".
×
×
  • Create New...